diff options
Diffstat (limited to 'meta-gnome/recipes-support')
3 files changed, 90 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/usermode/usermode/0001-fix-compile-failure-against-musl-C-library.patch b/meta-gnome/recipes-support/usermode/usermode/0001-fix-compile-failure-against-musl-C-library.patch new file mode 100644 index 000000000..bf19f284c --- /dev/null +++ b/meta-gnome/recipes-support/usermode/usermode/0001-fix-compile-failure-against-musl-C-library.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From c77e3f0d4560797f7dc56549ae5ebcc035714a4d Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Thu, 20 Jul 2017 23:20:53 -0400 | ||
4 | Subject: [PATCH] fix compile failure against musl C library | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
9 | --- | ||
10 | usermount.c | 1 + | ||
11 | 1 file changed, 1 insertion(+) | ||
12 | |||
13 | diff --git a/usermount.c b/usermount.c | ||
14 | index 3aafadd..4107027 100644 | ||
15 | --- a/usermount.c | ||
16 | +++ b/usermount.c | ||
17 | @@ -46,6 +46,7 @@ | ||
18 | #include <limits.h> | ||
19 | #include <locale.h> | ||
20 | #include <mntent.h> | ||
21 | +#include <paths.h> | ||
22 | #include <stdio.h> | ||
23 | #include <stdlib.h> | ||
24 | #include <string.h> | ||
25 | -- | ||
26 | 2.8.1 | ||
27 | |||
diff --git a/meta-gnome/recipes-support/usermode/usermode/0001-formatting-issues.patch b/meta-gnome/recipes-support/usermode/usermode/0001-formatting-issues.patch new file mode 100644 index 000000000..9d512d439 --- /dev/null +++ b/meta-gnome/recipes-support/usermode/usermode/0001-formatting-issues.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 7a316dad0697af2ef4e8079a5af51565a8195aa6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Mon, 24 Jul 2017 01:42:30 -0400 | ||
4 | Subject: [PATCH] userhelper.c: fix formatting issues | ||
5 | |||
6 | Fixed when compile with "-Wformat -Wformat-security -Werror=format-security": | ||
7 | |../usermode-1.111/userhelper.c:585:4: error: format not a string | ||
8 | literal and no format arguments [-Werror=format-security] | ||
9 | | text = g_strdup_printf(dgettext(data->domain, data->banner)); | ||
10 | | ^~~~ | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | |||
14 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
15 | --- | ||
16 | userhelper.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/userhelper.c b/userhelper.c | ||
20 | index 76ad492..ee0da49 100644 | ||
21 | --- a/userhelper.c | ||
22 | +++ b/userhelper.c | ||
23 | @@ -582,7 +582,7 @@ converse_console(int num_msg, const struct pam_message **msg, | ||
24 | |||
25 | if (banner == 0) { | ||
26 | if ((data->banner != NULL) && (data->domain != NULL)) { | ||
27 | - text = g_strdup_printf(dgettext(data->domain, data->banner)); | ||
28 | + text = g_strdup_printf("%s", dgettext(data->domain, data->banner)); | ||
29 | } else { | ||
30 | if ((service != NULL) && (strlen(service) > 0)) { | ||
31 | if (data->fallback_allowed) { | ||
32 | -- | ||
33 | 2.8.1 | ||
34 | |||
diff --git a/meta-gnome/recipes-support/usermode/usermode_1.111.bb b/meta-gnome/recipes-support/usermode/usermode_1.111.bb new file mode 100644 index 000000000..06e400e52 --- /dev/null +++ b/meta-gnome/recipes-support/usermode/usermode_1.111.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "The usermode contains the userhelper program, which can be used to allow configured \ | ||
2 | programs to be run with superuser privileges by ordinary users, and several \ | ||
3 | graphical tools for users: \ | ||
4 | * userinfo allows users to change their finger information. \ | ||
5 | * usermount lets users mount, unmount, and format filesystems. \ | ||
6 | * userpasswd allows users to change their passwords. \ | ||
7 | " | ||
8 | HOMEPAGE = "https://pagure.io/usermode" | ||
9 | LICENSE = "GPLv2+" | ||
10 | DEPENDS = "libuser ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} \ | ||
11 | gtk+ desktop-file-utils-native \ | ||
12 | startup-notification intltool-native \ | ||
13 | util-linux \ | ||
14 | " | ||
15 | |||
16 | SRC_URI = "https://releases.pagure.org/${BPN}/${BPN}-${PV}.tar.xz \ | ||
17 | file://0001-formatting-issues.patch \ | ||
18 | " | ||
19 | SRC_URI[md5sum] = "28ba510fbd8da9f4e86e57d6c31cff29" | ||
20 | SRC_URI[sha256sum] = "3dd0b9639b5bd396b7ea5fada6aaa694dbfdaa3ad06eb95a6eabcdfd02f875c6" | ||
21 | |||
22 | SRC_URI_append_libc-musl = " file://0001-fix-compile-failure-against-musl-C-library.patch" | ||
23 | |||
24 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | ||
25 | |||
26 | inherit autotools gettext pkgconfig | ||
27 | |||
28 | EXTRA_OEMAKE += "INSTALL='install -p'" | ||
29 | |||