summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-support')
-rw-r--r--meta-gnome/recipes-support/florence/files/0001-Fix-glib-includes.patch33
-rw-r--r--meta-gnome/recipes-support/florence/florence_0.5.1.bb20
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/c99math.patch12
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/nodolt.patch12
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch19
-rw-r--r--meta-gnome/recipes-support/goffice/goffice_0.10.1.bb47
-rw-r--r--meta-gnome/recipes-support/tracker/files/90tracker4
-rw-r--r--meta-gnome/recipes-support/tracker/files/tracker-dbus.service15
-rw-r--r--meta-gnome/recipes-support/tracker/files/tracker-miner-fs.service12
-rw-r--r--meta-gnome/recipes-support/tracker/files/tracker-store.service12
-rw-r--r--meta-gnome/recipes-support/tracker/tracker-0.14.2/0005-Fix-missing-gobject-introspection-checks.patch17
-rw-r--r--meta-gnome/recipes-support/tracker/tracker-0.14.2/enable-sqlite-crosscompile.patch13
-rw-r--r--meta-gnome/recipes-support/tracker/tracker-0.14.2/fix-removable-media-detection.patch30
-rw-r--r--meta-gnome/recipes-support/tracker/tracker_0.14.2.bb79
14 files changed, 325 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/florence/files/0001-Fix-glib-includes.patch b/meta-gnome/recipes-support/florence/files/0001-Fix-glib-includes.patch
new file mode 100644
index 000000000..83e598e6a
--- /dev/null
+++ b/meta-gnome/recipes-support/florence/files/0001-Fix-glib-includes.patch
@@ -0,0 +1,33 @@
1From c8419ef05ff92ffa3de2e626eb6acd5d2df3baa1 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Tue, 15 May 2012 13:40:05 +0200
4Subject: [PATCH] Fix glib includes
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8Upstream-Status: unknown
9
10Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
11---
12 src/trace.c | 5 +----
13 1 files changed, 1 insertions(+), 4 deletions(-)
14
15diff --git a/src/trace.c b/src/trace.c
16index 5ea5c13..774c56d 100644
17--- a/src/trace.c
18+++ b/src/trace.c
19@@ -21,10 +21,7 @@
20
21 #include "trace.h"
22 #include "system.h"
23-#include <glib/gprintf.h>
24-#include <glib/gutils.h>
25-#include <glib/gslist.h>
26-#include <glib/gstrfuncs.h>
27+#include <glib.h>
28 #include <stdio.h>
29 #include <stdarg.h>
30
31--
321.7.6.5
33
diff --git a/meta-gnome/recipes-support/florence/florence_0.5.1.bb b/meta-gnome/recipes-support/florence/florence_0.5.1.bb
new file mode 100644
index 000000000..9eab38575
--- /dev/null
+++ b/meta-gnome/recipes-support/florence/florence_0.5.1.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Florence is a virtual keyboard (also called on-screen-keyboard), which allows the user to input text through a touchscreen."
2HOMEPAGE = "http://florence.sourceforge.net/english.html"
3
4#NOTICE: If florence can't find its gconf settings, you need to start florence with --config for one time and save the configuration once.
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
8
9PR = "r1"
10
11DEPENDS = "gtk+ libxml2 libglade librsvg libxtst gconf cairo intltool-native gnome-doc-utils libnotify"
12
13SRC_URI = "http://switch.dl.sourceforge.net/project/florence/florence/0.5.1/florence-0.5.1.tar.bz2 \
14 file://0001-Fix-glib-includes.patch"
15SRC_URI[md5sum] = "56d12e5b47c100d9df172aa5ddc0f609"
16SRC_URI[sha256sum] = "7b06ed84ef2b7b22d8d2cf0c7d013a05409bd82028240ac8719a68b192d5bc62"
17
18inherit gettext autotools gconf pkgconfig
19
20EXTRA_OECONF = "--disable-scrollkeeper --without-docs --without-at-spi --without-panelapplet"
diff --git a/meta-gnome/recipes-support/goffice/goffice/c99math.patch b/meta-gnome/recipes-support/goffice/goffice/c99math.patch
new file mode 100644
index 000000000..24e6c31a7
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/c99math.patch
@@ -0,0 +1,12 @@
1Index: goffice-0.7.14/configure.in
2===================================================================
3--- goffice-0.7.14.orig/configure.in 2009-11-14 19:14:37.106109501 +0100
4+++ goffice-0.7.14/configure.in 2009-11-14 19:19:40.907333188 +0100
5@@ -66,6 +66,7 @@
6
7 AC_ISC_POSIX
8 AC_PROG_CC
9+AC_PROG_CC_C99
10 AC_PROG_YACC
11 AM_PROG_LEX
12 AC_PROG_LN_S
diff --git a/meta-gnome/recipes-support/goffice/goffice/nodolt.patch b/meta-gnome/recipes-support/goffice/goffice/nodolt.patch
new file mode 100644
index 000000000..ea1777a99
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/nodolt.patch
@@ -0,0 +1,12 @@
1Index: goffice-0.7.14/configure.in
2===================================================================
3--- goffice-0.7.14.orig/configure.in
4+++ goffice-0.7.14/configure.in
5@@ -71,7 +71,6 @@ AC_PROG_YACC
6 AM_PROG_LEX
7 AC_PROG_LN_S
8 AM_PROG_LIBTOOL
9-DOLT
10 AC_STDC_HEADERS
11 AC_SYS_LARGEFILE
12
diff --git a/meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch b/meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch
new file mode 100644
index 000000000..ae9370cfc
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch
@@ -0,0 +1,19 @@
1Taken from http://trac.macports.org/ticket/34812
2
3Fixes abiword build failing with:
4/usr/lib/libgoffice-0.8.so: undefined reference to `pcre_info'
5
6Upstream-Status: pending
7
8http://www.linuxfromscratch.org/blfs/view/cvs/x/goffice.html
9--- a/goffice/utils/regutf8.c.orig 2009-09-05 18:52:09.000000000 -0500
10+++ b/goffice/utils/regutf8.c 2012-06-09 18:04:29.000000000 -0500
11@@ -155,7 +155,7 @@
12 default: return GO_REG_BADPAT;
13 }
14 } else {
15- gor->re_nsub = pcre_info (r, NULL, NULL);
16+ gor->re_nsub = pcre_fullinfo (r, NULL, 0, NULL);
17 gor->nosub = (cflags & GO_REG_NOSUB) != 0;
18 return 0;
19 }
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb b/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
new file mode 100644
index 000000000..1e9ec4cfd
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
@@ -0,0 +1,47 @@
1DESCRIPTION="Gnome Office Library"
2
3LICENSE="GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6dc33ff21e1ba1ac1a2a1069d361e29e"
5
6DEPENDS = "libxml-parser-perl-native glib-2.0 gtk+3 pango cairo libgsf libpcre libxml2 libart-lgpl librsvg intltool"
7
8inherit gnomebase pkgconfig perlnative
9
10GNOME_COMPRESS_TYPE = "xz"
11
12SRC_URI[archive.md5sum] = "90fd17c6fe205b779571e00d9b0b4727"
13SRC_URI[archive.sha256sum] = "5c38f4e81e874cc8e89481b080f77c47c72bfd6fe2526f4fc2ef87c17f96cad0"
14
15FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
16
17RRECOMMENDS_${PN} = " \
18 goffice-plugin-plot-barcol \
19 goffice-plugin-plot-distrib \
20 goffice-plugin-plot-pie \
21 goffice-plugin-plot-radar \
22 goffice-plugin-plot-surface \
23 goffice-plugin-plot-xy \
24 goffice-plugin-reg-linear \
25 goffice-plugin-reg-logfit \
26 goffice-plugin-smoothing \
27"
28
29FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
30 ${sysconfdir} ${sharedstatedir} ${localstatedir} \
31 ${base_bindir}/* ${base_sbindir}/* \
32 ${base_libdir}/*${SOLIBS} \
33 ${datadir}/${PN} \
34 ${datadir}/pixmaps ${datadir}/applications \
35 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
36 ${libdir}/bonobo/servers"
37
38FILES_${PN}-locale = "${libdir}/locale"
39
40PACKAGES_DYNAMIC += "^goffice-plugin-.*"
41
42python populate_packages_prepend () {
43 goffice_libdir = d.expand('${libdir}/goffice/${PV}/plugins/')
44
45 do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
46}
47
diff --git a/meta-gnome/recipes-support/tracker/files/90tracker b/meta-gnome/recipes-support/tracker/files/90tracker
new file mode 100644
index 000000000..9594b9168
--- /dev/null
+++ b/meta-gnome/recipes-support/tracker/files/90tracker
@@ -0,0 +1,4 @@
1#!/bin/sh
2
3/usr/bin/trackerd -m &
4
diff --git a/meta-gnome/recipes-support/tracker/files/tracker-dbus.service b/meta-gnome/recipes-support/tracker/files/tracker-dbus.service
new file mode 100644
index 000000000..c97f49a89
--- /dev/null
+++ b/meta-gnome/recipes-support/tracker/files/tracker-dbus.service
@@ -0,0 +1,15 @@
1[Unit]
2Description=tracker DBus session bus handler
3Before=tracker-store.service
4After=dbus.service
5Requires=dbus.service
6BindTo=tracker-store.service
7
8[Service]
9Type=forking
10EnvironmentFile=-/tmp/tracker.env
11ExecStartPre=@BASE_BINDIR@/rm -rf /tmp/tracker.env
12ExecStart=/bin/sh -c 'echo "DBUS_SESSION_BUS_ADDRESS=`dbus-daemon --fork --session --print-address`" > /tmp/tracker.env'
13
14[Install]
15WantedBy=multi-user.target
diff --git a/meta-gnome/recipes-support/tracker/files/tracker-miner-fs.service b/meta-gnome/recipes-support/tracker/files/tracker-miner-fs.service
new file mode 100644
index 000000000..34d9a1e68
--- /dev/null
+++ b/meta-gnome/recipes-support/tracker/files/tracker-miner-fs.service
@@ -0,0 +1,12 @@
1[Unit]
2Description=tracker-miner-fs
3After=syslog.target local-fs.target udev.service dbus.service tracker-store.service
4Requires=tracker-store.service
5
6[Service]
7Environment=HOME=/home/root
8EnvironmentFile=-/tmp/tracker.env
9ExecStart=@LIBEXECDIR@/tracker-miner-fs
10
11[Install]
12WantedBy=multi-user.target
diff --git a/meta-gnome/recipes-support/tracker/files/tracker-store.service b/meta-gnome/recipes-support/tracker/files/tracker-store.service
new file mode 100644
index 000000000..c5037f3ab
--- /dev/null
+++ b/meta-gnome/recipes-support/tracker/files/tracker-store.service
@@ -0,0 +1,12 @@
1[Unit]
2Description=tracker-store
3After=syslog.target local-fs.target dbus.service
4Requires=dbus.service tracker-dbus.service
5BindTo=tracker-dbus.service
6
7[Service]
8EnvironmentFile=-/tmp/tracker.env
9ExecStart=@LIBEXECDIR@/tracker-store
10
11[Install]
12WantedBy=multi-user.target
diff --git a/meta-gnome/recipes-support/tracker/tracker-0.14.2/0005-Fix-missing-gobject-introspection-checks.patch b/meta-gnome/recipes-support/tracker/tracker-0.14.2/0005-Fix-missing-gobject-introspection-checks.patch
new file mode 100644
index 000000000..8701f5854
--- /dev/null
+++ b/meta-gnome/recipes-support/tracker/tracker-0.14.2/0005-Fix-missing-gobject-introspection-checks.patch
@@ -0,0 +1,17 @@
1diff -Naur ../tracker-0.10.8/configure.ac tracker-0.10.8//configure.ac
2--- ../tracker-0.10.8/configure.ac 2011-04-08 15:03:30.000000000 +0300
3+++ tracker-0.10.8//configure.ac 2011-04-11 13:47:16.625914002 +0300
4@@ -218,7 +218,12 @@
5
6 # Needed to generate .gir files,
7 # see http://live.gnome.org/GnomeGoals/AddGObjectIntrospectionSupport
8-GOBJECT_INTROSPECTION_CHECK([0.9.5])
9+#GOBJECT_INTROSPECTION_CHECK([0.9.5])
10+# Satisfy missing introspection foo
11+AM_CONDITIONAL(HAVE_INTROSPECTION, test "0" == "1")
12+
13+INTROSPECTION_CFLAGS=""
14+AC_SUBST(INTROSPECTION_CFLAGS)
15
16 # NOTE: dbus and dbus-glib-1 are only used now for libtracker-client
17 # which is deprecated and tracker-writeback which will be refactored
diff --git a/meta-gnome/recipes-support/tracker/tracker-0.14.2/enable-sqlite-crosscompile.patch b/meta-gnome/recipes-support/tracker/tracker-0.14.2/enable-sqlite-crosscompile.patch
new file mode 100644
index 000000000..5dadda2a2
--- /dev/null
+++ b/meta-gnome/recipes-support/tracker/tracker-0.14.2/enable-sqlite-crosscompile.patch
@@ -0,0 +1,13 @@
1Index: tracker-0.10.17/m4/sqlite-threadsafe.m4
2===================================================================
3--- tracker-0.10.17.orig/m4/sqlite-threadsafe.m4
4+++ tracker-0.10.17/m4/sqlite-threadsafe.m4
5@@ -45,7 +45,7 @@ int main ()
6 ]])],
7 [ax_cv_sqlite_threadsafe=yes],
8 [ax_cv_sqlite_threadsafe=no],
9- [ax_cv_sqlite_threadsafe=no])])
10+ [ax_cv_sqlite_threadsafe=yes])])
11
12 LIBS="$save_LIBS"
13 ])
diff --git a/meta-gnome/recipes-support/tracker/tracker-0.14.2/fix-removable-media-detection.patch b/meta-gnome/recipes-support/tracker/tracker-0.14.2/fix-removable-media-detection.patch
new file mode 100644
index 000000000..6c3d9de10
--- /dev/null
+++ b/meta-gnome/recipes-support/tracker/tracker-0.14.2/fix-removable-media-detection.patch
@@ -0,0 +1,30 @@
1Index: tracker-0.14.2/src/libtracker-miner/tracker-storage.c
2===================================================================
3--- tracker-0.14.2.orig/src/libtracker-miner/tracker-storage.c 2011-08-03 13:53:16.000000000 +0100
4+++ tracker-0.14.2/src/libtracker-miner/tracker-storage.c 2012-09-10 08:25:18.322215126 +0100
5@@ -20,6 +20,7 @@
6 #include "config.h"
7
8 #include <string.h>
9+#include <sys/stat.h>
10
11 #include <gio/gio.h>
12 #include <gio/gunixmounts.h>
13@@ -646,6 +647,17 @@
14 gchar *content_type;
15 gboolean is_multimedia;
16 gboolean is_blank;
17+ struct stat st;
18+
19+ /*
20+ * Consider all files under /media to be
21+ * removable unless the file .this-is-root is
22+ * present.
23+ */
24+ if (!strncmp (mount_path, "/media/",
25+ strlen ("/media/")) &&
26+ stat ("/media/.this-is-root", &st))
27+ is_removable = TRUE;
28
29 content_type = mount_guess_content_type (mount, &is_optical, &is_multimedia, &is_blank);
30
diff --git a/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb b/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb
new file mode 100644
index 000000000..104e490a3
--- /dev/null
+++ b/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb
@@ -0,0 +1,79 @@
1DESCRIPTION = "Tracker is a tool designed to extract information and metadata about your personal data so that it can be searched easily and quickly."
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ee31012bf90e7b8c108c69f197f3e3a4"
4DEPENDS = "file gstreamer gamin dbus libexif gettext sqlite3 icu gst-plugins-base libgnome-keyring poppler tiff enca libgsf libunistring giflib taglib bzip2 upower gtk+3 libgee networkmanager"
5
6RDEPENDS_${PN} += " gvfs gsettings-desktop-schemas"
7HOMEPAGE = "http://projects.gnome.org/tracker/"
8
9PR = "r7"
10
11inherit autotools pkgconfig gnomebase gettext gsettings systemd
12
13VER_DIR = "${@gnome_verdir("${PV}")}"
14SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/tracker/${VER_DIR}/tracker-${PV}.tar.xz \
15 file://0005-Fix-missing-gobject-introspection-checks.patch \
16 file://enable-sqlite-crosscompile.patch \
17 file://fix-removable-media-detection.patch \
18 file://90tracker \
19 file://tracker-store.service \
20 file://tracker-miner-fs.service \
21 file://tracker-dbus.service \
22 "
23
24SYSTEMD_SERVICE_${PN} = " tracker-store.service tracker-miner-fs.service tracker-dbus.service "
25SYSTEMD_AUTO_ENABLE = "disable"
26
27EXTRA_OECONF += " tracker_cv_have_ioprio=yes"
28
29PACKAGECONFIG ?= "nautilus"
30PACKAGECONFIG[nautilus] = "--enable-nautilus-extension,--disable-nautilus-extension,nautilus"
31
32# Disable the desktop-centric miners
33EXTRA_OECONF += "--disable-miner-thunderbird --disable-miner-firefox \
34 --disable-miner-evolution --disable-miner-flickr"
35
36LEAD_SONAME = "libtrackerclient.so.0"
37
38do_install_append() {
39 cp -PpR ${D}${STAGING_DATADIR}/* ${D}${datadir}/ || true
40# install -d ${D}/${sysconfdir}/X11/Xsession.d/
41# install -m 0755 ${WORKDIR}/90tracker ${D}/${sysconfdir}/X11/Xsession.d/
42
43 install -d ${D}${systemd_unitdir}/system
44 install -m 0644 ${WORKDIR}/tracker-store.service ${D}${systemd_unitdir}/system
45 install -m 0644 ${WORKDIR}/tracker-miner-fs.service ${D}${systemd_unitdir}/system
46 install -m 0644 ${WORKDIR}/tracker-dbus.service ${D}${systemd_unitdir}/system
47 sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' \
48 -e 's,@BASE_BINDIR@,${base_bindir},g' \
49 ${D}${systemd_unitdir}/system/*.service
50}
51
52PACKAGES =+ "${PN}-tests ${PN}-vala ${PN}-nautilus-extension"
53
54FILES_${PN} += "${datadir}/dbus-1/ \
55 ${libdir}/tracker-${VER_DIR}/*.so.* \
56 ${libdir}/tracker-${VER_DIR}/extract-modules/*.so \
57 ${datadir}/icons/hicolor/*/apps/tracker.* \
58 ${libdir}/nautilus/extensions-2.0/*.la \
59 ${datadir}/glib-2.0/schemas/* \
60 ${systemd_unitdir}/system/tracker-store.service \
61 ${systemd_unitdir}/system/tracker-miner-fs.service \
62 ${systemd_unitdir}/system/tracker-dbus.service \
63"
64
65FILES_${PN}-dev += "${libdir}/tracker-${VER_DIR}/*.la \
66 ${libdir}/tracker-${VER_DIR}/*.so \
67 ${libdir}/tracker-${VER_DIR}/*/*.so \
68 ${libdir}/tracker-${VER_DIR}/*/*.la \
69 ${libdir}/tracker-${VER_DIR}/extract-modules/*.la"
70
71FILES_${PN}-staticdev += "${libdir}/nautilus/extensions-2.0/*.a"
72FILES_${PN}-dbg += "${libdir}/*/*/.debug \
73 ${libdir}/*/.debug"
74FILES_${PN}-tests = "${datadir}/tracker-tests/"
75FILES_${PN}-vala = "${datadir}/vala/"
76FILES_${PN}-nautilus-extension += "${libdir}/nautilus/extensions-2.0/*.so"
77
78SRC_URI[md5sum] = "f3a871beeebf86fd752863ebd22af9ac"
79SRC_URI[sha256sum] = "9b59330aa2e9e09feee587ded895e9247f71fc25f46b023d616d9969314bc7f1"