summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support/florence
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-support/florence')
-rw-r--r--meta-gnome/recipes-support/florence/files/0001-Fix-glib-includes.patch33
-rw-r--r--meta-gnome/recipes-support/florence/florence_0.5.1.bb20
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/florence/files/0001-Fix-glib-includes.patch b/meta-gnome/recipes-support/florence/files/0001-Fix-glib-includes.patch
new file mode 100644
index 000000000..83e598e6a
--- /dev/null
+++ b/meta-gnome/recipes-support/florence/files/0001-Fix-glib-includes.patch
@@ -0,0 +1,33 @@
1From c8419ef05ff92ffa3de2e626eb6acd5d2df3baa1 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Tue, 15 May 2012 13:40:05 +0200
4Subject: [PATCH] Fix glib includes
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8Upstream-Status: unknown
9
10Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
11---
12 src/trace.c | 5 +----
13 1 files changed, 1 insertions(+), 4 deletions(-)
14
15diff --git a/src/trace.c b/src/trace.c
16index 5ea5c13..774c56d 100644
17--- a/src/trace.c
18+++ b/src/trace.c
19@@ -21,10 +21,7 @@
20
21 #include "trace.h"
22 #include "system.h"
23-#include <glib/gprintf.h>
24-#include <glib/gutils.h>
25-#include <glib/gslist.h>
26-#include <glib/gstrfuncs.h>
27+#include <glib.h>
28 #include <stdio.h>
29 #include <stdarg.h>
30
31--
321.7.6.5
33
diff --git a/meta-gnome/recipes-support/florence/florence_0.5.1.bb b/meta-gnome/recipes-support/florence/florence_0.5.1.bb
new file mode 100644
index 000000000..9eab38575
--- /dev/null
+++ b/meta-gnome/recipes-support/florence/florence_0.5.1.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Florence is a virtual keyboard (also called on-screen-keyboard), which allows the user to input text through a touchscreen."
2HOMEPAGE = "http://florence.sourceforge.net/english.html"
3
4#NOTICE: If florence can't find its gconf settings, you need to start florence with --config for one time and save the configuration once.
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
8
9PR = "r1"
10
11DEPENDS = "gtk+ libxml2 libglade librsvg libxtst gconf cairo intltool-native gnome-doc-utils libnotify"
12
13SRC_URI = "http://switch.dl.sourceforge.net/project/florence/florence/0.5.1/florence-0.5.1.tar.bz2 \
14 file://0001-Fix-glib-includes.patch"
15SRC_URI[md5sum] = "56d12e5b47c100d9df172aa5ddc0f609"
16SRC_URI[sha256sum] = "7b06ed84ef2b7b22d8d2cf0c7d013a05409bd82028240ac8719a68b192d5bc62"
17
18inherit gettext autotools gconf pkgconfig
19
20EXTRA_OECONF = "--disable-scrollkeeper --without-docs --without-at-spi --without-panelapplet"