summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch')
-rw-r--r--meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch b/meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch
new file mode 100644
index 000000000..1b4096dd0
--- /dev/null
+++ b/meta-gnome/recipes-gnome/themes/gnome-themes/iconpath-option.patch
@@ -0,0 +1,52 @@
1
2The patch is ported from sato-icon-theme.
3
4pkg-config will only search the target sysroot and we want the native script. This
5patch adds an option to allow the path to the tool to be specified.
6
7Upstream-Status: Pending
8Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
9---
10 configure.in | 26 ++++++++++++++++----------
11 1 file changed, 16 insertions(+), 10 deletions(-)
12
13diff --git a/configure.in b/configure.in
14index 5f7a18c..e8fc31e 100644
15--- a/configure.in
16+++ b/configure.in
17@@ -74,16 +74,22 @@ AC_ARG_ENABLE([icon-mapping],
18 ICONMAP="true"
19 if test "x$enable_mapping" != "xno"; then
20 UTILS_REQUIRED=0.8.7
21-
22- AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
23- PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED, have_utils=yes, have_utils=no)
24- if test "x$have_utils" = "xyes"; then
25- UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
26- ICONMAP="$UTILS_PATH/icon-name-mapping"
27- AC_MSG_RESULT([yes])
28- else
29- AC_MSG_RESULT([no])
30- AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build and install gnome-themes])
31+ PKG_PROG_PKG_CONFIG()
32+ AC_ARG_WITH(iconmap,
33+ AC_HELP_STRING([--with-iconmap=<dir>], [The location of the icon-name-mapping script to use]),
34+ ICONMAP=$withval, ICONMAP="")
35+ if test "x$ICONMAP" = "x"; then
36+ AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
37+ PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED, have_utils=yes, have_utils=no)
38+ if test "x$have_utils" = "xyes"; then
39+ UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
40+ ICONMAP="$UTILS_PATH/icon-name-mapping"
41+
42+ AC_MSG_RESULT([yes])
43+ else
44+ AC_MSG_RESULT([no])
45+ AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build and install gnome-themes"])
46+ fi
47 fi
48 fi
49 AC_SUBST(ICONMAP)
50--
511.7.9.5
52