diff options
Diffstat (limited to 'meta-gnome/recipes-gnome/sysprof')
-rw-r--r-- | meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch | 12 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/sysprof/sysprof/0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch | 32 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb (renamed from meta-gnome/recipes-gnome/sysprof/sysprof_3.44.0.bb) | 19 |
3 files changed, 50 insertions, 13 deletions
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch b/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch index dc702a0e37..1082fe4ffc 100644 --- a/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch +++ b/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch | |||
@@ -13,15 +13,15 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | 13 | 1 file changed, 1 insertion(+), 1 deletion(-) |
14 | 14 | ||
15 | diff --git a/meson.build b/meson.build | 15 | diff --git a/meson.build b/meson.build |
16 | index 2835782..0fdb39a 100644 | 16 | index 3d3d8b5..4a1963d 100644 |
17 | --- a/meson.build | 17 | --- a/meson.build |
18 | +++ b/meson.build | 18 | +++ b/meson.build |
19 | @@ -81,7 +81,7 @@ config_h.set10('HAVE_POLKIT_AGENT', polkit_agent_dep.found()) | 19 | @@ -96,7 +96,7 @@ config_h.set10('HAVE_POLKIT', polkit_dep.found()) |
20 | config_h.set10('HAVE_POLKIT', polkit_dep.found()) | ||
21 | |||
22 | if get_option('libunwind') | 20 | if get_option('libunwind') |
23 | - libunwind_dep = dependency('libunwind-generic') | 21 | # Force libunwind usage if it's specified to avoid back compiles |
24 | + libunwind_dep = dependency('libunwind') | 22 | # and backtrace() showing up in builds |
23 | - libunwind_dep = dependency('libunwind-generic', required: true) | ||
24 | + libunwind_dep = dependency('libunwind', required: true) | ||
25 | config_h.set('ENABLE_LIBUNWIND', libunwind_dep.found()) | 25 | config_h.set('ENABLE_LIBUNWIND', libunwind_dep.found()) |
26 | config_h.set('HAVE_UNW_SET_CACHE_SIZE', libunwind_dep.found() and cc.has_header_symbol('libunwind.h', 'unw_set_cache_size', dependencies: [libunwind_dep])) | 26 | config_h.set('HAVE_UNW_SET_CACHE_SIZE', libunwind_dep.found() and cc.has_header_symbol('libunwind.h', 'unw_set_cache_size', dependencies: [libunwind_dep])) |
27 | endif | 27 | endif |
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof/0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch b/meta-gnome/recipes-gnome/sysprof/sysprof/0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch new file mode 100644 index 0000000000..998c20c657 --- /dev/null +++ b/meta-gnome/recipes-gnome/sysprof/sysprof/0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 9ad120283f4b61b97da67f18a95bb3b4f1e8a3b9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Carlos Alberto Lopez Perez <clopez@igalia.com> | ||
3 | Date: Wed, 24 Jul 2024 15:51:05 +0100 | ||
4 | Subject: [PATCH] meson: Do not invoke the commands to update the icon caches | ||
5 | when cross-building | ||
6 | |||
7 | This does not have any useful efect when cross-building and it requires | ||
8 | the cross-builder environment to have gtk4-native built in order to invoke | ||
9 | gtk-update-icon-cache program. | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Carlos Alberto Lopez Perez <clopez@igalia.com> | ||
13 | --- | ||
14 | meson.build | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/meson.build b/meson.build | ||
18 | index 3d3d8b5..da622f1 100644 | ||
19 | --- a/meson.build | ||
20 | +++ b/meson.build | ||
21 | @@ -250,7 +250,7 @@ configure_file( | ||
22 | configuration: config_h | ||
23 | ) | ||
24 | |||
25 | -if get_option('gtk') and gnome.found() | ||
26 | +if get_option('gtk') and gnome.found() and not meson.is_cross_build() | ||
27 | gnome.post_install( | ||
28 | gtk_update_icon_cache: true, | ||
29 | update_desktop_database: true | ||
30 | -- | ||
31 | 2.39.2 | ||
32 | |||
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof_3.44.0.bb b/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb index 3523bad3e2..bf4ee7a73e 100644 --- a/meta-gnome/recipes-gnome/sysprof/sysprof_3.44.0.bb +++ b/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb | |||
@@ -14,19 +14,24 @@ DEPENDS += " \ | |||
14 | json-glib \ | 14 | json-glib \ |
15 | " | 15 | " |
16 | 16 | ||
17 | SRC_URI += "file://0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch" | 17 | SRC_URI += "file://0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch \ |
18 | SRC_URI[archive.sha256sum] = "ab5d9f5b71973b3088d58a1bfdf1dc23c39a02f5fce4e5e9c73e034b178b005b" | 18 | file://0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch " |
19 | SRC_URI[archive.sha256sum] = "07d9081a66cf2fb52753f48ff2b85ada75c60ff1bc1af1bd14d8aeb627972168" | ||
19 | 20 | ||
20 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'sysprofd libsysprof', '', d)} \ | 21 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'sysprofd', '', d)} \ |
21 | ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)} \ | 22 | ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)} \ |
22 | libunwind" | 23 | agent \ |
24 | libsysprof \ | ||
25 | libunwind \ | ||
26 | " | ||
23 | # nongnu libunwind needs porting to RV32 | 27 | # nongnu libunwind needs porting to RV32 |
24 | PACKAGECONFIG:remove:riscv32 = "libunwind" | 28 | PACKAGECONFIG:remove:riscv32 = "libunwind" |
25 | 29 | ||
26 | PACKAGECONFIG[gtk] = "-Denable_gtk=true,-Denable_gtk=false,gtk+3 libdazzle" | 30 | PACKAGECONFIG[gtk] = "-Dgtk=true,-Dgtk=false,gtk4 libadwaita" |
27 | PACKAGECONFIG[sysprofd] = "-Dwith_sysprofd=bundled,-Dwith_sysprofd=none,polkit" | 31 | PACKAGECONFIG[sysprofd] = "-Dsysprofd=bundled,-Dsysprofd=none,polkit" |
28 | PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,polkit" | 32 | PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,json-glib" |
29 | PACKAGECONFIG[libunwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind" | 33 | PACKAGECONFIG[libunwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind" |
34 | PACKAGECONFIG[agent] = "-Dagent=true,-Dagent=false," | ||
30 | 35 | ||
31 | EXTRA_OEMESON += "-Dsystemdunitdir=${systemd_unitdir}/system" | 36 | EXTRA_OEMESON += "-Dsystemdunitdir=${systemd_unitdir}/system" |
32 | 37 | ||