summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb b/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb
new file mode 100644
index 0000000000..bf4ee7a73e
--- /dev/null
+++ b/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb
@@ -0,0 +1,48 @@
1SUMMARY = "System-wide Performance Profiler for Linux"
2HOMEPAGE = "http://www.sysprof.com"
3LICENSE = "GPL-3.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
5 file://src/sysprof/sysprof-application.c;endline=17;md5=a3de8df3b0f8876dd01e1388d2d4b607"
6
7inherit gnomebase gnome-help gettext systemd upstream-version-is-even gsettings mime mime-xdg
8
9DEPENDS += " \
10 glib-2.0-native \
11 yelp-tools-native \
12 libxml2-native \
13 glib-2.0 \
14 json-glib \
15"
16
17SRC_URI += "file://0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch \
18 file://0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch "
19SRC_URI[archive.sha256sum] = "07d9081a66cf2fb52753f48ff2b85ada75c60ff1bc1af1bd14d8aeb627972168"
20
21PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'sysprofd', '', d)} \
22 ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)} \
23 agent \
24 libsysprof \
25 libunwind \
26 "
27# nongnu libunwind needs porting to RV32
28PACKAGECONFIG:remove:riscv32 = "libunwind"
29
30PACKAGECONFIG[gtk] = "-Dgtk=true,-Dgtk=false,gtk4 libadwaita"
31PACKAGECONFIG[sysprofd] = "-Dsysprofd=bundled,-Dsysprofd=none,polkit"
32PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,json-glib"
33PACKAGECONFIG[libunwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
34PACKAGECONFIG[agent] = "-Dagent=true,-Dagent=false,"
35
36EXTRA_OEMESON += "-Dsystemdunitdir=${systemd_unitdir}/system"
37
38SOLIBS = ".so"
39FILES_SOLIBSDEV = ""
40
41SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'sysprofd', 'sysprof2.service sysprof3.service', '', d)}"
42
43FILES:${PN} += " \
44 ${datadir}/dbus-1/system-services \
45 ${datadir}/dbus-1/system.d \
46 ${datadir}/dbus-1/interfaces \
47 ${datadir}/metainfo \
48"