diff options
Diffstat (limited to 'meta-gnome/recipes-gnome/nautilus')
-rw-r--r-- | meta-gnome/recipes-gnome/nautilus/nautilus3/no-try-run-strftime.diff | 41 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/nautilus/nautilus3_3.0.2.bb | 47 |
2 files changed, 88 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus3/no-try-run-strftime.diff b/meta-gnome/recipes-gnome/nautilus/nautilus3/no-try-run-strftime.diff new file mode 100644 index 000000000..56d2e159d --- /dev/null +++ b/meta-gnome/recipes-gnome/nautilus/nautilus3/no-try-run-strftime.diff | |||
@@ -0,0 +1,41 @@ | |||
1 | From dc9c8cf2676c8c91ea0ae250cfedf863352f3ccd Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Fri, 24 Jun 2011 20:24:08 +0200 | ||
4 | Subject: [PATCH] hack out check that tries to run generated binaries | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | configure.in | 17 +---------------- | ||
9 | 1 files changed, 1 insertions(+), 16 deletions(-) | ||
10 | |||
11 | diff --git a/configure.in b/configure.in | ||
12 | index c3aa371..1d3ecdc 100644 | ||
13 | --- a/configure.in | ||
14 | +++ b/configure.in | ||
15 | @@ -251,22 +251,7 @@ AC_SUBST(WARNING_CFLAGS) | ||
16 | |||
17 | dnl =========================================================================== | ||
18 | |||
19 | -dnl strftime checks | ||
20 | - | ||
21 | -AC_TRY_RUN([#include <time.h> | ||
22 | - int main () | ||
23 | - { | ||
24 | - char buf[100]; | ||
25 | - struct tm tm = {0}; | ||
26 | - tm.tm_year = 99; | ||
27 | - if (strftime(buf, 100, "%EY", &tm) == 4 && | ||
28 | - strcmp (buf, "1999")==0) | ||
29 | - return 0; | ||
30 | - return 1; | ||
31 | - } | ||
32 | - ], | ||
33 | - AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.]) | ||
34 | - ) | ||
35 | +AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.]) | ||
36 | |||
37 | dnl ========================================================================== | ||
38 | |||
39 | -- | ||
40 | 1.6.6.1 | ||
41 | |||
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus3_3.0.2.bb b/meta-gnome/recipes-gnome/nautilus/nautilus3_3.0.2.bb new file mode 100644 index 000000000..b530cee9c --- /dev/null +++ b/meta-gnome/recipes-gnome/nautilus/nautilus3_3.0.2.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | # nautilus OE build file | ||
2 | # Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved | ||
3 | # Released under the MIT license (see packages/COPYING) | ||
4 | |||
5 | LICENSE="GPLv2 && LGPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=f08a446809913fc9b3c718f0eaea0426 \ | ||
7 | file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" | ||
8 | |||
9 | PR = "r2" | ||
10 | |||
11 | DEPENDS = "libnotify3 gtk+3 libunique gvfs librsvg libexif gnome-desktop3" | ||
12 | # optional: tracker | ||
13 | |||
14 | BPN = "nautilus" | ||
15 | inherit gnome | ||
16 | |||
17 | SRC_URI += "file://no-try-run-strftime.diff" | ||
18 | SRC_URI[archive.md5sum] = "949187b1f241137ad3a5e6bdca3dfb0b" | ||
19 | SRC_URI[archive.sha256sum] = "6a4c6b75593f0e815763d0040878cd908da72318f18b05f33d24040e0d602b22" | ||
20 | |||
21 | EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb --enable-nst-extension" | ||
22 | export SYSROOT = "${STAGING_DIR_HOST}" | ||
23 | |||
24 | do_configure() { | ||
25 | sed -i -e /docs/d Makefile.am | ||
26 | autotools_do_configure | ||
27 | } | ||
28 | |||
29 | RDEPENDS_${PN} = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash glib-2.0-utils" | ||
30 | FILES_${PN} += "${datadir}/icons \ | ||
31 | /usr/libexec/ \ | ||
32 | ${datadir}/nautilus* \ | ||
33 | ${datadir}/dbus-1 \ | ||
34 | ${libdir}/nautilus/extensions*/*.so \ | ||
35 | " | ||
36 | FILES_${PN}-dbg += "/usr/libexec/.debug" | ||
37 | |||
38 | # Don't make nautils drag us in | ||
39 | PRIVATE_LIBS = "libnautilus-extension.so.1" | ||
40 | |||
41 | pkg_postinst_${PN} () { | ||
42 | if [ -n "$D" ]; then | ||
43 | exit 1 | ||
44 | fi | ||
45 | |||
46 | glib-compile-schemas ${datadir}/glib-2.0/schemas | ||
47 | } | ||