summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb b/meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb
deleted file mode 100644
index ec2110785..000000000
--- a/meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1SUMMARY = "Power management daemon"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
4
5PR = "r4"
6
7DEPENDS = "glib-2.0 gtk+ gconf libgnome-keyring dbus dbus-glib libnotify libwnck cairo libunique xrandr virtual/libx11 libxrender libcanberra upower gnome-doc-utils"
8RRECOMMENDS_${PN} += "gnome-keyring"
9
10inherit gnome
11
12SRC_URI += " \
13 file://sysrooted-pkg-config.patch \
14 file://0001-Makefile.am-don-t-build-help-man.patch \
15"
16
17SRC_URI[archive.md5sum] = "9a08e85dce3ffb90775f15e3bda4adda"
18SRC_URI[archive.sha256sum] = "17fa301bf7e133285c0e054ae3be2b0f690c48f59b09f67e04d6ed339b330476"
19GNOME_COMPRESS_TYPE="bz2"
20
21EXTRA_OECONF = " --disable-scrollkeeper \
22 --disable-applets \
23 --x-includes=${STAGING_INCDIR} \
24 --x-libraries=${STAGING_LIBDIR} \
25 --enable-compile-warnings=no \
26 ac_cv_header_X11_extensions_dpms_h=yes \
27"
28
29do_configure_append() {
30 # Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
31 for i in $(find ${B} -name "Makefile") ; do
32 sed -i -e s:-Werror::g $i
33 done
34 sed -e "s/libtool --/${TARGET_SYS}-libtool --/" -i ${B}/src/Makefile
35}
36
37PACKAGES =+ "${PN}-applets"
38
39FILES_${PN}-applets = "${bindir}/*applet* \
40 ${libdir}/bonobo/servers \
41 ${datadir}/gnome-2.0/ui \
42"
43
44FILES_${PN} += "${datadir}/icons \
45 ${datadir}/dbus-1 \
46 ${datadir}/gnome/autostart \
47"
48
49FILES_${PN}-doc += "${datadir}/omf \
50 ${datadir}/gnome/help \
51"
52
53# gnome-power-manager-2.32.0/src/gpm-manager.c:488:18: error: too many arguments to function 'notify_notification_new'
54PNBLACKLIST[gnome-power-manager] ?= "BROKEN: not compatible with current libnotify - the recipe will be removed on 2017-09-01 unless the issue is fixed"