summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-keyring
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-keyring')
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/egg-asn1x.patch55
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb40
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/libgnome-keyring_2.32.0.bb19
3 files changed, 114 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/egg-asn1x.patch b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/egg-asn1x.patch
new file mode 100644
index 000000000..ad8a40ccf
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/egg-asn1x.patch
@@ -0,0 +1,55 @@
1Fixed build error with gcc 4.8
2
3Errors like below
4
5egg-asn1x.c: In function 'anode_encode_build':
6egg-asn1x.c:1280:7: warning: variable 'type' set but not used [-Wunused-but-set-variable]
7egg-asn1x.c: In function 'traverse_and_prepare':
8egg-asn1x.c:3354:3: warning: passing argument 1 of 'egg_asn1x_create' from incompatible pointer type [enabled by default]
9In file included from egg-asn1x.c:50:0:
10egg-asn1x.h:38:8: note: expected 'const struct static_struct_asn *' but argument is of type 'const struct asn1_static_node *'
11egg-asn1x.c: At top level:
12egg-asn1x.c:3509:1: error: conflicting types for 'egg_asn1x_create'
13In file included from egg-asn1x.c:50:0:
14egg-asn1x.h:38:8: note: previous declaration of 'egg_asn1x_create' was here
15egg-asn1x.c:3572:1: error: conflicting types for 'egg_asn1x_create_quark'
16In file included from egg-asn1x.c:50:0:
17egg-asn1x.h:41:8: note: previous declaration of 'egg_asn1x_create_quark' was here
18egg-asn1x.c:3579:1: error: conflicting types for 'egg_asn1x_create_and_decode'
19In file included from egg-asn1x.c:50:0:
20egg-asn1x.h:44:8: note: previous declaration of 'egg_asn1x_create_and_decode' was here
21make[4]: *** [libegg_la-egg-asn1x.lo] Error 1
22
23
24Signed-off-by: Khem Raj <raj.khem@gmail.com>
25
26Upstream-Status: Pending
27Index: gnome-keyring-2.32.1/egg/egg-asn1x.h
28===================================================================
29--- gnome-keyring-2.32.1.orig/egg/egg-asn1x.h 2010-10-18 19:11:38.000000000 -0700
30+++ gnome-keyring-2.32.1/egg/egg-asn1x.h 2013-06-11 15:15:00.675399263 -0700
31@@ -25,6 +25,7 @@
32 #define EGG_ASN1X_H_
33
34 #include <glib.h>
35+#include <libtasn1.h>
36
37 #ifndef HAVE_EGG_ALLOCATOR
38 typedef void* (*EggAllocator) (void* p, gsize);
39@@ -35,13 +36,13 @@
40
41 struct static_struct_asn;
42
43-GNode* egg_asn1x_create (const struct static_struct_asn *defs,
44+GNode* egg_asn1x_create (const ASN1_ARRAY_TYPE *defs,
45 const gchar *type);
46
47-GNode* egg_asn1x_create_quark (const struct static_struct_asn *defs,
48+GNode* egg_asn1x_create_quark (const ASN1_ARRAY_TYPE *defs,
49 GQuark type);
50
51-GNode* egg_asn1x_create_and_decode (const struct static_struct_asn *defs,
52+GNode* egg_asn1x_create_and_decode (const ASN1_ARRAY_TYPE *defs,
53 const gchar *type,
54 gconstpointer data,
55 gsize n_data);
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
new file mode 100644
index 000000000..860851d98
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Password and keyring managing daemon"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://gcr/gcr.h;endline=22;md5=a272df1e633e27ecf35e74fb5576250e \
8 file://egg/egg-dbus.h;endline=25;md5=eb6f531af37165dc53420c073d774e61 \
9 file://gp11/gp11.h;endline=24;md5=bd8c7a8a21d6c28d40536d96a35e3469 \
10 file://pkcs11/pkcs11i.h;endline=24;md5=e72cfbb718389b76a4dae838d1c1f439"
11
12SECTION = "x11/gnome"
13
14PR = "r12"
15
16inherit autotools gnome gtk-doc pkgconfig gsettings
17
18SRC_URI += "file://egg-asn1x.patch"
19
20DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} intltool-native"
21RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils"
22
23EXTRA_OECONF = "${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)}"
24
25SRC_URI[archive.md5sum] = "9a8aa74e03361676f29d6e73155786fc"
26SRC_URI[archive.sha256sum] = "31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9"
27
28FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr \
29 ${base_libdir}/security/*${SOLIBSDEV} \
30 "
31
32FILES_${PN}-dev += "${libdir}/${BPN}/devel/*.la \
33 ${libdir}/${BPN}/devel/*${SOLIBSDEV} \
34 ${libdir}/${BPN}/standalone/*.la \
35 ${base_libdir}/security/*.la \
36 "
37
38FILES_${PN}-dbg += "${libdir}/${BPN}/standalone/.debug/ \
39 ${libdir}/${BPN}/devel/.debug/ \
40 ${base_libdir}/security/.debug/"
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/libgnome-keyring_2.32.0.bb b/meta-gnome/recipes-gnome/gnome-keyring/libgnome-keyring_2.32.0.bb
new file mode 100644
index 000000000..43379bdca
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-keyring/libgnome-keyring_2.32.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Compatibility library for accessing secrets"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2 & LGPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=0914b9d3ebaba41ef2e3e0ae16f296cf \
7 file://library/gnome-keyring.h;endline=25;md5=68ea64f81c160d670c37da5f137be4fb \
8 file://library/gnome-keyring.c;endline=26;md5=8d7a4fb674aaa012ea5a98e7c368b4a5 \
9 file://egg/egg-dh.h;endline=22;md5=1626c16af2a8da1f88324cf3ced33f08"
10
11SECTION = "x11/gnome/libs"
12PR = "r3"
13
14inherit gnomebase gtk-doc
15
16DEPENDS = "dbus libgcrypt glib-2.0 intltool-native"
17
18SRC_URI[archive.md5sum] = "c42b2ca66204835d901d3dbfc1fa5ae6"
19SRC_URI[archive.sha256sum] = "56388c0d81ddfdb57d30e4963c83ecc1c18498aab99395420e0fff69929a0f0c"