summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
new file mode 100644
index 000000000..860851d98
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Password and keyring managing daemon"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://gcr/gcr.h;endline=22;md5=a272df1e633e27ecf35e74fb5576250e \
8 file://egg/egg-dbus.h;endline=25;md5=eb6f531af37165dc53420c073d774e61 \
9 file://gp11/gp11.h;endline=24;md5=bd8c7a8a21d6c28d40536d96a35e3469 \
10 file://pkcs11/pkcs11i.h;endline=24;md5=e72cfbb718389b76a4dae838d1c1f439"
11
12SECTION = "x11/gnome"
13
14PR = "r12"
15
16inherit autotools gnome gtk-doc pkgconfig gsettings
17
18SRC_URI += "file://egg-asn1x.patch"
19
20DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} intltool-native"
21RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils"
22
23EXTRA_OECONF = "${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)}"
24
25SRC_URI[archive.md5sum] = "9a8aa74e03361676f29d6e73155786fc"
26SRC_URI[archive.sha256sum] = "31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9"
27
28FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr \
29 ${base_libdir}/security/*${SOLIBSDEV} \
30 "
31
32FILES_${PN}-dev += "${libdir}/${BPN}/devel/*.la \
33 ${libdir}/${BPN}/devel/*${SOLIBSDEV} \
34 ${libdir}/${BPN}/standalone/*.la \
35 ${base_libdir}/security/*.la \
36 "
37
38FILES_${PN}-dbg += "${libdir}/${BPN}/standalone/.debug/ \
39 ${libdir}/${BPN}/devel/.debug/ \
40 ${base_libdir}/security/.debug/"