summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility')
-rw-r--r--meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/0001-Add-support-for-DeviceAutomountHint.patch74
-rw-r--r--meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/disable-scrollkeeper.patch27
-rw-r--r--meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/fix-dbus-interfaces.patch34
-rw-r--r--meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/sysrooted-pkg-config.patch37
4 files changed, 172 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/0001-Add-support-for-DeviceAutomountHint.patch b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/0001-Add-support-for-DeviceAutomountHint.patch
new file mode 100644
index 000000000..805e93776
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/0001-Add-support-for-DeviceAutomountHint.patch
@@ -0,0 +1,74 @@
1From 7dde5bc75a1d96be9510ce1e98d28f9d33520919 Mon Sep 17 00:00:00 2001
2From: David Zeuthen <davidz@redhat.com>
3Date: Fri, 8 Jul 2011 11:03:52 -0400
4Subject: [PATCH] Add support for DeviceAutomountHint
5
6Based on the patch in https://bugzilla.gnome.org/show_bug.cgi?id=653184
7
8Upstream-Status: Applied [1]
9
10[1] https://mail.gnome.org/archives/commits-list/2011-July/msg03207.html
11
12Signed-off-by: David Zeuthen <davidz@redhat.com>
13---
14 src/gdu/gdu-device.c | 10 ++++++++++
15 src/gdu/gdu-device.h | 1 +
16 2 files changed, 11 insertions(+), 0 deletions(-)
17
18diff --git a/src/gdu/gdu-device.c b/src/gdu/gdu-device.c
19index 6a5afad..4be39cf 100644
20--- a/src/gdu/gdu-device.c
21+++ b/src/gdu/gdu-device.c
22@@ -82,6 +82,7 @@ typedef struct
23 gboolean device_presentation_nopolicy;
24 char *device_presentation_name;
25 char *device_presentation_icon_name;
26+ char *device_automount_hint;
27 guint64 device_size;
28 guint64 device_block_size;
29
30@@ -279,6 +280,8 @@ collect_props (const char *key,
31 props->device_presentation_name = g_strdup (g_value_get_string (value));
32 else if (strcmp (key, "DevicePresentationIconName") == 0)
33 props->device_presentation_icon_name = g_strdup (g_value_get_string (value));
34+ else if (strcmp (key, "DeviceAutomountHint") == 0)
35+ props->device_automount_hint = g_strdup (g_value_get_string (value));
36 else if (strcmp (key, "DeviceSize") == 0)
37 props->device_size = g_value_get_uint64 (value);
38 else if (strcmp (key, "DeviceBlockSize") == 0)
39@@ -549,6 +552,7 @@ device_properties_free (DeviceProperties *props)
40 g_strfreev (props->device_mount_paths);
41 g_free (props->device_presentation_name);
42 g_free (props->device_presentation_icon_name);
43+ g_free (props->device_automount_hint);
44 g_free (props->job_id);
45 g_free (props->id_usage);
46 g_free (props->id_type);
47@@ -1294,6 +1298,12 @@ gdu_device_drive_get_media_compatibility (GduDevice *device)
48 }
49
50 const char *
51+gdu_device_get_automount_hint (GduDevice *device)
52+{
53+ return device->priv->props->device_automount_hint;
54+}
55+
56+const char *
57 gdu_device_drive_get_media (GduDevice *device)
58 {
59 return device->priv->props->drive_media;
60diff --git a/src/gdu/gdu-device.h b/src/gdu/gdu-device.h
61index 4c1302b..8cfd7a9 100644
62--- a/src/gdu/gdu-device.h
63+++ b/src/gdu/gdu-device.h
64@@ -143,6 +143,7 @@ const char *gdu_device_drive_get_wwn (GduDevice *device);
65 const char *gdu_device_drive_get_connection_interface (GduDevice *device);
66 guint64 gdu_device_drive_get_connection_speed (GduDevice *device);
67 char **gdu_device_drive_get_media_compatibility (GduDevice *device);
68+const gchar *gdu_device_get_automount_hint(GduDevice *device);
69 const char *gdu_device_drive_get_media (GduDevice *device);
70 gboolean gdu_device_drive_get_is_media_ejectable (GduDevice *device);
71 gboolean gdu_device_drive_get_requires_eject (GduDevice *device);
72--
731.7.6.5
74
diff --git a/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/disable-scrollkeeper.patch b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/disable-scrollkeeper.patch
new file mode 100644
index 000000000..f36942d19
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/disable-scrollkeeper.patch
@@ -0,0 +1,27 @@
1From: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
2Subject: Disable scrollkeeper-config not found message
3Upstream-Status: Not-Applicable
4
5If scrollkeeper-config isn't found, configure fails with an error.
6Fix that by commenting out the check.
7
8Signed-Off-By: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
9
10
11Index: gnome-disk-utility-2.32.0/configure.ac
12===================================================================
13--- gnome-disk-utility-2.32.0.orig/configure.ac 2010-09-15 19:07:25.000000000 +0400
14+++ gnome-disk-utility-2.32.0/configure.ac 2011-08-20 01:29:48.000000000 +0400
15@@ -188,9 +188,9 @@
16 # *************
17
18 AC_PATH_PROG(SCROLLKEEPER_CONFIG, scrollkeeper-config,no)
19-if test x$SCROLLKEEPER_CONFIG = xno; then
20- AC_MSG_ERROR(Couldn't find scrollkeeper-config, please install the scrollkeeper package)
21-fi
22+dnl if test x$SCROLLKEEPER_CONFIG = xno; then
23+dnl AC_MSG_ERROR([Couldn't find scrollkeeper-config, please install the scrollkeeper package])
24+dnl fi
25
26 # ********************
27 # Internationalization
diff --git a/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/fix-dbus-interfaces.patch b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/fix-dbus-interfaces.patch
new file mode 100644
index 000000000..6ba397955
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/fix-dbus-interfaces.patch
@@ -0,0 +1,34 @@
1Index: gnome-disk-utility-2.32.0/src/gdu/Makefile.am
2===================================================================
3--- gnome-disk-utility-2.32.0.orig/src/gdu/Makefile.am 2011-08-20 01:59:16.000000000 +0400
4+++ gnome-disk-utility-2.32.0/src/gdu/Makefile.am 2011-08-20 02:08:18.000000000 +0400
5@@ -14,20 +14,20 @@
6 gdu-marshal.c: gdu-marshal.list
7 echo "#include \"gdu-marshal.h\"" > $@ && glib-genmarshal $< --prefix=gdu_marshal --body >> $@
8
9-udisks-daemon-glue.h: /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.xml Makefile.am
10- dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-daemon-glue.h /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.xml
11+udisks-daemon-glue.h: $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.xml Makefile.am
12+ dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-daemon-glue.h $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.xml
13
14-udisks-device-glue.h: /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Device.xml Makefile.am
15- dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-device-glue.h /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Device.xml
16+udisks-device-glue.h: $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Device.xml Makefile.am
17+ dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-device-glue.h $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Device.xml
18
19-udisks-adapter-glue.h: /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Adapter.xml Makefile.am
20- dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-adapter-glue.h /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Adapter.xml
21+udisks-adapter-glue.h: $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Adapter.xml Makefile.am
22+ dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-adapter-glue.h $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Adapter.xml
23
24-udisks-expander-glue.h: /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Expander.xml Makefile.am
25- dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-expander-glue.h /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Expander.xml
26+udisks-expander-glue.h: $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Expander.xml Makefile.am
27+ dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-expander-glue.h $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Expander.xml
28
29-udisks-port-glue.h: /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Port.xml Makefile.am
30- dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-port-glue.h /usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Port.xml
31+udisks-port-glue.h: $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Port.xml Makefile.am
32+ dbus-binding-tool --prefix=devkit_disks_daemon --mode=glib-client --output=udisks-port-glue.h $(PKG_CONFIG_SYSROOT_DIR)/usr/share/dbus-1/interfaces/org.freedesktop.UDisks.Port.xml
33
34 lib_LTLIBRARIES=libgdu.la
diff --git a/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/sysrooted-pkg-config.patch b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/sysrooted-pkg-config.patch
new file mode 100644
index 000000000..48e63b1ea
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/sysrooted-pkg-config.patch
@@ -0,0 +1,37 @@
1In cross environment we have to prepend the sysroot to the path found by
2pkgconfig since the path returned from pkgconfig does not have sysroot prefixed
3it ends up using the files from host system. Now usually people have gnome installed
4so the build succeeds but if you dont have gnome installed on build host then
5it wont find the files on host system and packages using gnome-doc-utils wont
6compile.
7
8This should work ok with non sysrooted builds too since in those cases PKG_CONFIG_SYSROOT_DIR
9will be empty
10
11Upstream-Status: Pending
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14
15Index: gnome-disk-utility-2.32.0/gnome-doc-utils.make
16===================================================================
17--- gnome-disk-utility-2.32.0.orig/gnome-doc-utils.make 2010-09-15 08:27:46.000000000 -0700
18+++ gnome-disk-utility-2.32.0/gnome-doc-utils.make 2011-09-25 16:04:30.693795591 -0700
19@@ -133,12 +133,12 @@
20 _xml2po ?= `which xml2po`
21 _xml2po_mode = $(if $(DOC_ID),mallard,docbook)
22
23-_db2html ?= `$(PKG_CONFIG) --variable db2html gnome-doc-utils`
24-_db2omf ?= `$(PKG_CONFIG) --variable db2omf gnome-doc-utils`
25-_malrng ?= `$(PKG_CONFIG) --variable malrng gnome-doc-utils`
26-_chunks ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/chunks.xsl
27-_credits ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/credits.xsl
28-_ids ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/ids.xsl
29+_db2html ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2html gnome-doc-utils`
30+_db2omf ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2omf gnome-doc-utils`
31+_malrng ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable malrng gnome-doc-utils`
32+_chunks ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/chunks.xsl
33+_credits ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/credits.xsl
34+_ids ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/ids.xsl
35
36 if ENABLE_SK
37 _ENABLE_SK = true