summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.1.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.1.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.1.bb b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.1.bb
new file mode 100644
index 000000000..87daec0c2
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.1.bb
@@ -0,0 +1,74 @@
1SUMMARY = "GNOME Settings"
2DESCRIPTION = "GNOME Settings is GNOME's main interface for configuration of various aspects of your desktop"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GTKIC_VERSION = "4"
7
8DEPENDS = " \
9 accountsservice \
10 colord-gtk \
11 gcr \
12 gdk-pixbuf \
13 glib-2.0 \
14 gnome-bluetooth \
15 gnome-desktop \
16 gnome-online-accounts \
17 gnome-settings-daemon \
18 gsettings-desktop-schemas \
19 gtk4 \
20 libadwaita \
21 libepoxy \
22 libgtop \
23 libgudev \
24 libnma \
25 libpwquality \
26 libxml2 \
27 polkit \
28 pulseaudio \
29 samba \
30 setxkbmap-native \
31 tecla \
32 udisks2 \
33 upower \
34"
35
36inherit gtk-icon-cache pkgconfig gnomebase gsettings gettext upstream-version-is-even bash-completion features_check useradd
37
38REQUIRED_DISTRO_FEATURES += "opengl polkit pulseaudio systemd x11"
39
40SRC_URI += "file://0001-Add-meson-option-to-pass-sysroot.patch"
41SRC_URI[archive.sha256sum] = "81792423019deda1d2a074c1ecf6a7e6ef3172c09cbe6f4d7995a4b5dea28312"
42
43PACKAGECONFIG ??= "ibus ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
44PACKAGECONFIG[cups] = ",,cups,cups"
45PACKAGECONFIG[ibus] = "-Dibus=true, -Dibus=false, ibus"
46PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false, wayland"
47PACKAGECONFIG[file-share] = ",,,gnome-user-share"
48PACKAGECONFIG[media-share] = ",,,rygel-meta tumbler"
49
50EXTRA_OEMESON += "-Doe_sysroot=${STAGING_DIR_HOST}"
51
52export XDG_DATA_DIRS = "${STAGING_DATADIR}"
53
54USERADD_PACKAGES = "${PN}"
55USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd"
56
57do_install:append() {
58 if [ -d ${D}${datadir}/polkit-1/rules.d ]; then
59 chmod 700 ${D}${datadir}/polkit-1/rules.d
60 chown polkitd:root ${D}${datadir}/polkit-1/rules.d
61 fi
62}
63
64PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
65
66FILES:${PN} += " \
67 ${datadir}/dbus-1 \
68 ${datadir}/gnome-shell \
69 ${datadir}/metainfo \
70"
71
72FILES:${PN}-dev += "${datadir}/gettext"
73
74RDEPENDS:${PN} += "gsettings-desktop-schemas tecla system-config-printer cups-pk-helper"