summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.2.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.2.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.2.bb
new file mode 100644
index 000000000..c916aca00
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.2.bb
@@ -0,0 +1,44 @@
1SUMMARY = "GNOME bluetooth manager"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
5 file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
6"
7
8SECTION = "x11/gnome"
9
10DEPENDS = " \
11 udev \
12 libnotify \
13 libcanberra \
14 bluez5 \
15 upower \
16 gtk4 \
17 gsound \
18 libadwaita \
19"
20
21GNOMEBASEBUILDCLASS = "meson"
22GTKDOC_MESON_OPTION = "gtk_doc"
23GTKIC_VERSION = "4"
24
25inherit features_check gnomebase gtk-icon-cache gtk-doc gobject-introspection
26
27REQUIRED_DISTRO_FEATURES = "x11"
28
29SRC_URI[archive.sha256sum] = "8ce8ecfab28272db1830a63f08f9ccb5304734d1be2dbfce795fe4029e629f0c"
30
31BT_PULSE_PACKS = " \
32 pulseaudio-lib-bluez5-util \
33 pulseaudio-module-bluetooth-discover \
34 pulseaudio-module-bluetooth-policy \
35 pulseaudio-module-bluez5-device \
36 pulseaudio-module-bluez5-discover \
37"
38
39PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}"
40PACKAGECONFIG[pulseaudio] = ",,,${BT_PULSE_PACKS}"
41
42FILES:${PN} += "${datadir}/gnome-bluetooth-3.0"
43
44RDEPENDS:${PN} += "bluez5"