summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/file-roller/file-roller_44.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/file-roller/file-roller_44.2.bb')
-rw-r--r--meta-gnome/recipes-gnome/file-roller/file-roller_44.2.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/file-roller/file-roller_44.2.bb b/meta-gnome/recipes-gnome/file-roller/file-roller_44.2.bb
new file mode 100644
index 000000000..2131cdd85
--- /dev/null
+++ b/meta-gnome/recipes-gnome/file-roller/file-roller_44.2.bb
@@ -0,0 +1,46 @@
1SUMMARY = "An archive manager utility for the GNOME Environment"
2LICENSE="GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5
6DEPENDS = " \
7 desktop-file-utils-native \
8 glib-2.0-native \
9 glib-2.0 \
10 json-glib \
11 gtk4 \
12 libadwaita \
13 libarchive \
14 libhandy \
15 libportal \
16"
17
18inherit gnomebase gsettings itstool gobject-introspection gnome-help gettext upstream-version-is-even mime-xdg gtk-icon-cache features_check
19
20REQUIRED_DISTRO_FEATURES = "opengl"
21
22EXTRA_OEMESON += "-Dintrospection=enabled"
23
24SRC_URI = "git://gitlab.gnome.org/GNOME/file-roller.git;protocol=https;branch=master"
25SRCREV = "5b21d887e087155b008f9293ca054d6ac3116a2b"
26S = "${WORKDIR}/git"
27
28PACKAGECONFIG ??= ""
29
30PACKAGECONFIG[nautilus] = "-Dnautilus-actions=enabled,-Dnautilus-actions=disabled,nautilus"
31PACKAGECONFIG[packagekit] = "-Dpackagekit=true,-Dpackagekit=false,,packagekit"
32
33FILES:${PN} += " \
34 ${datadir}/dbus-1 \
35 ${datadir}/metainfo \
36 ${libdir}/nautilus \
37"
38
39EXTRA_OEMESON += "--cross-file=${WORKDIR}/meson-${PN}.cross"
40
41do_write_config:append() {
42 cat >${WORKDIR}/meson-${PN}.cross <<EOF
43[binaries]
44cpio = '${bindir}/cpio'
45EOF
46}