summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/evince/evince_3.34.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/evince/evince_3.34.2.bb')
-rw-r--r--meta-gnome/recipes-gnome/evince/evince_3.34.2.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/evince/evince_3.34.2.bb b/meta-gnome/recipes-gnome/evince/evince_3.34.2.bb
new file mode 100644
index 000000000..8f669c9db
--- /dev/null
+++ b/meta-gnome/recipes-gnome/evince/evince_3.34.2.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Evince is a document viewer for document formats like pdf, ps, djvu"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=96f2f8d5ee576a2163977938ea36fa7b"
4SECTION = "x11/office"
5DEPENDS = " \
6 gnome-common-native \
7 yelp-tools-native \
8 appstream-glib \
9 gtk+3 \
10 gspell \
11 libsecret \
12 poppler \
13 gstreamer1.0-plugins-base \
14 orc \
15 adwaita-icon-theme \
16 ${@bb.utils.contains('DISTRO_FEATURES','x11','gnome-desktop3','',d)} \
17"
18
19inherit gnomebase itstool gnome-help pkgconfig gsettings gobject-introspection upstream-version-is-even gettext features_check
20
21SRC_URI[archive.md5sum] = "9e9e82fa8f6045ad7817157d9335d185"
22SRC_URI[archive.sha256sum] = "3cc0955f11204e3a2db1c7ab99b866692749592257485b87304134ad69da0617"
23SRC_URI += " \
24 file://0001-Add-format-attribute-to-_synctex_malloc.patch \
25 file://0002-add-a-formatting-attribute-check.patch \
26"
27
28EXTRA_OECONF = " \
29 --enable-thumbnailer \
30 --without-systemduserunitdir \
31"
32
33do_compile_prepend() {
34 export GIR_EXTRA_LIBS_PATH="${B}/libdocument/.libs"
35}
36
37PACKAGECONFIG ??= ""
38PACKAGECONFIG[nautilus] = "--enable-nautilus,--disable-nautilus,nautilus"
39PACKAGECONFIG[browser-plugin] = "--enable-browser-plugin,--disable-browser-plugin,"
40
41RDEPENDS_${PN} += "glib-2.0-utils"
42RRECOMMMENDS_${PN} = "adwaita-icon-theme"
43
44PACKAGES =+ "${PN}-nautilus-extension"
45PACKAGES =+ "${PN}-browser-plugin"
46
47FILES_${PN} += "${datadir}/dbus-1 \
48 ${datadir}/metainfo \
49 ${datadir}/thumbnailers \
50"
51FILES_${PN}-nautilus-extension = "${libdir}/nautilus/*/*so"
52FILES_${PN}-browser-plugin = "${libdir}/mozilla/*/*so"