summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/abiword/abiword.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/abiword/abiword.inc')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword.inc34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword.inc b/meta-gnome/recipes-gnome/abiword/abiword.inc
index 8fbcd3bb2..39c590c41 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword.inc
+++ b/meta-gnome/recipes-gnome/abiword/abiword.inc
@@ -20,15 +20,15 @@ CVSSRC = "${WORKDIR}/abi"
20SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" 20SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
21 21
22FILES_${PN} += " \ 22FILES_${PN} += " \
23 ${datadir}/icons/* \ 23 ${datadir}/icons/* \
24 ${datadir}/mime-info \ 24 ${datadir}/mime-info \
25 ${datadir}/abiword-${SHRT_VER}/glade \ 25 ${datadir}/abiword-${SHRT_VER}/glade \
26 ${datadir}/abiword-${SHRT_VER}/system.profile-en \ 26 ${datadir}/abiword-${SHRT_VER}/system.profile-en \
27 ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \ 27 ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \
28 " 28"
29 29
30# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \ 30# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
31# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \ 31# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
32 32
33inherit autotools pkgconfig 33inherit autotools pkgconfig
34 34
@@ -40,10 +40,10 @@ PARALLEL_MAKE = ""
40# --disable-exports options 40# --disable-exports options
41 41
42EXTRA_OECONF = " --enable-embedded=poky \ 42EXTRA_OECONF = " --enable-embedded=poky \
43 --disable-printing \ 43 --disable-printing \
44 --with-sys-wv \ 44 --with-sys-wv \
45 --disable-exports \ 45 --disable-exports \
46 --disable-spellcheck" 46 --disable-spellcheck"
47 47
48# TODO -- refactor this, so that instead of two strings and profiles 48# TODO -- refactor this, so that instead of two strings and profiles
49# packages we have lots of locale packages, each with a set of strings and 49# packages we have lots of locale packages, each with a set of strings and
@@ -51,14 +51,14 @@ EXTRA_OECONF = " --enable-embedded=poky \
51# 51#
52PACKAGES += " abiword-strings abiword-systemprofiles" 52PACKAGES += " abiword-strings abiword-systemprofiles"
53 53
54FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings" 54FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
55FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*" 55FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
56 56
57# AbiWord configure.ac does not play nicely with autoreconf 57# AbiWord configure.ac does not play nicely with autoreconf
58# so use the autogen.sh script that comes with AbiWord 58# so use the autogen.sh script that comes with AbiWord
59# 59#
60do_configure() { 60do_configure() {
61 cd ${S} 61 cd ${S}
62 export NOCONFIGURE="no"; ./autogen.sh 62 export NOCONFIGURE="no"; ./autogen.sh
63 oe_runconf 63 oe_runconf
64} 64}