diff options
Diffstat (limited to 'meta-gnome/recipes-extended/gparted')
-rw-r--r-- | meta-gnome/recipes-extended/gparted/gparted/0001-configure.ac-use-pkg-config-to-check-for-version-of-.patch | 68 | ||||
-rw-r--r-- | meta-gnome/recipes-extended/gparted/gparted_0.23.0.bb (renamed from meta-gnome/recipes-extended/gparted/gparted_0.20.0.bb) | 9 |
2 files changed, 3 insertions, 74 deletions
diff --git a/meta-gnome/recipes-extended/gparted/gparted/0001-configure.ac-use-pkg-config-to-check-for-version-of-.patch b/meta-gnome/recipes-extended/gparted/gparted/0001-configure.ac-use-pkg-config-to-check-for-version-of-.patch deleted file mode 100644 index 1c99ff512..000000000 --- a/meta-gnome/recipes-extended/gparted/gparted/0001-configure.ac-use-pkg-config-to-check-for-version-of-.patch +++ /dev/null | |||
@@ -1,68 +0,0 @@ | |||
1 | From a39d205ec3c6db6fe98aa2c7f8352db767557f60 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Wed, 12 Nov 2014 11:26:19 +0100 | ||
4 | Subject: [PATCH] configure.ac: use pkg-config to check for version of gparted | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | running test programs causes headaches when cross-compiling | ||
10 | |||
11 | Upstream-Status: submitted [1] | ||
12 | |||
13 | [1] https://bugzilla.gnome.org/show_bug.cgi?id=740004 | ||
14 | |||
15 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
16 | --- | ||
17 | configure.ac | 34 ++++++---------------------------- | ||
18 | 1 file changed, 6 insertions(+), 28 deletions(-) | ||
19 | |||
20 | diff --git a/configure.ac b/configure.ac | ||
21 | index 37025b0..17bb686 100644 | ||
22 | --- a/configure.ac | ||
23 | +++ b/configure.ac | ||
24 | @@ -48,35 +48,13 @@ LIBPARTED_REQUIRED_VERSION='1.7.1' | ||
25 | AC_MSG_CHECKING([for libparted >= $LIBPARTED_REQUIRED_VERSION]) | ||
26 | LIBPARTED_REQUIRED_INT=`echo "$LIBPARTED_REQUIRED_VERSION" | | ||
27 | $AWK -F. '{print $1 * 10000 + $2 * 100 + $3}'` | ||
28 | -AC_RUN_IFELSE( | ||
29 | - [AC_LANG_SOURCE( | ||
30 | - [[ | ||
31 | -#include <stdio.h> | ||
32 | -#include <stdlib.h> | ||
33 | -#include <parted/parted.h> | ||
34 | - | ||
35 | -int main() | ||
36 | -{ | ||
37 | - const char *version = ped_get_version(); | ||
38 | - if (version == NULL) | ||
39 | - { | ||
40 | - fprintf(stderr, "ERROR: ped_get_version() returned NULL\n"); | ||
41 | - return EXIT_FAILURE; | ||
42 | - } | ||
43 | - printf("%s\n", version); | ||
44 | - return EXIT_SUCCESS; | ||
45 | -} | ||
46 | - ]] | ||
47 | - )], | ||
48 | - dnl Run test program again to cache libparted version. | ||
49 | - [LIBPARTED_FOUND_VERSION=`./conftest$EXEEXT` | ||
50 | - LIBPARTED_FOUND_INT=`echo "$LIBPARTED_FOUND_VERSION" | | ||
51 | - $AWK -F. '{print $1 * 10000 + $2 * 100 + $3}'` | ||
52 | - test "$LIBPARTED_FOUND_INT" -ge "$LIBPARTED_REQUIRED_INT" || | ||
53 | + | ||
54 | +LIBPARTED_FOUND_VERSION="`pkg-config libparted --modversion`" | ||
55 | +LIBPARTED_FOUND_INT=`echo "$LIBPARTED_FOUND_VERSION" | | ||
56 | + $AWK -F. '{print $1 * 10000 + $2 * 100 + $3}'` | ||
57 | + | ||
58 | +test "$LIBPARTED_FOUND_INT" -ge "$LIBPARTED_REQUIRED_INT" || | ||
59 | AC_MSG_ERROR([*** libparted too old. Require libparted >= $LIBPARTED_REQUIRED_VERSION but only found libparted $LIBPARTED_FOUND_VERSION.]) | ||
60 | - ], | ||
61 | - [AC_MSG_ERROR([*** Error querying libparted version. Check config.log for details.])] | ||
62 | -) | ||
63 | |||
64 | |||
65 | dnl Check for libparted >= 2.2 for improved informing the kernel to | ||
66 | -- | ||
67 | 1.8.3.1 | ||
68 | |||
diff --git a/meta-gnome/recipes-extended/gparted/gparted_0.20.0.bb b/meta-gnome/recipes-extended/gparted/gparted_0.23.0.bb index 30eac8e55..070543910 100644 --- a/meta-gnome/recipes-extended/gparted/gparted_0.20.0.bb +++ b/meta-gnome/recipes-extended/gparted/gparted_0.23.0.bb | |||
@@ -5,12 +5,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | |||
5 | 5 | ||
6 | inherit autotools pkgconfig | 6 | inherit autotools pkgconfig |
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.bz2" |
9 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.bz2 \ | 9 | SRC_URI[md5sum] = "5901dca33ced32213cccb13a2713dea8" |
10 | file://0001-configure.ac-use-pkg-config-to-check-for-version-of-.patch \ | 10 | SRC_URI[sha256sum] = "7fd1dddf29814c2982f55ab765b8918561e1b5dabf792012c66b4d3ba25da754" |
11 | " | ||
12 | SRC_URI[md5sum] = "d9df57f9d4b4dbd148644774f8bbccfb" | ||
13 | SRC_URI[sha256sum] = "9b34d73d4519352a7e7344c8403ef61253be1b4db3ff332c397b0b1eb5c1ddc2" | ||
14 | 11 | ||
15 | DEPENDS = "glib-2.0 gtkmm parted" | 12 | DEPENDS = "glib-2.0 gtkmm parted" |
16 | 13 | ||