diff options
Diffstat (limited to 'meta-filesystems')
-rw-r--r-- | meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-unionfs-Define-IOCPARM_LEN-if-undefined.patch | 62 | ||||
-rw-r--r-- | meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.1.bb (renamed from meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.0.bb) | 3 |
2 files changed, 1 insertions, 64 deletions
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-unionfs-Define-IOCPARM_LEN-if-undefined.patch b/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-unionfs-Define-IOCPARM_LEN-if-undefined.patch deleted file mode 100644 index 8f991cd3f..000000000 --- a/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-unionfs-Define-IOCPARM_LEN-if-undefined.patch +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | From 10411fa8658621822ae394160daffaced4a4cd7f Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Jul 2017 23:07:29 -0700 | ||
4 | Subject: [PATCH] unionfs: Define IOCPARM_LEN if undefined | ||
5 | |||
6 | musl does not have sysctl.h which defines this | ||
7 | for glibc | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/unionfs.c | 8 -------- | ||
12 | src/unionfs.h | 15 +++++++++++++++ | ||
13 | 2 files changed, 15 insertions(+), 8 deletions(-) | ||
14 | |||
15 | diff --git a/src/unionfs.c b/src/unionfs.c | ||
16 | index a34d34e..51684a7 100644 | ||
17 | --- a/src/unionfs.c | ||
18 | +++ b/src/unionfs.c | ||
19 | @@ -21,14 +21,6 @@ | ||
20 | #include "opts.h" | ||
21 | #include "usyslog.h" | ||
22 | |||
23 | -#ifndef _IOC_SIZE | ||
24 | -#ifdef IOCPARM_LEN | ||
25 | -#define _IOC_SIZE(x) IOCPARM_LEN(x) | ||
26 | -#else | ||
27 | -#error "No mechanism for determining ioctl length found." | ||
28 | -#endif | ||
29 | -#endif | ||
30 | - | ||
31 | static struct fuse_opt unionfs_opts[] = { | ||
32 | FUSE_OPT_KEY("chroot=%s,", KEY_CHROOT), | ||
33 | FUSE_OPT_KEY("cow", KEY_COW), | ||
34 | diff --git a/src/unionfs.h b/src/unionfs.h | ||
35 | index 8f5e0bf..b02de5a 100644 | ||
36 | --- a/src/unionfs.h | ||
37 | +++ b/src/unionfs.h | ||
38 | @@ -17,6 +17,21 @@ | ||
39 | #define FUSE_META_FILE ".fuse_hidden" | ||
40 | #define FUSE_META_LENGTH 12 | ||
41 | |||
42 | +#ifndef IOCPARM_MASK | ||
43 | +#define IOCPARM_MASK 0x1FFF | ||
44 | +#endif | ||
45 | +#ifndef IOCPARM_LEN | ||
46 | +#define IOCPARM_LEN(a) (((a) >> 16) & IOCPARM_MASK) | ||
47 | +#endif | ||
48 | + | ||
49 | +#ifndef _IOC_SIZE | ||
50 | +#ifdef IOCPARM_LEN | ||
51 | +#define _IOC_SIZE(x) IOCPARM_LEN(x) | ||
52 | +#else | ||
53 | +#error "No mechanism for determining ioctl length found." | ||
54 | +#endif | ||
55 | +#endif | ||
56 | + | ||
57 | // file access protection mask | ||
58 | #define S_PROT_MASK (S_ISUID| S_ISGID | S_ISVTX | S_IRWXU | S_IRWXG | S_IRWXO) | ||
59 | |||
60 | -- | ||
61 | 2.13.2 | ||
62 | |||
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.0.bb b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.1.bb index 6bedf16b0..3dd5c82ee 100644 --- a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.0.bb +++ b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.1.bb | |||
@@ -8,9 +8,8 @@ LIC_FILES_CHKSUM = "file://src/unionfs.c;beginline=3;endline=8;md5=30fa8de70fd8a | |||
8 | 8 | ||
9 | SRC_URI = "git://github.com/rpodgorny/${BPN}.git;branch=master \ | 9 | SRC_URI = "git://github.com/rpodgorny/${BPN}.git;branch=master \ |
10 | file://0001-support-cross-compiling.patch \ | 10 | file://0001-support-cross-compiling.patch \ |
11 | file://0001-unionfs-Define-IOCPARM_LEN-if-undefined.patch \ | ||
12 | " | 11 | " |
13 | SRCREV = "c8d23a9a75f1a62988593671839e8a168a79f3e5" | 12 | SRCREV = "8d732962423c3ca5be1f14b7ec139ff464e10a51" |
14 | 13 | ||
15 | DEPENDS = "fuse" | 14 | DEPENDS = "fuse" |
16 | 15 | ||