diff options
Diffstat (limited to 'meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.14.0.bb')
-rw-r--r-- | meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.14.0.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.14.0.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.14.0.bb new file mode 100644 index 000000000..5d76afe00 --- /dev/null +++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.14.0.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "XFS Filesystem Utilities" | ||
2 | HOMEPAGE = "http://oss.sgi.com/projects/xfs" | ||
3 | SECTION = "base" | ||
4 | LICENSE = "GPLv2 & LGPLv2.1" | ||
5 | LICENSE_libhandle = "LGPLv2.1" | ||
6 | LIC_FILES_CHKSUM = "file://doc/COPYING;md5=102f7fec3d53c7c8f0b7baf9bf9d76a8" | ||
7 | DEPENDS = "util-linux util-linux-native" | ||
8 | SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \ | ||
9 | file://remove_flags_from_build_flags.patch \ | ||
10 | file://0001-build-Check-for-sync_file_range-libc-function.patch \ | ||
11 | " | ||
12 | SRC_URI[md5sum] = "2d50e3751cc98e6c9364bc3d2297b9fd" | ||
13 | SRC_URI[sha256sum] = "b1b710b268bc95d6f45eca06e1262c29eb38865a19cd4404e48ba446e043b7ec" | ||
14 | |||
15 | inherit autotools-brokensep | ||
16 | |||
17 | PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle" | ||
18 | |||
19 | DEPENDS += "util-linux" | ||
20 | |||
21 | RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs ${PN}-repair" | ||
22 | |||
23 | FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs" | ||
24 | FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs" | ||
25 | FILES_${PN}-repair = "${base_sbindir}/xfs_repair" | ||
26 | |||
27 | FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}" | ||
28 | |||
29 | EXTRA_OECONF = "--enable-gettext=no \ | ||
30 | INSTALL_USER=root \ | ||
31 | INSTALL_GROUP=root \ | ||
32 | ac_cv_header_aio_h=yes \ | ||
33 | ac_cv_lib_rt_lio_listio=yes \ | ||
34 | " | ||
35 | |||
36 | DISABLE_STATIC = "" | ||
37 | EXTRA_AUTORECONF += "-I ${S}/m4 --exclude=autoheader" | ||
38 | |||
39 | PACKAGECONFIG ??= "readline blkid" | ||
40 | |||
41 | PACKAGECONFIG[readline] = "--enable-readline=yes,--enable-readline=no,readline" | ||
42 | PACKAGECONFIG[blkid] = "--enable-blkid=yes,--enable-blkid=no,util-linux" | ||
43 | |||
44 | export DEBUG="-DNDEBUG" | ||
45 | export BUILD_VERBOSE="1" | ||
46 | export tagname="CC" | ||
47 | |||
48 | EXTRA_OEMAKE = "DIST_ROOT='${D}'" | ||
49 | |||
50 | do_configure_prepend () { | ||
51 | export BUILD_CC="${BUILD_CC} ${BUILD_CFLAGS}" | ||
52 | # Prevent Makefile from calling configure without arguments, | ||
53 | # when do_configure gets called for a second time. | ||
54 | rm -f ${B}/include/builddefs ${B}/include/platform_defs.h ${B}/configure | ||
55 | # Recreate configure script. | ||
56 | oe_runmake configure | ||
57 | } | ||
58 | |||
59 | do_install_append() { | ||
60 | oe_runmake 'DESTDIR=${D}' install-dev | ||
61 | rm ${D}${libdir}/*.la | ||
62 | rmdir --ignore-fail-on-non-empty ${D}${libdir} | ||
63 | } | ||