summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.12.0.bb')
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.12.0.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.12.0.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.12.0.bb
new file mode 100644
index 000000000..0788695ee
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.12.0.bb
@@ -0,0 +1,65 @@
1SUMMARY = "XFS Filesystem Utilities"
2HOMEPAGE = "http://oss.sgi.com/projects/xfs"
3SECTION = "base"
4LICENSE = "GPLv2 & LGPLv2.1"
5LICENSE_libhandle = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://doc/COPYING;md5=102f7fec3d53c7c8f0b7baf9bf9d76a8"
7DEPENDS = "util-linux util-linux-native"
8SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \
9 file://0001-xfsprogs-remove-double-underscore-integer-types.patch \
10 file://0001-xfs-remove-double-underscore-integer-types.patch \
11 file://remove_flags_from_build_flags.patch \
12 file://xfsprogs-4.12.0-fix_musl.patch \
13 "
14SRC_URI[md5sum] = "e348b0e1d7bd1cd82d64b91ff37e727e"
15SRC_URI[sha256sum] = "b330ad8d737f4152ae511580102e2fc49212bb51dfb4b614084344abae46d0df"
16
17inherit autotools-brokensep
18
19PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle"
20
21DEPENDS += "util-linux"
22
23RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs ${PN}-repair"
24
25FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs"
26FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs"
27FILES_${PN}-repair = "${base_sbindir}/xfs_repair"
28
29FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
30
31EXTRA_OECONF = "--enable-gettext=no \
32 INSTALL_USER=root \
33 INSTALL_GROUP=root \
34 ac_cv_header_aio_h=yes \
35 ac_cv_lib_rt_lio_listio=yes \
36"
37
38DISABLE_STATIC = ""
39EXTRA_AUTORECONF += "-I ${S}/m4 --exclude=autoheader"
40
41PACKAGECONFIG ??= "readline blkid"
42
43PACKAGECONFIG[readline] = "--enable-readline=yes,--enable-readline=no,readline"
44PACKAGECONFIG[blkid] = "--enable-blkid=yes,--enable-blkid=no,util-linux"
45
46export DEBUG="-DNDEBUG"
47export BUILD_VERBOSE="1"
48export tagname="CC"
49
50EXTRA_OEMAKE = "DIST_ROOT='${D}'"
51
52do_configure_prepend () {
53 export BUILD_CC="${BUILD_CC} ${BUILD_CFLAGS}"
54 # Prevent Makefile from calling configure without arguments,
55 # when do_configure gets called for a second time.
56 rm -f ${B}/include/builddefs ${B}/include/platform_defs.h ${B}/configure
57 # Recreate configure script.
58 oe_runmake configure
59}
60
61do_install_append() {
62 oe_runmake 'DESTDIR=${D}' install-dev
63 rm ${D}${libdir}/*.la
64 rmdir --ignore-fail-on-non-empty ${D}${libdir}
65}