summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch')
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch b/meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch
index 231da806c..b5071aea6 100644
--- a/meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch
+++ b/meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch
@@ -1,4 +1,4 @@
1From f8a22f16c03e51d3c779b12f37d362faaa0ecf31 Mon Sep 17 00:00:00 2001 1From 1a4c9ebbb8731f2e3631d77b7eeaf3c373141d88 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 31 Jan 2018 21:28:53 -0800 3Date: Wed, 31 Jan 2018 21:28:53 -0800
4Subject: [PATCH] build: Check for sync_file_range libc function 4Subject: [PATCH] build: Check for sync_file_range libc function
@@ -16,10 +16,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
16 4 files changed, 9 insertions(+), 2 deletions(-) 16 4 files changed, 9 insertions(+), 2 deletions(-)
17 17
18diff --git a/include/builddefs.in b/include/builddefs.in 18diff --git a/include/builddefs.in b/include/builddefs.in
19index b895949..a388c83 100644 19index d38dc7e..706eca6 100644
20--- a/include/builddefs.in 20--- a/include/builddefs.in
21+++ b/include/builddefs.in 21+++ b/include/builddefs.in
22@@ -95,6 +95,7 @@ HAVE_FIEMAP = @have_fiemap@ 22@@ -94,6 +94,7 @@ HAVE_FIEMAP = @have_fiemap@
23 HAVE_PREADV = @have_preadv@ 23 HAVE_PREADV = @have_preadv@
24 HAVE_PWRITEV2 = @have_pwritev2@ 24 HAVE_PWRITEV2 = @have_pwritev2@
25 HAVE_COPY_FILE_RANGE = @have_copy_file_range@ 25 HAVE_COPY_FILE_RANGE = @have_copy_file_range@
@@ -28,11 +28,11 @@ index b895949..a388c83 100644
28 HAVE_SYNCFS = @have_syncfs@ 28 HAVE_SYNCFS = @have_syncfs@
29 HAVE_READDIR = @have_readdir@ 29 HAVE_READDIR = @have_readdir@
30diff --git a/io/Makefile b/io/Makefile 30diff --git a/io/Makefile b/io/Makefile
31index 00ede48..dd001b0 100644 31index 484e2b5..2751dcb 100644
32--- a/io/Makefile 32--- a/io/Makefile
33+++ b/io/Makefile 33+++ b/io/Makefile
34@@ -60,10 +60,13 @@ CFILES += inject.c resblks.c 34@@ -53,10 +53,13 @@ else
35 LCFLAGS += -DHAVE_INJECT -DHAVE_RESBLKS 35 LSRCFILES += fiemap.c
36 endif 36 endif
37 37
38-ifeq ($(HAVE_COPY_FILE_RANGE),yes) 38-ifeq ($(HAVE_COPY_FILE_RANGE),yes)
@@ -47,10 +47,10 @@ index 00ede48..dd001b0 100644
47 ifeq ($(HAVE_SYNC_FILE_RANGE),yes) 47 ifeq ($(HAVE_SYNC_FILE_RANGE),yes)
48 CFILES += sync_file_range.c 48 CFILES += sync_file_range.c
49diff --git a/io/io.h b/io/io.h 49diff --git a/io/io.h b/io/io.h
50index e1f3d95..fe2e6a2 100644 50index 6469179..678b3d7 100644
51--- a/io/io.h 51--- a/io/io.h
52+++ b/io/io.h 52+++ b/io/io.h
53@@ -151,7 +151,7 @@ extern void fiemap_init(void); 53@@ -146,7 +146,7 @@ extern void fiemap_init(void);
54 #define fiemap_init() do { } while (0) 54 #define fiemap_init() do { } while (0)
55 #endif 55 #endif
56 56