diff options
Diffstat (limited to 'meta-filesystems/recipes-utils/udevil/files')
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/udevil/files/0001-udevil-0.4.3-fix-compile-with-gcc6.patch b/meta-filesystems/recipes-utils/udevil/files/0001-udevil-0.4.3-fix-compile-with-gcc6.patch new file mode 100644 index 000000000..355e93a37 --- /dev/null +++ b/meta-filesystems/recipes-utils/udevil/files/0001-udevil-0.4.3-fix-compile-with-gcc6.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | Fix compilation with GCC6 | ||
2 | |||
3 | --- a/src/device-info.c 2013-12-09 14:59:27.000000000 +0100 | ||
4 | +++ b/src/device-info.c 2017-03-13 07:06:25.506666680 +0100 | ||
5 | @@ -3,6 +3,7 @@ | ||
6 | * contains code excerpts from udisks v1.0.4 | ||
7 | ************************************************************************** */ | ||
8 | |||
9 | +#include <sys/stat.h> | ||
10 | #include "device-info.h" | ||
11 | |||
12 | static char * | ||
diff --git a/meta-filesystems/recipes-utils/udevil/files/0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch b/meta-filesystems/recipes-utils/udevil/files/0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch new file mode 100644 index 000000000..f014a0f53 --- /dev/null +++ b/meta-filesystems/recipes-utils/udevil/files/0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 80b087193698632e525b90d45b4a49e61e343e1c Mon Sep 17 00:00:00 2001 | ||
2 | From: Krzysztof Kozlowski <krzk@kernel.org> | ||
3 | Date: Thu, 13 Jul 2017 21:30:35 +0200 | ||
4 | Subject: [PATCH] etc: Makefile.am: Use systemd_unitdir instead of libdir | ||
5 | |||
6 | Proper directory for installing systemd services is systemd_unitdir, not | ||
7 | libdir. | ||
8 | |||
9 | Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> | ||
10 | --- | ||
11 | etc/Makefile.am | 6 +++--- | ||
12 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
13 | |||
14 | diff --git a/etc/Makefile.am b/etc/Makefile.am | ||
15 | index 9b6e7522c20f..6d663241a72f 100644 | ||
16 | --- a/etc/Makefile.am | ||
17 | +++ b/etc/Makefile.am | ||
18 | @@ -16,8 +16,8 @@ if ADD_SYSTEMD | ||
19 | test -f $(DESTDIR)/$(sysconfdir)/conf.d/devmon || $(INSTALL_DATA) \ | ||
20 | $(srcdir)/systemd/devmon \ | ||
21 | $(DESTDIR)/$(sysconfdir)/conf.d/devmon | ||
22 | - test -d $(DESTDIR)/$(libdir)/systemd/system || \ | ||
23 | - mkdir -p -- $(DESTDIR)/$(libdir)/systemd/system | ||
24 | + test -d $(DESTDIR)/$(systemd_unitdir)/system || \ | ||
25 | + mkdir -p -- $(DESTDIR)/$(systemd_unitdir)/system | ||
26 | $(INSTALL_DATA) $(srcdir)/systemd/devmon@.service \ | ||
27 | - $(DESTDIR)/$(libdir)/systemd/system/devmon@.service | ||
28 | + $(DESTDIR)/$(systemd_unitdir)/system/devmon@.service | ||
29 | endif | ||
30 | -- | ||
31 | 2.11.0 | ||
32 | |||