summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch')
-rw-r--r--meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch b/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch
deleted file mode 100644
index 6732dc42e..000000000
--- a/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From daf04dc9ca1f2e4c65ec338ab439e0a792e1a8ac Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 5 Sep 2017 10:36:52 -0700
4Subject: [PATCH] libau: Define STRIP weakly
5
6STRIP can be set on environment to use cross version of strip utility
7hardcoding to strip is not working in cross environment
8
9Upstream-Status: Submitted
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12
13---
14 libau/Makefile | 3 ++-
15 1 file changed, 2 insertions(+), 1 deletion(-)
16
17diff --git a/libau/Makefile b/libau/Makefile
18index 81520ac..c25eef2 100644
19--- a/libau/Makefile
20+++ b/libau/Makefile
21@@ -25,6 +25,7 @@ LibSoHdr = libau.h rdu.h
22 LibSoExport = $(addsuffix .exp, $(basename ${LibSoObj}))
23 LibSoExportErr = $(addsuffix .err, ${LibSoExport})
24 LibSoVerScript = verscript
25+STRIP ?= strip
26
27 all: ${LibSo}
28
29@@ -77,7 +78,7 @@ ${LibSo}.${LibSoMajor}.${LibSoMinor}: ${LibSoObj}
30 ${CC} --shared -Wl,-soname,${LibSo}.${LibSoMajor} \
31 -Wl,--version-script,${LibSoVerScript} \
32 ${LDFLAGS} -o $@ $^ ${LDLIBS}
33- strip -R EXP $@
34+ ${STRIP} -R EXP $@
35 # readelf --syms --use-dynamic libau.so
36
37 install_ulib: File = ${LibSo}.${LibSoMajor}.${LibSoMinor}