summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/fuse-exfat/fuse-exfat_1.0.1.bb26
-rw-r--r--meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.2.bb16
-rw-r--r--meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2013.1.13.bb39
-rwxr-xr-xmeta-filesystems/recipes-filesystems/owfs/owfs/owhttpd60
-rwxr-xr-xmeta-filesystems/recipes-filesystems/owfs/owfs/owserver59
-rw-r--r--meta-filesystems/recipes-filesystems/owfs/owfs_2.9p1.bb68
-rw-r--r--meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/configure.patch11
-rw-r--r--meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb25
-rw-r--r--meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_2.5.bb17
-rw-r--r--meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_0.26.bb15
-rw-r--r--meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb35
11 files changed, 371 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/fuse-exfat/fuse-exfat_1.0.1.bb b/meta-filesystems/recipes-filesystems/fuse-exfat/fuse-exfat_1.0.1.bb
new file mode 100644
index 000000000..f984c4bb7
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/fuse-exfat/fuse-exfat_1.0.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "read and write exFAT driver for FUSE"
2DESCRIPTION = "fuse-exfat is a read and write driver implementing the \
3extended file allocation table as a filesystem in userspace. A mounthelper \
4is provided unter the name mount.exfat-fuse. \
5"
6HOMEPAGE = "http://code.google.com/p/exfat/"
7SECTION = "universe/otherosfs"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10SRC_URI = "${DEBIAN_MIRROR}/main/f/fuse-exfat/fuse-exfat_${PV}.orig.tar.gz \
11"
12DEPENDS = "fuse virtual/libc"
13RRECOMMENDS_${PN} = "util-linux-mount"
14
15inherit scons
16
17SRC_URI[md5sum] = "7988a5111841593231f20af22153362d"
18SRC_URI[sha256sum] = "12ac1ba1b7d4343bef64e7898176705a41cfe3b5a7a179e28549d242e2854758"
19
20EXTRA_OESCONS = " \
21 DESTDIR=${D}/${base_sbindir} \
22"
23
24do_install_prepend() {
25 install -d ${D}/${base_sbindir}
26}
diff --git a/meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.2.bb b/meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.2.bb
new file mode 100644
index 000000000..42f4c872b
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.2.bb
@@ -0,0 +1,16 @@
1SUMMARY = "A fuse filesystem to access the contents of an iPhone or iPod Touch"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=6ab17b41640564434dda85c06b7124f7"
4HOMEPAGE ="http://www.libimobiledevice.org/"
5
6PNBLACKLIST[ifuse] ?= "depends on blacklisted libimobiledevice"
7DEPENDS = "fuse libimobiledevice"
8
9SRC_URI = " \
10 http://www.libimobiledevice.org/downloads/ifuse-${PV}.tar.bz2 \
11"
12
13SRC_URI[md5sum] = "4152526b2ac3c505cb41797d997be14d"
14SRC_URI[sha256sum] = "47835c8afb72588b3202fe0b206d7ea37a68663d9aa4eaf73f0a4bcb6215fc05"
15
16inherit autotools pkgconfig
diff --git a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2013.1.13.bb b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2013.1.13.bb
new file mode 100644
index 000000000..6957ea92b
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2013.1.13.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "The NTFS-3G driver is an open source, freely available NTFS driver for Linux with read and write support."
2HOMEPAGE = "http://www.ntfs-3g.org/"
3DEPENDS = "fuse libgcrypt"
4PROVIDES = "ntfsprogs ntfs-3g"
5LICENSE = "GPLv2 & LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8
9SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz"
10S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}"
11
12SRC_URI[md5sum] = "2d6fb47ddf62b51733227126fe9227fe"
13SRC_URI[sha256sum] = "4b383f0074a3ab7683339d1f18222b107aaeb4983db119292c43c2b275cefb27"
14
15inherit autotools pkgconfig
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[uuid] = "--with-uuid,--without-uuid,util-linux"
19
20# required or it calls ldconfig at install step
21EXTRA_OEMAKE = "LDCONFIG=echo"
22
23PACKAGES =+ "ntfs-3g ntfsprogs libntfs-3g"
24
25FILES_ntfs-3g = "${base_sbindir}/*.ntfs-3g ${bindir}/ntfs-3g* ${base_sbindir}/mount.ntfs"
26RDEPENDS_ntfs-3g += "fuse"
27RRECOMMENDS_ntfs-3g = "util-linux-mount"
28
29FILES_ntfsprogs = "${base_sbindir}/* ${bindir}/* ${sbindir}/*"
30FILES_libntfs-3g = "${libdir}/*${SOLIBS}"
31
32do_install_append() {
33 # Standard mount will execute the program /sbin/mount.TYPE
34 # when called. Add the symbolic to let mount could find ntfs.
35 ln -sf mount.ntfs-3g ${D}/${base_sbindir}/mount.ntfs
36}
37
38# Satisfy the -dev runtime dependency
39ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs/owhttpd b/meta-filesystems/recipes-filesystems/owfs/owfs/owhttpd
new file mode 100755
index 000000000..5d74d13d9
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs/owhttpd
@@ -0,0 +1,60 @@
1#!/bin/sh
2
3PATH=/sbin:/bin:/usr/bin
4
5DAEMON="owhttpd"
6
7test -f /usr/bin/${DAEMON} || exit 0
8
9if test -f /etc/default/${DAEMON} ; then
10. /etc/default/${DAEMON}
11else
12:
13fi
14
15if [ "$START_OWHTTPD" != "yes" ]
16then
17 exit 0
18fi
19
20
21startdaemon(){
22 echo -n "Starting ${DAEMON}: "
23 start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
24 echo "done"
25}
26
27stopdaemon(){
28 echo -n "Stopping ${DAEMON}: "
29 start-stop-daemon --stop -p /var/run/${DAEMON}.pid
30 echo "done"
31}
32
33
34
35case "$1" in
36 start)
37 startdaemon
38 ;;
39 stop)
40 stopdaemon
41 ;;
42 force-reload)
43 stopdaemon
44 startdaemon
45 ;;
46 restart)
47 stopdaemon
48 startdaemon
49 ;;
50 reload)
51 stopdaemon
52 startdaemon
53 ;;
54 *)
55 echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
56 exit 1
57 ;;
58esac
59
60exit 0
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs/owserver b/meta-filesystems/recipes-filesystems/owfs/owfs/owserver
new file mode 100755
index 000000000..b69ea53e3
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs/owserver
@@ -0,0 +1,59 @@
1#!/bin/sh
2
3PATH=/sbin:/bin:/usr/bin
4
5DAEMON="owserver"
6
7test -f /usr/bin/${DAEMON} || exit 0
8
9if test -f /etc/default/${DAEMON} ; then
10. /etc/default/${DAEMON}
11else
12:
13fi
14
15if [ "$START_OWSERVER" != "yes" ]
16then
17 exit 0
18fi
19
20startdaemon(){
21 echo -n "Starting ${DAEMON}: "
22 start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
23 echo "done"
24}
25
26stopdaemon(){
27 echo -n "Stopping ${DAEMON}: "
28 start-stop-daemon --stop -p /var/run/${DAEMON}.pid
29 echo "done"
30}
31
32
33
34case "$1" in
35 start)
36 startdaemon
37 ;;
38 stop)
39 stopdaemon
40 ;;
41 force-reload)
42 stopdaemon
43 startdaemon
44 ;;
45 restart)
46 stopdaemon
47 startdaemon
48 ;;
49 reload)
50 stopdaemon
51 startdaemon
52 ;;
53 *)
54 echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
55 exit 1
56 ;;
57esac
58
59exit 0
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs_2.9p1.bb b/meta-filesystems/recipes-filesystems/owfs/owfs_2.9p1.bb
new file mode 100644
index 000000000..21fd7e93e
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs_2.9p1.bb
@@ -0,0 +1,68 @@
1SUMMARY = "1-Wire file system"
2DESCRIPTION = "OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim"
3HOMEPAGE = "http://www.owfs.org/"
4SECTION = "console/network"
5
6LICENSE = "GPLv2 & LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=a0bc427f423a41220ab79a0b392218bd \
8 file://COPYING.LIB;md5=865c4bd642d9e04f43925ad7e929ae87"
9
10DEPENDS = "fuse virtual/libusb0"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/owfs/owfs-${PV}.tar.gz \
13 file://owhttpd \
14 file://owserver "
15SRC_URI[md5sum] = "56ba145be208002e58775a7203369851"
16SRC_URI[sha256sum] = "9d22dbff72d235476688c02669f7171b23e21dffadf40bbdd3b8263908218424"
17
18inherit autotools-brokensep update-rc.d
19
20EXTRA_OECONF = " \
21 --with-fuseinclude=${STAGING_INCDIR} \
22 --with-fuselib=${STAGING_LIBDIR} \
23 --enable-owfs \
24 --enable-owhttpd \
25 --enable-w1 \
26 --disable-swig \
27 --disable-owtcl \
28 --disable-owphp \
29 --disable-owpython \
30 --disable-owperl \
31"
32
33do_install_prepend() {
34 install -d ${D}${sysconfdir}/default/
35 install -d ${D}${sysconfdir}/init.d/
36 install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
37 install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver
38}
39
40PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
41
42DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access"
43DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control"
44DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control"
45DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
46DESCRIPTION_libowcapi = "easy C-language 1-wire interface "
47DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol"
48DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol"
49DESCRIPTION_owmon = "Monitor for owserver settings and statistics"
50DESCRIPTION_owtap = "Packet sniffer for the owserver protocol"
51
52FILES_owftpd = "${bindir}/owftpd"
53FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd"
54FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver"
55FILES_owshell = "${bindir}/owread ${bindir}/owwrite \
56 ${bindir}/owdir ${bindir}/owpresent \
57 ${bindir}/owget ${bindir}/owside"
58FILES_owmon = "${bindir}/owmon"
59FILES_owtap = "${bindir}/owtap"
60FILES_libowcapi = "${libdir}/libowcapi-*"
61FILES_libow = "${libdir}/libow-*"
62FILES_libownet = "${libdir}/libownet-*"
63
64INITSCRIPT_PACKAGES = "owhttpd owserver"
65INITSCRIPT_NAME_owserver = "owserver"
66INITSCRIPT_NAME_owhttpd = "owhttpd"
67INITSCRIPT_PARAMS_owserver = "defaults 20"
68INITSCRIPT_PARAMS_owhttpd = "defaults 21"
diff --git a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/configure.patch b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/configure.patch
new file mode 100644
index 000000000..c80fed187
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/configure.patch
@@ -0,0 +1,11 @@
1Index: git/configure.in
2===================================================================
3--- git.orig/configure.in 2014-06-18 16:06:16.040721349 +0000
4+++ git/configure.in 2014-07-18 07:49:17.085552256 +0000
5@@ -1,5 +1,5 @@
6 AC_INIT([SMBNetFS],[0.5.3а])
7-AM_INIT_AUTOMAKE
8+AM_INIT_AUTOMAKE([foreign])
9 AC_CONFIG_HEADERS([src/config.h])
10 AC_PROG_CC
11
diff --git a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
new file mode 100644
index 000000000..a0eddbc79
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
@@ -0,0 +1,25 @@
1SUMMARY = "FUSE module for mounting an entire SMB/NMB network in a single directory"
2DESCRIPTION = "SMBNetFS is a Linux/FreeBSD filesystem that allow you to use \
3 samba/microsoft network in the same manner as the network \
4 neighborhood in Microsoft Windows. Please donate me to help \
5 in SMBNetFS development."
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9HOMEPAGE ="http://sourceforge.net/projects/smbnetfs"
10
11DEPENDS = "fuse samba"
12
13inherit autotools gitpkgv pkgconfig
14
15PKGV = "${GITPKGVTAG}"
16
17SRCREV = "ace1c519d45fe488b9b7e6cc77a2bcadb6c83464"
18
19SRC_URI = "git://smbnetfs.git.sourceforge.net/gitroot/smbnetfs/smbnetfs;branch=master \
20 file://configure.patch"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring=yes,--with-gnome-keyring=no,libgnome-keyring"
24
25S = "${WORKDIR}/git"
diff --git a/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_2.5.bb b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_2.5.bb
new file mode 100644
index 000000000..459d1575e
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_2.5.bb
@@ -0,0 +1,17 @@
1SUMMARY = "This is a filesystem client based on the SSH File Transfer Protocol using FUSE"
2AUTHOR = "Miklos Szeredi <miklos@szeredi.hu>"
3HOMEPAGE = "http://fuse.sourceforge.net/sshfs.html"
4SECTION = "console/network"
5LICENSE = "GPLv2"
6DEPENDS = "glib-2.0 fuse"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/${BP}.tar.gz"
10S = "${WORKDIR}/${P}"
11
12inherit autotools pkgconfig
13
14FILES_${PN} += "${libdir}/sshnodelay.so"
15
16SRC_URI[md5sum] = "17494910db8383a366b1301e5f5148a9"
17SRC_URI[sha256sum] = "e9171452e5d0150b9c6a2158fd2e2dcefb5d5d03ba4d208949e00a3a46c6e63e"
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_0.26.bb b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_0.26.bb
new file mode 100644
index 000000000..38ded9f68
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_0.26.bb
@@ -0,0 +1,15 @@
1SUMMARY = "A FUSE based implemention of unionfs"
2HOMEPAGE = "http://podgorny.cz/moin/UnionFsFuse"
3SECTION = "console/network"
4LICENSE = "BSD-3-Clause"
5DEPENDS = "fuse"
6LIC_FILES_CHKSUM = "file://src/unionfs.c;beginline=3;endline=8;md5=30fa8de70fd8abab00b483a1b7943a32"
7
8SRC_URI = "http://podgorny.cz/unionfs-fuse/releases/${BP}.tar.xz"
9
10SRC_URI[md5sum] = "689c636484756f6f7a728ef354cbeac2"
11SRC_URI[sha256sum] = "8d5c9dcb51ecb9a9b03890e16d17e37d602b0c1f23ed6a9ddec2b0f719c9f662"
12
13do_install() {
14 oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix}
15}
diff --git a/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb b/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb
new file mode 100644
index 000000000..0e1e460b6
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Yet Another Flash File System"
2DESCRIPTION = "Tools for managing 'yaffs2' file systems."
3
4SECTION = "base"
5HOMEPAGE = "http://www.yaffs.net"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=12;endline=14;md5=5f5464f9b3e981ca574e65b00e438561"
9
10PV = "0.0+git${SRCPV}"
11
12DEPENDS = "mtd-utils"
13
14# Source is the HEAD of master branch at the time of writing this recipe
15SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master"
16SRCREV = "bc76682d93955cfb33051beb503ad9f8a5450578"
17S = "${WORKDIR}/git"
18
19CFLAGS_append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES"
20
21do_compile() {
22 cd utils && oe_runmake
23}
24
25INSTALL_FILES = "mkyaffsimage \
26 mkyaffs2image \
27 "
28do_install() {
29 install -d ${D}${sbindir}/
30 for i in ${INSTALL_FILES}; do
31 install -m 0755 utils/$i ${D}${sbindir}/
32 done
33}
34
35BBCLASSEXTEND = "native"