summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch')
-rw-r--r--meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch b/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch
new file mode 100644
index 000000000..bf363ca1b
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch
@@ -0,0 +1,32 @@
1From 449cec34c123b86b792627553c6ec7471d2ee7ed Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 30 Jun 2017 14:46:51 +0800
4Subject: [PATCH] support cross compiling
5
6Do not override OE CMAKE variables
7
8Upstream-Status: Pending
9
10Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
11---
12 CMakeLists.txt | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/CMakeLists.txt b/CMakeLists.txt
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -10,9 +10,9 @@ IF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
19 ENDIF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
20
21 # Select flags.
22-SET(CMAKE_C_FLAGS "-pipe -W -Wall -DFORTIFY_SOURCE=2")
23+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pipe -W -Wall -DFORTIFY_SOURCE=2")
24 SET(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
25-SET(CMAKE_C_FLAGS_RELEASE "-O2")
26+SET(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O2")
27 SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -DDEBUG")
28
29 if (UNIX AND APPLE)
30--
312.8.1
32