diff options
Diffstat (limited to 'meta-efl')
-rw-r--r-- | meta-efl/recipes-efl/webkit/webkit-efl/0001-CMake-Do-not-pass-P-to-the-preprocessor-when-running.patch | 76 | ||||
-rw-r--r-- | meta-efl/recipes-efl/webkit/webkit-efl_svn.bb | 3 |
2 files changed, 78 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/0001-CMake-Do-not-pass-P-to-the-preprocessor-when-running.patch b/meta-efl/recipes-efl/webkit/webkit-efl/0001-CMake-Do-not-pass-P-to-the-preprocessor-when-running.patch new file mode 100644 index 000000000..dcd3a4672 --- /dev/null +++ b/meta-efl/recipes-efl/webkit/webkit-efl/0001-CMake-Do-not-pass-P-to-the-preprocessor-when-running.patch | |||
@@ -0,0 +1,76 @@ | |||
1 | From 3dfc99730b99472d642f19b825fb9794e32a05c4 Mon Sep 17 00:00:00 2001 | ||
2 | From: "rakuco@webkit.org" | ||
3 | <rakuco@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc> | ||
4 | Date: Tue, 10 Apr 2012 22:59:04 +0000 | ||
5 | Subject: [PATCH] [CMake] Do not pass -P to the preprocessor when running | ||
6 | make_names.pl. | ||
7 | https://bugs.webkit.org/show_bug.cgi?id=83225 | ||
8 | |||
9 | Reviewed by Rob Buis. | ||
10 | |||
11 | This is necessary to make CMake-based ports build with the | ||
12 | recently-released GCC 4.7.0, whose preprocessor seems to ignore | ||
13 | empty lines when -P is passed to it. Such behavior breaks | ||
14 | make_names.pl (in fact, InFilesParser.pm), which expects an empty | ||
15 | line to separate common and specific sections in .in files. | ||
16 | |||
17 | A fix for this same problem has been supposedly done in r84123, | ||
18 | but as the CMake-based ports always pass --preprocessor to the | ||
19 | Perl tools the fix never reached us. | ||
20 | |||
21 | The idea is to define CODE_GENERATOR_PREPROCESSOR_WITH_LINEMARKERS | ||
22 | for (!MSVC && !QNX) and use it in the macros which call | ||
23 | make_names.pl. | ||
24 | |||
25 | * Source/cmake/OptionsCommon.cmake: | ||
26 | * Source/cmake/WebKitMacros.cmake: | ||
27 | |||
28 | git-svn-id: http://svn.webkit.org/repository/webkit/trunk@113786 268f45cc-cd09-0410-ab3c-d52691b4dbfc | ||
29 | --- | ||
30 | ChangeLog | 24 ++++++++++++++++++++++++ | ||
31 | Source/cmake/OptionsCommon.cmake | 7 +++++++ | ||
32 | Source/cmake/WebKitMacros.cmake | 2 +- | ||
33 | 3 files changed, 32 insertions(+), 1 deletions(-) | ||
34 | |||
35 | diff --git a/Source/cmake/OptionsCommon.cmake b/Source/cmake/OptionsCommon.cmake | ||
36 | index 11581e6..37cb4a8 100644 | ||
37 | --- a/Source/cmake/OptionsCommon.cmake | ||
38 | +++ b/Source/cmake/OptionsCommon.cmake | ||
39 | @@ -5,14 +5,21 @@ IF (WTF_OS_UNIX) | ||
40 | ADD_DEFINITIONS(-DXP_UNIX) | ||
41 | ENDIF (WTF_OS_UNIX) | ||
42 | |||
43 | +# CODE_GENERATOR_PREPROCESSOR_WITH_LINEMARKERS only matters with GCC >= 4.7.0. Since this | ||
44 | +# version, -P does not output empty lines, which currently breaks make_names.pl in | ||
45 | +# WebCore. Investigating whether make_names.pl should be changed instead is left as an exercise to | ||
46 | +# the reader. | ||
47 | IF (MSVC) | ||
48 | # FIXME: Some codegenerators don't support paths with spaces. So use the executable name only. | ||
49 | GET_FILENAME_COMPONENT(CODE_GENERATOR_PREPROCESSOR_EXECUTABLE ${CMAKE_CXX_COMPILER} NAME) | ||
50 | SET(CODE_GENERATOR_PREPROCESSOR "${CODE_GENERATOR_PREPROCESSOR_EXECUTABLE} /nologo /EP") | ||
51 | + SET(CODE_GENERATOR_PREPROCESSOR_WITH_LINEMARKERS "${CODE_GENERATOR_PREPROCESSOR}") | ||
52 | ELSEIF (CMAKE_SYSTEM_NAME MATCHES QNX) | ||
53 | SET(CODE_GENERATOR_PREPROCESSOR "${CMAKE_CXX_COMPILER} -E -Wp,-P -x c++") | ||
54 | + SET(CODE_GENERATOR_PREPROCESSOR_WITH_LINEMARKERS "${CODE_GENERATOR_PREPROCESSOR}") | ||
55 | ELSE () | ||
56 | SET(CODE_GENERATOR_PREPROCESSOR "${CMAKE_CXX_COMPILER} -E -P -x c++") | ||
57 | + SET(CODE_GENERATOR_PREPROCESSOR_WITH_LINEMARKERS "${CMAKE_CXX_COMPILER} -E -x c++") | ||
58 | ENDIF () | ||
59 | |||
60 | SET_PROPERTY(GLOBAL PROPERTY USE_FOLDERS ON) | ||
61 | diff --git a/Source/cmake/WebKitMacros.cmake b/Source/cmake/WebKitMacros.cmake | ||
62 | index 3abe342..4e7ca9f 100644 | ||
63 | --- a/Source/cmake/WebKitMacros.cmake | ||
64 | +++ b/Source/cmake/WebKitMacros.cmake | ||
65 | @@ -89,7 +89,7 @@ MACRO (GENERATE_DOM_NAMES _namespace _attrs) | ||
66 | ADD_CUSTOM_COMMAND( | ||
67 | OUTPUT ${_outputfiles} | ||
68 | DEPENDS ${NAMES_GENERATOR} ${SCRIPTS_BINDINGS} ${_attrs} ${_tags} | ||
69 | - COMMAND ${PERL_EXECUTABLE} -I${WEBCORE_DIR}/bindings/scripts ${NAMES_GENERATOR} --preprocessor "${CODE_GENERATOR_PREPROCESSOR}" --outputDir ${DERIVED_SOURCES_WEBCORE_DIR} ${_arguments} ${_additionArguments} | ||
70 | + COMMAND ${PERL_EXECUTABLE} -I${WEBCORE_DIR}/bindings/scripts ${NAMES_GENERATOR} --preprocessor "${CODE_GENERATOR_PREPROCESSOR_WITH_LINEMARKERS}" --outputDir ${DERIVED_SOURCES_WEBCORE_DIR} ${_arguments} ${_additionArguments} | ||
71 | VERBATIM) | ||
72 | ENDMACRO () | ||
73 | |||
74 | -- | ||
75 | 1.7.7 | ||
76 | |||
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb index c0e346ce0..cd3809654 100644 --- a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb +++ b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb | |||
@@ -11,7 +11,7 @@ DEPENDS = "icu libxslt sqlite3 gperf-native bison-native flex-native jpeg \ | |||
11 | 11 | ||
12 | SRCREV = "105069" | 12 | SRCREV = "105069" |
13 | PV = "1.7.3+svnr${SRCPV}" | 13 | PV = "1.7.3+svnr${SRCPV}" |
14 | PR = "r1" | 14 | PR = "r2" |
15 | 15 | ||
16 | SRCREV_FORMAT = "source" | 16 | SRCREV_FORMAT = "source" |
17 | 17 | ||
@@ -20,6 +20,7 @@ SRC_URI = "\ | |||
20 | svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http;subdir=src \ | 20 | svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http;subdir=src \ |
21 | svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \ | 21 | svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \ |
22 | file://0001-JavaScriptCore-add-EINA_LIBRARIES-to-shell-build-for.patch \ | 22 | file://0001-JavaScriptCore-add-EINA_LIBRARIES-to-shell-build-for.patch \ |
23 | file://0001-CMake-Do-not-pass-P-to-the-preprocessor-when-running.patch \ | ||
23 | file://CMakeLists.txt \ | 24 | file://CMakeLists.txt \ |
24 | " | 25 | " |
25 | 26 | ||