summaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl/0006-OptionsEfl.cmake-Fix-build-with-newer-CMake-3.4.patch30
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/0006-OptionsEfl.cmake-Fix-build-with-newer-CMake-3.4.patch b/meta-efl/recipes-efl/webkit/webkit-efl/0006-OptionsEfl.cmake-Fix-build-with-newer-CMake-3.4.patch
new file mode 100644
index 000000000..05626349b
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl/0006-OptionsEfl.cmake-Fix-build-with-newer-CMake-3.4.patch
@@ -0,0 +1,30 @@
1From 993882f81fe991b8baf1099392703337cc13fac0 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Wed, 27 Jan 2016 18:40:23 +0100
4Subject: [PATCH] OptionsEfl.cmake: Fix build with newer CMake 3.4
5
6* otherwise it fails with:
7 | CMake Error at Source/cmake/OptionsEfl.cmake:251 (CHECK_INCLUDE_FILES):
8 | Unknown CMake command "CHECK_INCLUDE_FILES".
9* https://bugs.webkit.org/show_bug.cgi?id=150117
10
11Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
12---
13 Source/cmake/OptionsEfl.cmake | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/Source/cmake/OptionsEfl.cmake b/Source/cmake/OptionsEfl.cmake
17index 1aa9002..05216d0 100644
18--- a/Source/cmake/OptionsEfl.cmake
19+++ b/Source/cmake/OptionsEfl.cmake
20@@ -253,6 +253,7 @@ if (ENABLE_WEBGL OR WTF_USE_TILED_BACKING_STORE)
21 set(WTF_USE_EGL 1)
22 add_definitions(-DWTF_USE_EGL=1)
23 else ()
24+ include(CheckIncludeFiles)
25 CHECK_INCLUDE_FILES("GL/glx.h" OPENGLX_FOUND)
26 add_definitions(-DWTF_USE_GLX=1)
27 endif ()
28--
292.7.0
30
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb b/meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb
index 07cbd89d0..96ad83029 100644
--- a/meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb
+++ b/meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb
@@ -6,6 +6,7 @@ SRC_URI += "\
6 file://0003-FEBlendNEON.h-fix-missing-semicolon.patch \ 6 file://0003-FEBlendNEON.h-fix-missing-semicolon.patch \
7 file://0004-Fix-the-build-with-EFL-1.12-https-bugs.webkit.org-sh.patch \ 7 file://0004-Fix-the-build-with-EFL-1.12-https-bugs.webkit.org-sh.patch \
8 file://0005-Fix-the-build-with-cmake-3.patch \ 8 file://0005-Fix-the-build-with-cmake-3.patch \
9 file://0006-OptionsEfl.cmake-Fix-build-with-newer-CMake-3.4.patch \
9" 10"
10SRC_URI[md5sum] = "90fa970ebf8646319d292c2bb5bff5db" 11SRC_URI[md5sum] = "90fa970ebf8646319d292c2bb5bff5db"
11SRC_URI[sha256sum] = "d8d21e27f4a21cd77c41914548c184ddb98693ba23851aa66c8e51c0be4b90b7" 12SRC_URI[sha256sum] = "d8d21e27f4a21cd77c41914548c184ddb98693ba23851aa66c8e51c0be4b90b7"