summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-efl/recipes-efl/webkit/webkit-efl_svn.bb')
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl_svn.bb20
1 files changed, 13 insertions, 7 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
index 9f02a595e..77aef024b 100644
--- a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
+++ b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
@@ -1,25 +1,31 @@
1DESCRIPTION = "Webkit browser engine, EFL edition" 1DESCRIPTION = "Webkit browser engine, EFL edition"
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \ 3LIC_FILES_CHKSUM = "file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
4 file://JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \ 4 file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
5 file://WebKit/efl/ewk/EWebKit.h;endline=20;md5=55ea170b1582797d2c69712de850f2fa \ 5 file://Source/WebKit/efl/ewk/EWebKit.h;endline=20;md5=55ea170b1582797d2c69712de850f2fa \
6" 6"
7 7
8DEPENDS = "icu libxslt sqlite3 gperf-native bison-native flex-native jpeg \ 8DEPENDS = "icu libxslt sqlite3 gperf-native bison-native flex-native jpeg \
9 libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \ 9 libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \
10 libxml2 pango eina ecore evas edje" 10 libxml2 pango eina ecore evas edje"
11 11
12SRCREV = "97724" 12SRCREV = "105069"
13PV = "1.6.1+svnr${SRCPV}" 13PV = "1.7.3+svnr${SRCPV}"
14 14
15SRCREV_FORMAT = "source" 15SRCREV_FORMAT = "source"
16 16
17SRC_URI = "\ 17SRC_URI = "\
18 svn://svn.webkit.org/repository/webkit/trunk;module=Source;name=source;proto=http;subdir=src \ 18 svn://svn.webkit.org/repository/webkit/trunk;module=Source;name=source;proto=http;subdir=src \
19 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http;subdir=src \
19 svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \ 20 svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \
20 " 21 file://CMakeLists.txt \
22"
23
24S = "${WORKDIR}/src"
21 25
22S = "${WORKDIR}/src/Source" 26do_configure_prepend() {
27 cp ${WORKDIR}/CMakeLists.txt ${S};
28}
23 29
24inherit cmake lib_package pkgconfig perlnative 30inherit cmake lib_package pkgconfig perlnative
25 31