diff options
Diffstat (limited to 'meta-efl/recipes-efl/efl/efl.inc')
-rw-r--r-- | meta-efl/recipes-efl/efl/efl.inc | 145 |
1 files changed, 145 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/efl/efl.inc b/meta-efl/recipes-efl/efl/efl.inc new file mode 100644 index 000000000..0d149660f --- /dev/null +++ b/meta-efl/recipes-efl/efl/efl.inc | |||
@@ -0,0 +1,145 @@ | |||
1 | SUMMARY = "EFL" | ||
2 | LICENSE = "MIT BSD LGPL-2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=a1809a807e39dd48ddcf7be98477d130" | ||
4 | |||
5 | DEPENDS_class-native = "lua5.1-native freetype-native libxext-native libpng-native jpeg-native tiff-native libfribidi-native glib-2.0-native dbus-native" | ||
6 | DEPENDS = "virtual/libiconv tslib curl glib-2.0 gnutls pkgconfig zlib jpeg openssl libsndfile1 lua5.1 dbus libexif librsvg freetype libpng tiff libxext virtual/libx11 libxrender fontconfig libfribidi giflib udev libxcursor libxcomposite libxinerama libxrandr libxtst libxscrnsaver efl-native" | ||
7 | |||
8 | inherit efl gettext pkgconfig | ||
9 | |||
10 | BBCLASSEXTEND = "native" | ||
11 | |||
12 | PROVIDES += "ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus" | ||
13 | |||
14 | # we don't have bullet for physics | ||
15 | EXTRA_OECONF = " \ | ||
16 | --disable-physics \ | ||
17 | " | ||
18 | EXTRA_OECONF_append_class-target = " \ | ||
19 | --with-bin-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \ | ||
20 | " | ||
21 | EXTRA_OECONF_append_class-native = " \ | ||
22 | --disable-fontconfig \ | ||
23 | --disable-audio \ | ||
24 | --with-x11=none \ | ||
25 | --disable-image-loader-bmp \ | ||
26 | --disable-image-loader-eet \ | ||
27 | --disable-image-loader-generic \ | ||
28 | --disable-image-loader-gif \ | ||
29 | --disable-image-loader-ico \ | ||
30 | --disable-image-loader-jp2k \ | ||
31 | --disable-image-loader-pmaps \ | ||
32 | --disable-image-loader-psd \ | ||
33 | --disable-image-loader-tga \ | ||
34 | --disable-image-loader-wbmp \ | ||
35 | --disable-image-loader-webp \ | ||
36 | --disable-image-loader-xpm \ | ||
37 | " | ||
38 | |||
39 | PACKAGECONFIG ??= "opengl-es" | ||
40 | PACKAGECONFIG_class-native = "" | ||
41 | |||
42 | # sort of tri-state | ||
43 | PACKAGECONFIG[opengl-full] = "--with-opengl=full,,virtual/libgl" | ||
44 | PACKAGECONFIG[opengl-es] = "--with-opengl=es,,virtual/libgles2" | ||
45 | PACKAGECONFIG[opengl-none] = "--with-opengl=none,," | ||
46 | # used only in ecore examples and supports only 0.10 now | ||
47 | PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer" | ||
48 | PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio" | ||
49 | |||
50 | # new efl doesn't have option to disable eeze build and we don't want to provide udev-native just to build eeze-native we don't need | ||
51 | do_configure_prepend_class-native() { | ||
52 | sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac | ||
53 | } | ||
54 | |||
55 | PACKAGES += "ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus" | ||
56 | RPROVIDES_edje += "edje-utils" | ||
57 | |||
58 | python populate_packages_prepend () { | ||
59 | for plugin_type in "engines loaders savers".split(): | ||
60 | bb.note( "splitting packages for evas %s..." % plugin_type ) | ||
61 | basedir = d.expand( '${libdir}/evas/modules/%s' % plugin_type) | ||
62 | |||
63 | do_split_packages(d, basedir, '^(.*)', | ||
64 | output_pattern = 'evas-' + plugin_type[:-1] + "-%s", | ||
65 | description = 'Evas module %s', | ||
66 | allow_dirs=True, recursive=False, extra_depends="" ) | ||
67 | |||
68 | plugin_type = "cserve2" | ||
69 | bb.note( "splitting packages for evas %s..." % plugin_type ) | ||
70 | basedir = d.expand( '${libdir}/evas/%s/loaders' % plugin_type) | ||
71 | |||
72 | do_split_packages(d, basedir, '^(.*)', | ||
73 | output_pattern = 'evas-' + plugin_type + "-%s", | ||
74 | description = 'Evas csever2 loader module %s', | ||
75 | allow_dirs=True, recursive=False, extra_depends="" ) | ||
76 | } | ||
77 | |||
78 | PACKAGES_DYNAMIC += "^evas-engine-.* ^evas-loader-.* ^evas-saver-.* ^evas-cserve2-.*" | ||
79 | |||
80 | FILES_efreet = " \ | ||
81 | ${libdir}/efreet/*/efreet*create \ | ||
82 | ${bindir}/efreetd \ | ||
83 | ${datadir}/efreet \ | ||
84 | " | ||
85 | FILES_eet = " \ | ||
86 | ${bindir}/eet \ | ||
87 | " | ||
88 | FILES_emotion = " \ | ||
89 | ${datadir}/emotion \ | ||
90 | " | ||
91 | FILES_embryo = " \ | ||
92 | ${datadir}/embryo \ | ||
93 | " | ||
94 | FILES_ethumb = " \ | ||
95 | ${bindir}/ethumbd \ | ||
96 | ${bindir}/ethumb \ | ||
97 | ${libdir}/ethumb/*/*/*/module.so \ | ||
98 | ${libdir}/ethumb/*/*/*/*.edj \ | ||
99 | ${libdir}/ethumb_client/utils/*/ethumbd_slave \ | ||
100 | ${datadir}/ethumb* \ | ||
101 | " | ||
102 | FILES_ecore = " \ | ||
103 | ${libdir}/ecore*/*/*/*/module.so \ | ||
104 | ${datadir}/ecore* \ | ||
105 | " | ||
106 | FILES_evas = " \ | ||
107 | ${libdir}/evas*/*/*/*/*/module.so \ | ||
108 | ${libdir}/evas*/*/*/*/*/*.edj \ | ||
109 | ${libdir}/evas/cserve2/bin/*/evas_cserve2* \ | ||
110 | ${datadir}/evas* \ | ||
111 | " | ||
112 | |||
113 | FILES_eeze = " \ | ||
114 | ${libdir}/eeze*/*/*/*/*/module.so \ | ||
115 | ${datadir}/eeze \ | ||
116 | " | ||
117 | FILES_edje = " \ | ||
118 | ${libdir}/edje*/*/*/*/module.so \ | ||
119 | ${libdir}/edje/utils/*/epp \ | ||
120 | ${datadir}/edje \ | ||
121 | ${datadir}/mime \ | ||
122 | " | ||
123 | FILES_${PN}-dbg += " \ | ||
124 | ${libdir}/efreet/*/.debug \ | ||
125 | ${libdir}/ecore*/*/*/*/.debug \ | ||
126 | ${libdir}/evas*/*/*/*/*/.debug \ | ||
127 | ${libdir}/evas/cserve2/bin/*/.debug \ | ||
128 | ${libdir}/eeze*/*/*/*/*/.debug \ | ||
129 | ${libdir}/edje*/*/*/*/.debug \ | ||
130 | ${libdir}/edje/utils/*/.debug \ | ||
131 | ${libdir}/ethumb/*/*/*/.debug \ | ||
132 | ${libdir}/ethumb_client/utils/*/.debug \ | ||
133 | " | ||
134 | FILES_${PN}-dev += " \ | ||
135 | ${libdir}/cmake \ | ||
136 | ${libdir}/ecore*/*/*/*/module.la \ | ||
137 | ${libdir}/evas*/*/*/*/*/module.la \ | ||
138 | ${libdir}/ethumb*/*/*/*/module.la \ | ||
139 | ${libdir}/eeze*/*/*/*/*/module.la \ | ||
140 | ${libdir}/edje*/*/*/*/module.la \ | ||
141 | ${datadir}/gdb/auto-load \ | ||
142 | ${datadir}/eo/gdb \ | ||
143 | ${bindir}/eldbus-codegen \ | ||
144 | ${bindir}/eina-bench-cmp \ | ||
145 | " | ||