summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/efl/edje_1.7.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-efl/recipes-efl/efl/edje_1.7.8.bb')
-rw-r--r--meta-efl/recipes-efl/efl/edje_1.7.8.bb66
1 files changed, 65 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/efl/edje_1.7.8.bb b/meta-efl/recipes-efl/efl/edje_1.7.8.bb
index ea3fc74e3..ed43c323f 100644
--- a/meta-efl/recipes-efl/efl/edje_1.7.8.bb
+++ b/meta-efl/recipes-efl/efl/edje_1.7.8.bb
@@ -1,4 +1,68 @@
1require ${BPN}.inc 1DESCRIPTION = "Edje is the Enlightenment graphical design & layout library"
2DEPENDS = "lua5.1 eet evas ecore embryo edje-native eina libsndfile1 eio"
3DEPENDS_virtclass-native = "lua5.1-native evas-native ecore-native eet-native embryo-native eina-native"
4DEPENDS_virtclass-nativesdk = "evas-native ecore-native eet-native embryo-native eina-native"
5# GPLv2 because of epp in PN-utils
6LICENSE = "MIT BSD GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c18cc221a14a84b033db27794dc36df8"
8
9inherit efl
10
11BBCLASSEXTEND = "native nativesdk"
12
13do_configure_prepend_virtclass-native() {
14 sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
15 sed -i 's: cpp -I: /usr/bin/cpp -I:' ${S}/src/bin/edje_cc_parse.c
16 sed -i 's:\"gcc -I:\"/usr/bin/gcc -I:' ${S}/src/bin/edje_cc_parse.c
17}
18# The new lua stuff is a bit broken...
19do_configure_append() {
20 for i in $(find "${S}" -name "Makefile") ; do
21 sed -i -e 's:-L/usr/local/lib::g' $i
22 done
23}
24
25do_compile_append() {
26 sed -i -e s:local/::g -e 's:-L${STAGING_LIBDIR}::g' ${S}/edje.pc
27}
28
29# gain some extra performance at the expense of RAM - generally i'd say bad
30# and a possible source of bugs
31#EXTRA_OECONF = "--enable-edje-program-cache"
32
33# Since r44323 edje has a fixed-point mode
34require edje-fpu.inc
35EXTRA_OECONF += "${@get_edje_fpu_setting(bb, d)}"
36
37SNDFILE = "--enable-sndfile"
38SNDFILE_virtclass-native = "--disable-sndfile"
39SNDFILE_virtclass-nativesdk = "--disable-sndfile"
40EXTRA_OECONF += "${SNDFILE}"
41
42PACKAGES =+ "${PN}-utils"
43RDEPENDS_${PN}-utils = "cpp cpp-symlinks embryo-tests"
44
45RRECOMMENDS_${PN}-utils = "\
46 evas-saver-png \
47 evas-saver-jpeg \
48 evas-saver-eet \
49"
50
51DEBIAN_NOAUTONAME_${PN}-utils = "1"
52# Some upgrade path tweaking
53AUTO_LIBNAME_PKGS = ""
54
55FILES_${PN}-utils = "\
56 ${bindir}/edje_* \
57 ${bindir}/inkscape2edc \
58 ${libdir}/edje/utils/epp \
59 ${datadir}/edje/include/edje.inc \
60"
61
62FILES_${PN} += "${libdir}/${PN}/modules/*/*/module.so \
63 ${datadir}/mime/packages/edje.xml"
64FILES_${PN}-dev += "${libdir}/${PN}/modules/*/*/module.la"
65FILES_${PN}-dbg += "${libdir}/${PN}/modules/*/*/.debug"
2 66
3SRC_URI = "\ 67SRC_URI = "\
4 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \ 68 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \