summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17/e-wm_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-efl/recipes-efl/e17/e-wm_svn.bb')
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_svn.bb211
1 files changed, 7 insertions, 204 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm_svn.bb b/meta-efl/recipes-efl/e17/e-wm_svn.bb
index abee301a1..22eb821f7 100644
--- a/meta-efl/recipes-efl/e17/e-wm_svn.bb
+++ b/meta-efl/recipes-efl/e17/e-wm_svn.bb
@@ -1,13 +1,12 @@
1DESCRIPTION = "The Enlightenment Window Manager Version 17" 1require ${BPN}.inc
2DEPENDS = "eet evas eina ecore edje efreet edbus eeze eio elementary libxcb xcb-util-keysyms" 2
3LICENSE = "MIT BSD" 3PV = "0.17.0+svnr${SRCPV}"
4LIC_FILES_CHKSUM = "file://COPYING;md5=76de290eb3fdda12121830191c152a7d" 4PR = "${INC_PR}.0"
5SRCNAME = "e" 5
6PV = "0.16.999.060+svnr${SRCPV}" 6DEFAULT_PREFERENCE = "-1"
7PR = "r10" 7
8SRCREV = "${EFL_SRCREV}" 8SRCREV = "${EFL_SRCREV}"
9 9
10inherit e update-alternatives gettext
11S = "${WORKDIR}/${SRCNAME}" 10S = "${WORKDIR}/${SRCNAME}"
12 11
13SRC_URI = "\ 12SRC_URI = "\
@@ -15,199 +14,3 @@ SRC_URI = "\
15 file://enlightenment_start.oe \ 14 file://enlightenment_start.oe \
16 file://applications.menu \ 15 file://applications.menu \
17" 16"
18
19EXTRA_OECONF = "\
20 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
21 --with-eet-eet=${STAGING_BINDIR_NATIVE}/eet \
22 --x-includes=${STAGING_INCDIR}/X11 \
23 --x-libraries=${STAGING_LIBDIR} \
24 --enable-simple-x11 \
25"
26
27do_configure_prepend() {
28 autopoint || true
29}
30
31do_install_append() {
32 # customising - should rather make this simple upstream
33 install -m 755 ${WORKDIR}/enlightenment_start.oe ${D}/${bindir}
34
35 # security reasons, e-wm checks that in runtime
36 # xinit[418]: ERROR: CONFIGURATION FILE HAS BAD PERMISSIONS
37 chmod 600 ${D}/${sysconfdir}/enlightenment/sysactions.conf
38
39 install -d ${D}/${datadir}/applications/
40 install -m 644 ${S}/src/modules/fileman/module.desktop ${D}/${datadir}/applications/efm.desktop
41 sed "s#Type=Link#Type=Application#g" -i ${D}/${datadir}/applications/efm.desktop
42 echo "Exec=enlightenment_remote -efm-open-dir" >> ${D}/${datadir}/applications/efm.desktop
43 echo "Terminal=false" >> ${D}/${datadir}/applications/efm.desktop
44 echo "Categories=Application;" >> ${D}/${datadir}/applications/efm.desktop
45 echo "StartupNotify=true" >> ${D}/${datadir}/applications/efm.desktop
46 install -d ${D}/${datadir}/icons/
47 install -m 644 ${S}/data/themes/img/O/icon_icon_theme.png ${D}/${datadir}/icons/e-module-fileman.png
48
49 install -d ${D}/${sysconfdir}/xdg/menus
50 install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/
51 for I in `find ${D}/${libdir}/enlightenment -name "*.a" -print`; do rm -f $I; done
52 for I in `find ${D}/${libdir}/enlightenment -name "*.la" -print`; do rm -f $I; done
53
54 # work around for issue caused in r78978, more infor in:
55 # http://sourceforge.net/mailarchive/forum.php?thread_name=20121118194904.GA3438%40jama.jama.net&forum_name=enlightenment-devel
56 mv ${D}/${libdir}/enlightenment/modules/policies ${D}/${libdir}/enlightenment/modules/illume2/ \
57 || echo "illume2 policies are in correct place now"
58 mv ${D}/${libdir}/enlightenment/modules/keyboards ${D}/${libdir}/enlightenment/modules/illume2/ \
59 || echo "illume2 keyboards are in correct place now"
60}
61
62RDEPENDS_${PN} += "\
63 shared-mime-info \
64 mime-support \
65 setxkbmap \
66 edje-utils \
67 ${PN}-utils \
68 dbus-x11 \
69 evas-loader-png \
70 evas-loader-jpeg \
71 evas-loader-gif \
72 evas-generic-loader-svg \
73"
74
75# Uclibc build don't have 'glibc-utils'
76RDEPENDS_${PN}_append_libc-glibc = " glibc-utils "
77
78# The systray module used to be external, but is part of e-wm now
79RREPLACES_${PN} = "systray"
80
81RREPLACES_${PN}-config-mobile = "${PN}-config-illume2"
82RCONFLICTS_${PN}-config-mobile = "${PN}-config-illume2"
83RPROVIDES_${PN}-config-mobile = "${PN}-config-illume2"
84
85PACKAGES =+ "\
86 ${PN}-config-default \
87 ${PN}-config-mobile \
88 ${PN}-config-minimalist \
89 ${PN}-config-netbook \
90 ${PN}-config-scaleable \
91 ${PN}-config-standard \
92 ${PN}-theme-default \
93 ${PN}-background-dark-gradient \
94 ${PN}-background-light-gradient \
95 ${PN}-backgrounds \
96 ${PN}-images \
97 ${PN}-icons \
98 ${PN}-other \
99 ${PN}-input-methods \
100 ${PN}-sysactions \
101 ${PN}-utils \
102 ${PN}-menu \
103 efm-desktop-icon \
104 illume-keyboard-default-alpha \
105 illume-keyboard-default-numeric \
106 illume-keyboard-default-terminal \
107"
108
109ESYSACTIONS ?= "${PN}-sysactions"
110
111RRECOMMENDS_${PN} = "\
112 ${PN}-config-default \
113 ${PN}-images \
114 ${PN}-icons \
115 ${PN}-other \
116 ${PN}-input-methods \
117 ${ESYSACTIONS} \
118"
119
120FILES_${PN} = "\
121 ${bindir}/* \
122 ${libdir}/enlightenment/utils/* \
123 ${libdir}/enlightenment/modules/*/*.* \
124 ${libdir}/enlightenment/modules/*/*/* \
125 ${libdir}/enlightenment/modules/*/*/.order \
126 ${libdir}/enlightenment/modules/keyboards/ignore_built_in_keyboards \
127 ${libdir}/enlightenment/*plugins/*/*/* \
128 ${libdir}/enlightenment/preload/e_precache.so \
129 ${datadir}/enlightenment/data/icons \
130 ${datadir}/enlightenment/data/favorites \
131 ${datadir}/enlightenment/data/input_methods \
132 ${datadir}/enlightenment/data/config/profile.cfg \
133 ${datadir}/enlightenment/AUTHORS \
134 ${datadir}/enlightenment/COPYING \
135 ${datadir}/xsessions/enlightenment.desktop \
136 ${sysconfdir}/xdg \
137"
138
139FILES_${PN}-config-default = "${datadir}/enlightenment/data/config/default"
140FILES_${PN}-config-mobile = "${datadir}/enlightenment/data/config/mobile"
141FILES_${PN}-config-minimalist = "${datadir}/enlightenment/data/config/minimalist"
142FILES_${PN}-config-netbook = "${datadir}/enlightenment/data/config/netbook"
143FILES_${PN}-config-scaleable = "${datadir}/enlightenment/data/config/scaleable"
144FILES_${PN}-config-standard = "${datadir}/enlightenment/data/config/standard"
145FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
146FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
147FILES_${PN}-background-dark-gradient = "${datadir}/enlightenment/data/backgrounds/Dark_Gradient.edj"
148FILES_${PN}-background-light-gradient = "${datadir}/enlightenment/data/backgrounds/Light_Gradient.edj"
149FILES_${PN}-backgrounds = "${datadir}/enlightenment/data/backgrounds/*.edj"
150FILES_${PN}-images = "${datadir}/enlightenment/data/images ${datadir}/enlightenment/data/flags"
151FILES_${PN}-icons = "${datadir}/enlightenment/data/icons"
152FILES_${PN}-other = "${datadir}/enlightenment/data/other"
153FILES_${PN}-input-methods = "${datadir}/enlightenment/data/input_methods"
154FILES_${PN}-sysactions = "${sysconfdir}/enlightenment/sysactions.conf"
155FILES_${PN}-utils = "${libdir}/enlightenment/utils/*"
156FILES_${PN}-menu = "${sysconfdir}/xdg/menus/applications.menu"
157
158FILES_efm-desktop-icon = "\
159 ${datadir}/applications/efm.desktop \
160 ${datadir}/applications/enlightenment_filemanager.desktop \
161 ${datadir}/icons/e-module-fileman.png \
162"
163
164KEYBOARDS_DIR="${libdir}/enlightenment/modules/illume-keyboard/keyboards"
165FILES_illume-keyboard-default-alpha = "\
166 ${KEYBOARDS_DIR}/Default.kbd \
167 ${KEYBOARDS_DIR}/alpha.png \
168"
169FILES_illume-keyboard-default-numeric = "\
170 ${KEYBOARDS_DIR}/Numbers.kbd \
171 ${KEYBOARDS_DIR}/numeric.png \
172"
173FILES_illume-keyboard-default-terminal = "\
174 ${KEYBOARDS_DIR}/Terminal.kbd \
175 ${KEYBOARDS_DIR}/qwerty.png \
176"
177
178RRECOMMENDS_${PN}-config-default = "${PN}-theme-default"
179RRECOMMENDS_${PN}-config-mobile = "\
180 illume-keyboard-default-alpha \
181 illume-keyboard-default-numeric \
182 illume-keyboard-default-terminal \
183"
184
185RRECOMMENDS_${PN}-config-minimalist = "\
186 ${PN}-background-light-gradient \
187 ${PN}-theme-default \
188"
189RRECOMMENDS_${PN}-config-netbook = "\
190 ${PN}-background-dark-gradient \
191 ${PN}-theme-default \
192"
193RRECOMMENDS_${PN}-config-scaleable = "${PN}-theme-default"
194RRECOMMENDS_${PN}-config-standard = "${PN}-theme-default"
195
196FILES_${PN}-dbg += "\
197 ${libdir}/enlightenment/modules/*/*/.debug/ \
198 ${libdir}/enlightenment/modules/policies/.debug/ \
199 ${libdir}/enlightenment/preload/.debug/ \
200 ${libdir}/enlightenment/utils/.debug/ \
201 ${libdir}/enlightenment/*plugins/*/*/.debug \
202"
203
204FILES_${PN}-doc += "\
205 ${datadir}/enlightenment/doc \
206"
207
208CONFFILES_${PN}-menu = "${sysconfdir}/xdg/menus/applications.menu"
209CONFFILES_${PN}-sysactions = "/etc/enlightenment/sysactions.conf"
210
211ALTERNATIVE_${PN} = "x-window-manager"
212ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/enlightenment_start.oe"
213ALTERNATIVE_PRIORITY[x-window-manager] = "16"