diff options
Diffstat (limited to 'meta-efl/recipes-efl/e17/e-wm')
5 files changed, 205 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm/applications.menu b/meta-efl/recipes-efl/e17/e-wm/applications.menu new file mode 100644 index 000000000..77c6f0429 --- /dev/null +++ b/meta-efl/recipes-efl/e17/e-wm/applications.menu | |||
@@ -0,0 +1,105 @@ | |||
1 | <?xml version="1.0"?> | ||
2 | <!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN" "http://standards.freedesktop.org/menu-spec/menu-1.0.dtd"> | ||
3 | <Menu> | ||
4 | <Name>Applications</Name> | ||
5 | <!-- <Directory>Applications.directory</Directory> --> | ||
6 | |||
7 | <!-- Read standard .directory and .desktop file locations --> | ||
8 | <DefaultAppDirs>/usr/share/applications</DefaultAppDirs> | ||
9 | <DefaultDirectoryDirs/> | ||
10 | |||
11 | <Menu> | ||
12 | <Name>Office</Name> | ||
13 | <Directory>Office.directory</Directory> | ||
14 | <Include> | ||
15 | <And> | ||
16 | <Category>Office</Category> | ||
17 | </And> | ||
18 | </Include> | ||
19 | </Menu> | ||
20 | |||
21 | <Menu> | ||
22 | <Name>Multimedia</Name> | ||
23 | <Directory>Multimedia.directory</Directory> | ||
24 | <Include> | ||
25 | <And> | ||
26 | <Category>AudioVideo</Category> | ||
27 | </And> | ||
28 | </Include> | ||
29 | </Menu> | ||
30 | |||
31 | <Menu> | ||
32 | <Name>Graphics</Name> | ||
33 | <Directory>Graphics.directory</Directory> | ||
34 | <Include> | ||
35 | <And> | ||
36 | <Category>Graphics</Category> | ||
37 | </And> | ||
38 | </Include> | ||
39 | </Menu> | ||
40 | |||
41 | <Menu> | ||
42 | <Name>Games</Name> | ||
43 | <Directory>Games.directory</Directory> | ||
44 | <Include> | ||
45 | <And> | ||
46 | <Or> | ||
47 | <Category>Game</Category> | ||
48 | <Category>Games</Category> | ||
49 | </Or> | ||
50 | </And> | ||
51 | </Include> | ||
52 | </Menu> | ||
53 | |||
54 | <Menu> | ||
55 | <Name>Internet</Name> | ||
56 | <Directory>Internet.directory</Directory> | ||
57 | <Include> | ||
58 | <And> | ||
59 | <Or> | ||
60 | <Category>Internet</Category> | ||
61 | <Category>Network</Category> | ||
62 | </Or> | ||
63 | </And> | ||
64 | </Include> | ||
65 | </Menu> | ||
66 | |||
67 | <Menu> | ||
68 | <Name>Settings</Name> | ||
69 | <Directory>Settings.directory</Directory> | ||
70 | <Include> | ||
71 | <And> | ||
72 | <Or> | ||
73 | <Category>SystemSettings</Category> | ||
74 | <Category>Settings</Category> | ||
75 | </Or> | ||
76 | <Not> | ||
77 | <Category>System</Category> | ||
78 | </Not> | ||
79 | </And> | ||
80 | </Include> | ||
81 | </Menu> | ||
82 | |||
83 | <Menu> | ||
84 | <Name>Accessories</Name> | ||
85 | <Directory>Accessories.directory</Directory> | ||
86 | <Include> | ||
87 | <And> | ||
88 | <Or> | ||
89 | <Category>Applications</Category> | ||
90 | <Category>Utility</Category> | ||
91 | </Or> | ||
92 | <Not> | ||
93 | <Category>System</Category> | ||
94 | <Category>Office</Category> | ||
95 | <Category>Internet</Category> | ||
96 | <Category>AudioVideo</Category> | ||
97 | <Category>Graphics</Category> | ||
98 | <Category>Games</Category> | ||
99 | </Not> | ||
100 | </And> | ||
101 | </Include> | ||
102 | </Menu> | ||
103 | |||
104 | </Menu> | ||
105 | |||
diff --git a/meta-efl/recipes-efl/e17/e-wm/enlightenment_start.oe b/meta-efl/recipes-efl/e17/e-wm/enlightenment_start.oe new file mode 100644 index 000000000..e5a65025c --- /dev/null +++ b/meta-efl/recipes-efl/e17/e-wm/enlightenment_start.oe | |||
@@ -0,0 +1,9 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | E_PROFILE="" | ||
4 | if [ -r /etc/enlightenment/default_profile ]; then | ||
5 | . /etc/enlightenment/default_profile | ||
6 | fi | ||
7 | |||
8 | renice -10 -p $$ | ||
9 | exec enlightenment_start $E_PROFILE | ||
diff --git a/meta-efl/recipes-efl/e17/e-wm/illume-disable-screensaver.patch b/meta-efl/recipes-efl/e17/e-wm/illume-disable-screensaver.patch new file mode 100644 index 000000000..984895cf5 --- /dev/null +++ b/meta-efl/recipes-efl/e17/e-wm/illume-disable-screensaver.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: e/config/illume/e.src | ||
2 | =================================================================== | ||
3 | --- e.orig/config/illume/e.src 2009-01-30 23:34:37.000000000 +0100 | ||
4 | +++ e/config/illume/e.src 2009-01-30 23:34:54.000000000 +0100 | ||
5 | @@ -665,7 +665,7 @@ | ||
6 | value "display_res_height" int: 1; | ||
7 | value "display_res_hz" int: 0; | ||
8 | value "display_res_rotation" int: 0; | ||
9 | - value "screensaver_enable" int: 1; | ||
10 | + value "screensaver_enable" int: 0; | ||
11 | value "screensaver_timeout" int: 30; | ||
12 | value "screensaver_interval" int: 5; | ||
13 | value "screensaver_blanking" int: 2; | ||
diff --git a/meta-efl/recipes-efl/e17/e-wm/illume-flaunch-fix.patch b/meta-efl/recipes-efl/e17/e-wm/illume-flaunch-fix.patch new file mode 100644 index 000000000..5aab3b5dc --- /dev/null +++ b/meta-efl/recipes-efl/e17/e-wm/illume-flaunch-fix.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | --- e/src/modules/illume/e_flaunch.c 2010-02-09 22:33:25.000000000 +0100 | ||
2 | +++ e/src/modules/illume/e_flaunch.c 2010-02-09 22:33:25.000000000 +0100 | ||
3 | @@ -97,10 +97,10 @@ | ||
4 | int num = 0, max, count; | ||
5 | |||
6 | // FIXME: 3 should become config here | ||
7 | - max = 10; | ||
8 | + max = 3; | ||
9 | // for now just look for any apps in "category" 'Bar' and add the first 3 | ||
10 | // FIXME: category should be configurable... | ||
11 | - bar_desktops = efreet_util_desktop_category_list("System"); | ||
12 | + bar_desktops = efreet_util_desktop_category_list("Bar"); | ||
13 | if (bar_desktops) | ||
14 | { | ||
15 | Efreet_Desktop *desktop; | ||
diff --git a/meta-efl/recipes-efl/e17/e-wm/wizard-module-skipping.patch b/meta-efl/recipes-efl/e17/e-wm/wizard-module-skipping.patch new file mode 100644 index 000000000..d124325b3 --- /dev/null +++ b/meta-efl/recipes-efl/e17/e-wm/wizard-module-skipping.patch | |||
@@ -0,0 +1,63 @@ | |||
1 | Index: e/src/modules/wizard/Makefile.am | ||
2 | =================================================================== | ||
3 | --- e/src/modules/wizard/Makefile.am (revision 43860) | ||
4 | +++ e/src/modules/wizard/Makefile.am (working copy) | ||
5 | @@ -6,7 +6,7 @@ | ||
6 | files_DATA = \ | ||
7 | e-module-$(MODULE).edj module.desktop | ||
8 | |||
9 | -EXTRA_DIST = $(files_DATA) page_040.c page_050.c page_060.c | ||
10 | +EXTRA_DIST = $(files_DATA) page_030.c page_040.c page_050.c page_060.c page_070.c page_080.c | ||
11 | |||
12 | # the module .so file | ||
13 | INCLUDES = -I. \ | ||
14 | @@ -21,9 +21,6 @@ | ||
15 | page_000.la \ | ||
16 | page_010.la \ | ||
17 | page_020.la \ | ||
18 | - page_030.la \ | ||
19 | - page_070.la \ | ||
20 | - page_080.la \ | ||
21 | page_200.la | ||
22 | |||
23 | ### disabled because profile selector really does the job. code here just for | ||
24 | @@ -60,10 +57,10 @@ | ||
25 | page_020_la_DEPENDENCIES = $(top_builddir)/config.h | ||
26 | |||
27 | #Choose Menus | ||
28 | -page_030_la_SOURCES = page_030.c | ||
29 | -page_030_la_LIBADD = @e_libs@ @dlopen_libs@ | ||
30 | -page_030_la_LDFLAGS = -module -avoid-version | ||
31 | -page_030_la_DEPENDENCIES = $(top_builddir)/config.h | ||
32 | +#page_030_la_SOURCES = page_030.c | ||
33 | +#page_030_la_LIBADD = @e_libs@ @dlopen_libs@ | ||
34 | +#page_030_la_LDFLAGS = -module -avoid-version | ||
35 | +#page_030_la_DEPENDENCIES = $(top_builddir)/config.h | ||
36 | |||
37 | #page_040_la_SOURCES = page_040.c | ||
38 | #page_040_la_LIBADD = @e_libs@ @dlopen_libs@ | ||
39 | @@ -81,16 +78,16 @@ | ||
40 | #page_060_la_DEPENDENCIES = $(top_builddir)/config.h | ||
41 | |||
42 | #Choose appliactions | ||
43 | -page_070_la_SOURCES = page_070.c | ||
44 | -page_070_la_LIBADD = @e_libs@ @dlopen_libs@ | ||
45 | -page_070_la_LDFLAGS = -module -avoid-version | ||
46 | -page_070_la_DEPENDENCIES = $(top_builddir)/config.h | ||
47 | +#page_070_la_SOURCES = page_070.c | ||
48 | +#page_070_la_LIBADD = @e_libs@ @dlopen_libs@ | ||
49 | +#page_070_la_LDFLAGS = -module -avoid-version | ||
50 | +#page_070_la_DEPENDENCIES = $(top_builddir)/config.h | ||
51 | |||
52 | #Choose quick launch | ||
53 | -page_080_la_SOURCES = page_080.c | ||
54 | -page_080_la_LIBADD = @e_libs@ @dlopen_libs@ | ||
55 | -page_080_la_LDFLAGS = -module -avoid-version | ||
56 | -page_080_la_DEPENDENCIES = $(top_builddir)/config.h | ||
57 | +#page_080_la_SOURCES = page_080.c | ||
58 | +#page_080_la_LIBADD = @e_libs@ @dlopen_libs@ | ||
59 | +#page_080_la_LDFLAGS = -module -avoid-version | ||
60 | +#page_080_la_DEPENDENCIES = $(top_builddir)/config.h | ||
61 | |||
62 | page_200_la_SOURCES = page_200.c | ||
63 | page_200_la_LIBADD = @e_libs@ @dlopen_libs@ | ||