summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-devtools/python/python-efl.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-efl/recipes-devtools/python/python-efl.inc')
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
new file mode 100644
index 000000000..f81630576
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -0,0 +1,46 @@
1DESCRIPTION = "${PN} bindings"
2LICENSE = "BSD"
3AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
4# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
5# we need to build pyrex otherwise cython doesn't get called to build
6# the extension modules.
7DEPENDS = "python-cython-native python-pyrex-native python-numeric eina"
8RDEPENDS_${PN} += "python-lang"
9PV = "0.7.3+svnr${SRCPV}"
10PR = "ml1"
11
12# necessary to let the call for python-config succeed
13export BUILD_SYS
14export HOST_SYS
15
16inherit e-base autotools pkgconfig distutils-base
17
18SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};proto=http"
19S = "${WORKDIR}/${SRCNAME}"
20
21
22do_configure_prepend() {
23 # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
24 sed -i "s#\`\$PKG_CONFIG --variable=includedir \"python-evas#${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
25}
26
27do_install_append() {
28 if [ -e examples ]; then
29 for i in `find examples -name "*.edc"`; do
30 cd ${S}/`dirname $i`
31 echo "Generating .edj file for $i..."
32 edje_cc `basename $i`
33 echo "Removing sources in this directory..."
34 rm -f *.edc *.png *.ttf *.jpeg
35 done
36 cd ${S}
37 install -d ${D}${datadir}/${PN}/
38 cp -a examples ${D}${datadir}/${PN}/
39 find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
40 fi
41}
42
43FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
44
45PACKAGES += "${PN}-examples"
46FILES_${PN}-examples = "${datadir}/${PN}/examples"