diff options
4 files changed, 95 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/tiptop/tiptop/0001-Fix-build-when-S-B.patch b/meta-oe/recipes-extended/tiptop/tiptop/0001-Fix-build-when-S-B.patch new file mode 100644 index 000000000..51756b891 --- /dev/null +++ b/meta-oe/recipes-extended/tiptop/tiptop/0001-Fix-build-when-S-B.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From ad907b1aff217fe3b431ae052025ba8ba6cacc01 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 20 Jun 2018 23:14:58 -0700 | ||
4 | Subject: [PATCH] Fix build when S != B | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | src/Makefile.in | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/Makefile.in b/src/Makefile.in | ||
14 | index 4392c06..2c5cae4 100644 | ||
15 | --- a/src/Makefile.in | ||
16 | +++ b/src/Makefile.in | ||
17 | @@ -69,7 +69,7 @@ install: | ||
18 | $(INSTALL) -d $(DESTDIR)$(bindir) | ||
19 | $(INSTALL) -m 0755 tiptop $(DESTDIR)$(bindir) | ||
20 | $(INSTALL) -d $(DESTDIR)$(man1dir) | ||
21 | - $(INSTALL) -m 0644 tiptop.1 $(DESTDIR)$(man1dir) | ||
22 | + $(INSTALL) -m 0644 $(srcdir)/tiptop.1 $(DESTDIR)$(man1dir) | ||
23 | ln $(DESTDIR)$(bindir)/tiptop $(DESTDIR)$(bindir)/ptiptop | ||
24 | ln $(DESTDIR)$(man1dir)/tiptop.1 $(DESTDIR)$(man1dir)/ptiptop.1 | ||
25 | |||
26 | -- | ||
27 | 2.17.1 | ||
28 | |||
diff --git a/meta-oe/recipes-extended/tiptop/tiptop/0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch b/meta-oe/recipes-extended/tiptop/tiptop/0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch new file mode 100644 index 000000000..ae676ae44 --- /dev/null +++ b/meta-oe/recipes-extended/tiptop/tiptop/0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 848983a30dc99248ec45632bfc31718716a86e9d Mon Sep 17 00:00:00 2001 | ||
2 | From: Tomasz Buchert <tomasz@debian.org> | ||
3 | Date: Fri, 7 Jul 2017 21:15:58 +0200 | ||
4 | Subject: [PATCH] Fix parallel build problems (by Adrian Bunk) | ||
5 | |||
6 | Taken from debian | ||
7 | Upstream-Status: Pending | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/Makefile.in | 3 ++- | ||
12 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/src/Makefile.in b/src/Makefile.in | ||
15 | index 32ab563..1993c9b 100644 | ||
16 | --- a/src/Makefile.in | ||
17 | +++ b/src/Makefile.in | ||
18 | @@ -59,8 +59,9 @@ lex.yy.c: calc.lex | ||
19 | lex.yy.o: lex.yy.c | ||
20 | $(CC) $(CFLAGS) -I$(srcdir) -c lex.yy.c | ||
21 | |||
22 | +y.tab.c: y.tab.h | ||
23 | |||
24 | -y.tab.c y.tab.h: calc.y | ||
25 | +y.tab.h: calc.y | ||
26 | $(YACC) -d $(srcdir)/calc.y | ||
27 | |||
28 | y.tab.o: y.tab.c | ||
diff --git a/meta-oe/recipes-extended/tiptop/tiptop/0002-fix-reproducibility-of-build-process.patch b/meta-oe/recipes-extended/tiptop/tiptop/0002-fix-reproducibility-of-build-process.patch new file mode 100644 index 000000000..cecb70bc9 --- /dev/null +++ b/meta-oe/recipes-extended/tiptop/tiptop/0002-fix-reproducibility-of-build-process.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 89dd9d8705408dccd5c5e47d22eba6fd6ec22b50 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tomasz Buchert <tomasz@debian.org> | ||
3 | Date: Thu, 9 Jul 2015 16:07:23 +0200 | ||
4 | Subject: [PATCH] fix reproducibility of build process | ||
5 | |||
6 | The upstream Makefile sets macros that depend on | ||
7 | a particular platform where the package is built. | ||
8 | We don't set them which fixes the problem. | ||
9 | |||
10 | Taken from debian | ||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | src/Makefile.in | 4 +--- | ||
16 | 1 file changed, 1 insertion(+), 3 deletions(-) | ||
17 | |||
18 | diff --git a/src/Makefile.in b/src/Makefile.in | ||
19 | index 1993c9b..4392c06 100644 | ||
20 | --- a/src/Makefile.in | ||
21 | +++ b/src/Makefile.in | ||
22 | @@ -48,9 +48,7 @@ Makefile: Makefile.in ../config.status | ||
23 | |||
24 | |||
25 | version.o: version.c | ||
26 | - $(CC) $(CFLAGS) -DCOMPILE_HOST="\""`hostname`"\"" \ | ||
27 | - -DCOMPILE_DATE="\"`date`\"" \ | ||
28 | - -c $(srcdir)/version.c | ||
29 | + $(CC) $(CFLAGS) -c $(srcdir)/version.c | ||
30 | |||
31 | |||
32 | lex.yy.c: calc.lex | ||
diff --git a/meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb b/meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb index 04084ecb4..cf67a08b3 100644 --- a/meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb +++ b/meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb | |||
@@ -4,11 +4,16 @@ LICENSE = "GPLv2" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
5 | DEPENDS = "ncurses libxml2 bison-native flex-native" | 5 | DEPENDS = "ncurses libxml2 bison-native flex-native" |
6 | 6 | ||
7 | SRC_URI = "http://tiptop.gforge.inria.fr/releases/${BP}.tar.gz" | 7 | SRC_URI = "http://tiptop.gforge.inria.fr/releases/${BP}.tar.gz \ |
8 | file://0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch \ | ||
9 | file://0002-fix-reproducibility-of-build-process.patch \ | ||
10 | file://0001-Fix-build-when-S-B.patch \ | ||
11 | " | ||
8 | SRC_URI[md5sum] = "46ca0fdf0236f02dd2b96d347626d2a2" | 12 | SRC_URI[md5sum] = "46ca0fdf0236f02dd2b96d347626d2a2" |
9 | SRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182" | 13 | SRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182" |
10 | 14 | ||
11 | inherit autotools-brokensep | 15 | inherit autotools |
16 | |||
12 | EXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2"" | 17 | EXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2"" |
13 | COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc|aarch64).*-linux" | 18 | COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc|aarch64).*-linux" |
14 | 19 | ||