summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools/0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch89
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb1
2 files changed, 90 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools/0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch
new file mode 100644
index 000000000..484af4e0f
--- /dev/null
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch
@@ -0,0 +1,89 @@
1From d6d7130f0a2e3b81880fca29966e42c1b2be40a7 Mon Sep 17 00:00:00 2001
2From: Sergei Trofimovich <slyfox@gentoo.org>
3Date: Fri, 8 Jan 2021 22:22:52 +0000
4Subject: [PATCH] m4/sctp.m4: make conpatible to autoconf-2.70
5
6On recently released `autoconf-2.70` generated `./configure`
7fails as:
8
9```
10$ ./configure
11...
12checking for struct sctp_event_subscribe.sctp_stream_reset_event... yes
13checking for gcc options needed to detect all undeclared functions... none needed
14./configure: line 16464: syntax error: unexpected end of file
15```
16
17This happens becuase new autoconf generates less whitespace:
18
19```
20{
21if ...
22...
23fi}
24```
25
26It requires at least whitespace between `fi` and `}`.
27
28As input already has newlines the change just drops extra `{}`.
29
30Tested on `autoconf-2.69` and `autoconf-2.70`.
31
32Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
33Signed-off-by: Marcelo Ricardo Leitner <marcelo.leitner@gmail.com>
34
35Upstream-Status: Backport [git://github.com/sctp/lksctp-tools.git]
36Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
37
38---
39 m4/sctp.m4 | 12 ++++++------
40 1 file changed, 6 insertions(+), 6 deletions(-)
41
42diff --git a/m4/sctp.m4 b/m4/sctp.m4
43index 6593517..94527a6 100644
44--- a/m4/sctp.m4
45+++ b/m4/sctp.m4
46@@ -6,7 +6,7 @@
47
48 # Macros to assist on probing kernel features
49 # Probes if a type is defined
50-AC_DEFUN([LKSCTP_CHECK_TYPE], [{
51+AC_DEFUN([LKSCTP_CHECK_TYPE], [
52 AC_CHECK_TYPE([$1],
53 AC_DEFINE([$2], 1,
54 [Define if $1 is present.])
55@@ -22,10 +22,10 @@ AC_CHECK_TYPE([$1],
56 #ifdef HAVE_LINUX_SCTP_H
57 # include <linux/sctp.h>
58 #endif
59-])}])
60+])])
61
62 # Probes if a struct has a given member
63-AC_DEFUN([LKSCTP_CHECK_MEMBER], [{
64+AC_DEFUN([LKSCTP_CHECK_MEMBER], [
65 AC_CHECK_MEMBER([$1],
66 AC_DEFINE([$2], 1,
67 [Define if $1 is present.])
68@@ -41,10 +41,10 @@ AC_CHECK_MEMBER([$1],
69 #ifdef HAVE_LINUX_SCTP_H
70 # include <linux/sctp.h>
71 #endif
72-])}])
73+])])
74
75 # Probes if a declaration is present
76-AC_DEFUN([LKSCTP_CHECK_DECL], [{
77+AC_DEFUN([LKSCTP_CHECK_DECL], [
78 AC_CHECK_DECL([$1],
79 AC_DEFINE([$2], 1,
80 [Define if $1 is present.])
81@@ -60,4 +60,4 @@ AC_CHECK_DECL([$1],
82 #ifdef HAVE_LINUX_SCTP_H
83 # include <linux/sctp.h>
84 #endif
85-])}])
86+])])
87--
882.27.0
89
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb
index 1e2c644b4..f481ffee1 100644
--- a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.18.bb
@@ -15,6 +15,7 @@ LK_REL = "1.0.18"
15 15
16SRC_URI = " \ 16SRC_URI = " \
17 git://github.com/sctp/lksctp-tools.git \ 17 git://github.com/sctp/lksctp-tools.git \
18 file://0001-m4-sctp.m4-make-conpatible-to-autoconf-2.70.patch \
18 file://run-ptest \ 19 file://run-ptest \
19 file://v4test.sh \ 20 file://v4test.sh \
20 file://v6test.sh \ 21 file://v6test.sh \