diff options
-rw-r--r-- | meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb | 1 | ||||
-rw-r--r-- | meta-oe/recipes-support/sdmon/sdmon_git.bb | 20 |
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb index 740835b217..6e2012daea 100644 --- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb | |||
@@ -874,6 +874,7 @@ RDEPENDS:packagegroup-meta-oe-support ="\ | |||
874 | raptor2 \ | 874 | raptor2 \ |
875 | rdfind \ | 875 | rdfind \ |
876 | re2 \ | 876 | re2 \ |
877 | sdmon \ | ||
877 | sdparm \ | 878 | sdparm \ |
878 | serial-forward \ | 879 | serial-forward \ |
879 | read-edid \ | 880 | read-edid \ |
diff --git a/meta-oe/recipes-support/sdmon/sdmon_git.bb b/meta-oe/recipes-support/sdmon/sdmon_git.bb new file mode 100644 index 0000000000..522539a67b --- /dev/null +++ b/meta-oe/recipes-support/sdmon/sdmon_git.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "Get SD card health data" | ||
2 | HOMEPAGE = "https://github.com/Ognian/sdmon" | ||
3 | |||
4 | LICENSE = "GPL-2.0-only" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
6 | |||
7 | SRC_URI = "git://github.com/Ognian/sdmon;protocol=https;branch=master" | ||
8 | |||
9 | PV = "0.8.1+git" | ||
10 | SRCREV = "ef1aec457f04a50721f0259651cca9c946f11390" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | do_compile() { | ||
15 | oe_runmake -C ${S}/src CC="${CC}" CFLAGS="${CFLAGS} -D_REENTRANT -DVERSION=\"\\\"${PV}\\\"\"" LDFLAGS="${LDFLAGS}" | ||
16 | } | ||
17 | |||
18 | do_install() { | ||
19 | install -Dm 0755 ${S}/src/sdmon ${D}${bindir}/sdmon | ||
20 | } | ||