diff options
4 files changed, 9 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb index e96412fec..8b917815d 100644 --- a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb +++ b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb | |||
@@ -115,7 +115,7 @@ python do_create_v8_qemu_wrapper () { | |||
115 | on the host.""" | 115 | on the host.""" |
116 | qemu_libdirs = [d.expand('${STAGING_DIR_HOST}${libdir}'), | 116 | qemu_libdirs = [d.expand('${STAGING_DIR_HOST}${libdir}'), |
117 | d.expand('${STAGING_DIR_HOST}${base_libdir}')] | 117 | d.expand('${STAGING_DIR_HOST}${base_libdir}')] |
118 | qemu_cmd = qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST', True), | 118 | qemu_cmd = qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST'), |
119 | qemu_libdirs) | 119 | qemu_libdirs) |
120 | wrapper_path = d.expand('${B}/v8-qemu-wrapper.sh') | 120 | wrapper_path = d.expand('${B}/v8-qemu-wrapper.sh') |
121 | with open(wrapper_path, 'w') as wrapper_file: | 121 | with open(wrapper_path, 'w') as wrapper_file: |
diff --git a/meta-oe/recipes-devtools/suitesparse/suitesparse_5.10.1.bb b/meta-oe/recipes-devtools/suitesparse/suitesparse_5.10.1.bb index 56cbfce20..13e6fd066 100644 --- a/meta-oe/recipes-devtools/suitesparse/suitesparse_5.10.1.bb +++ b/meta-oe/recipes-devtools/suitesparse/suitesparse_5.10.1.bb | |||
@@ -19,14 +19,14 @@ RPROVIDES:${PN} = "mongoose graphblas" | |||
19 | # the command line. To get around this problem, set these variables to only the | 19 | # the command line. To get around this problem, set these variables to only the |
20 | # program name and prepend the rest of the value onto the corresponding FLAGS | 20 | # program name and prepend the rest of the value onto the corresponding FLAGS |
21 | # variable. | 21 | # variable. |
22 | CFLAGS:prepend := "${@" ".join(d.getVar('CC', True).split()[1:])} " | 22 | CFLAGS:prepend := "${@" ".join(d.getVar('CC').split()[1:])} " |
23 | export CC := "${@d.getVar('CC', True).split()[0]}" | 23 | export CC := "${@d.getVar('CC').split()[0]}" |
24 | 24 | ||
25 | CXXFLAGS:prepend := "${@" ".join(d.getVar('CXX', True).split()[1:])} " | 25 | CXXFLAGS:prepend := "${@" ".join(d.getVar('CXX').split()[1:])} " |
26 | export CXX := "${@d.getVar('CXX', True).split()[0]}" | 26 | export CXX := "${@d.getVar('CXX').split()[0]}" |
27 | 27 | ||
28 | LDFLAGS:prepend := "${@" ".join(d.getVar('LD', True).split()[1:])} " | 28 | LDFLAGS:prepend := "${@" ".join(d.getVar('LD').split()[1:])} " |
29 | export LD := "${@d.getVar('LD', True).split()[0]}" | 29 | export LD := "${@d.getVar('LD').split()[0]}" |
30 | 30 | ||
31 | export CMAKE_OPTIONS = " \ | 31 | export CMAKE_OPTIONS = " \ |
32 | -DCMAKE_INSTALL_PREFIX=${D}${prefix} \ | 32 | -DCMAKE_INSTALL_PREFIX=${D}${prefix} \ |
diff --git a/meta-oe/recipes-kernel/spidev-test/spidev-test.bb b/meta-oe/recipes-kernel/spidev-test/spidev-test.bb index 81e832703..2e8c5cbb8 100644 --- a/meta-oe/recipes-kernel/spidev-test/spidev-test.bb +++ b/meta-oe/recipes-kernel/spidev-test/spidev-test.bb | |||
@@ -23,7 +23,7 @@ do_install() { | |||
23 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 23 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
24 | 24 | ||
25 | python do_package:prepend() { | 25 | python do_package:prepend() { |
26 | d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0]) | 26 | d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0]) |
27 | } | 27 | } |
28 | 28 | ||
29 | B = "${WORKDIR}/${BPN}-${PV}" | 29 | B = "${WORKDIR}/${BPN}-${PV}" |
diff --git a/meta-oe/recipes-kernel/usbip-tools/usbip-tools.bb b/meta-oe/recipes-kernel/usbip-tools/usbip-tools.bb index 47938969b..e7e4ca50a 100644 --- a/meta-oe/recipes-kernel/usbip-tools/usbip-tools.bb +++ b/meta-oe/recipes-kernel/usbip-tools/usbip-tools.bb | |||
@@ -65,5 +65,5 @@ PACKAGE_ARCH = "${MACHINE_ARCH}" | |||
65 | # Even though the libusbip is set to version 0.0.1, set the package version to match kernel | 65 | # Even though the libusbip is set to version 0.0.1, set the package version to match kernel |
66 | # e.g. usbip-tools-5.14.21-r0.qemux86_64.rpm for qemu package using kernel 5.14.21 | 66 | # e.g. usbip-tools-5.14.21-r0.qemux86_64.rpm for qemu package using kernel 5.14.21 |
67 | python do_package:prepend() { | 67 | python do_package:prepend() { |
68 | d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0]) | 68 | d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0]) |
69 | } \ No newline at end of file | 69 | } \ No newline at end of file |