summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch15
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0001-Remove-use-of-register-r7-because-llvm-now-issues-an.patch53
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/0003-Install-both-binaries-and-use-libdir.patch37
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_14.16.1.bb (renamed from meta-oe/recipes-devtools/nodejs/nodejs_12.21.0.bb)5
4 files changed, 25 insertions, 85 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
index 4dd121f48..d6e439ba2 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0001-Disable-running-gyp-files-for-bundled-deps.patch
@@ -1,4 +1,4 @@
1From c2aff16cc196a61f4ab1cdae4a91c7926123c239 Mon Sep 17 00:00:00 2001 1From 7d94bfe53beeb2d25eb5f2ff6b1d509df7e6ab80 Mon Sep 17 00:00:00 2001
2From: Zuzana Svetlikova <zsvetlik@redhat.com> 2From: Zuzana Svetlikova <zsvetlik@redhat.com>
3Date: Thu, 27 Apr 2017 14:25:42 +0200 3Date: Thu, 27 Apr 2017 14:25:42 +0200
4Subject: [PATCH] Disable running gyp on shared deps 4Subject: [PATCH] Disable running gyp on shared deps
@@ -8,18 +8,15 @@ Subject: [PATCH] Disable running gyp on shared deps
8 1 file changed, 1 insertion(+), 1 deletion(-) 8 1 file changed, 1 insertion(+), 1 deletion(-)
9 9
10diff --git a/Makefile b/Makefile 10diff --git a/Makefile b/Makefile
11index 0947300f24..6c98691984 100644 11index 93d63110..79caaec2 100644
12--- a/Makefile 12--- a/Makefile
13+++ b/Makefile 13+++ b/Makefile
14@@ -141,7 +141,7 @@ test-code-cache: with-code-cache 14@@ -138,7 +138,7 @@ with-code-cache test-code-cache:
15 echo "'test-code-cache' target is a noop" 15 $(warning '$@' target is a noop)
16 16
17 out/Makefile: config.gypi common.gypi node.gyp \ 17 out/Makefile: config.gypi common.gypi node.gyp \
18- deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp \ 18- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
19+ deps/http_parser/http_parser.gyp \ 19+ deps/llhttp/llhttp.gyp \
20 tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \ 20 tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
21 tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp 21 tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
22 $(PYTHON) tools/gyp_node.py -f make 22 $(PYTHON) tools/gyp_node.py -f make
23--
242.20.1
25
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0001-Remove-use-of-register-r7-because-llvm-now-issues-an.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0001-Remove-use-of-register-r7-because-llvm-now-issues-an.patch
deleted file mode 100644
index a23f1c243..000000000
--- a/meta-oe/recipes-devtools/nodejs/nodejs/0001-Remove-use-of-register-r7-because-llvm-now-issues-an.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1From be8d3cd6eab4b8f9849133060abb1aba4400276b Mon Sep 17 00:00:00 2001
2From: Amy Huang <akhuang@google.com>
3Date: Thu, 23 Apr 2020 11:25:53 -0700
4Subject: [PATCH] Remove use of register r7 because llvm now issues an error
5 when "r7" is used (starting in commit d85b3877)
6
7Bug: chromium:1073270
8Change-Id: I7ec8112f170b98d2edaf92bc9341e738f8de07a3
9Reviewed-on: https://chromium-review.googlesource.com/c/v8/v8/+/2163435
10Reviewed-by: Nico Weber <thakis@chromium.org>
11Reviewed-by: Ross McIlroy <rmcilroy@chromium.org>
12Commit-Queue: Nico Weber <thakis@chromium.org>
13Cr-Commit-Position: refs/heads/master@{#67371}
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16Upstream-Status: Backport [https://chromium.googlesource.com/v8/v8/+/00604cd2806b5d26bef592dd19989a234bd07a4b%5E%21/]
17 deps/v8/src/codegen/arm/cpu-arm.cc | 13 -------------
18 1 file changed, 13 deletions(-)
19
20diff --git a/deps/v8/src/codegen/arm/cpu-arm.cc b/deps/v8/src/codegen/arm/cpu-arm.cc
21index 868f360..654d68f 100644
22--- a/deps/v8/src/codegen/arm/cpu-arm.cc
23+++ b/deps/v8/src/codegen/arm/cpu-arm.cc
24@@ -30,18 +30,6 @@ V8_NOINLINE void CpuFeatures::FlushICache(void* start, size_t size) {
25 register uint32_t end asm("r1") = beg + size;
26 register uint32_t flg asm("r2") = 0;
27
28-#ifdef __clang__
29- // This variant of the asm avoids a constant pool entry, which can be
30- // problematic when LTO'ing. It is also slightly shorter.
31- register uint32_t scno asm("r7") = __ARM_NR_cacheflush;
32-
33- asm volatile("svc 0\n"
34- :
35- : "r"(beg), "r"(end), "r"(flg), "r"(scno)
36- : "memory");
37-#else
38- // Use a different variant of the asm with GCC because some versions doesn't
39- // support r7 as an asm input.
40 asm volatile(
41 // This assembly works for both ARM and Thumb targets.
42
43@@ -59,7 +47,6 @@ V8_NOINLINE void CpuFeatures::FlushICache(void* start, size_t size) {
44 : "r"(beg), "r"(end), "r"(flg), [scno] "i"(__ARM_NR_cacheflush)
45 : "memory");
46 #endif
47-#endif
48 #endif // !USE_SIMULATOR
49 }
50
51--
522.29.2
53
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/0003-Install-both-binaries-and-use-libdir.patch b/meta-oe/recipes-devtools/nodejs/nodejs/0003-Install-both-binaries-and-use-libdir.patch
index 92386fa77..622392099 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs/0003-Install-both-binaries-and-use-libdir.patch
+++ b/meta-oe/recipes-devtools/nodejs/nodejs/0003-Install-both-binaries-and-use-libdir.patch
@@ -1,28 +1,31 @@
1From 5bfeffdf4b5de1c60a2ff0d1ddf65db2bb9a1533 Mon Sep 17 00:00:00 2001 1From 5b22fac923d1ca3e9fefb97f5a171124a88f5e22 Mon Sep 17 00:00:00 2001
2From: Elliott Sales de Andrade <quantum.analyst@gmail.com> 2From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
3Date: Tue, 19 Mar 2019 23:22:40 -0400 3Date: Tue, 19 Mar 2019 23:22:40 -0400
4Subject: [PATCH 3/3] Install both binaries and use libdir. 4Subject: [PATCH] Install both binaries and use libdir.
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
5 8
6This allows us to build with a shared library for other users while 9This allows us to build with a shared library for other users while
7still providing the normal executable. 10still providing the normal executable.
8 11
9Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com> 12Taken from - https://src.fedoraproject.org/rpms/nodejs/raw/rawhide/f/0002-Install-both-binaries-and-use-libdir.patch
10
11Stolen from [1]
12
13[1] https://src.fedoraproject.org/rpms/nodejs/raw/master/f/0003-Install-both-binaries-and-use-libdir.patch
14 13
15Upstream-Status: Pending 14Upstream-Status: Pending
16 15
16Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
17Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> 17Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
18Signed-off-by: Khem Raj <raj.khem@gmail.com>
18--- 19---
19 configure.py | 7 +++++++ 20 configure.py | 7 +++++++
20 tools/install.py | 31 ++++++++++++++----------------- 21 tools/install.py | 21 +++++++++------------
21 2 files changed, 21 insertions(+), 17 deletions(-) 22 2 files changed, 16 insertions(+), 12 deletions(-)
22 23
24diff --git a/configure.py b/configure.py
25index e6f7e4db..6cf5c45d 100755
23--- a/configure.py 26--- a/configure.py
24+++ b/configure.py 27+++ b/configure.py
25@@ -602,6 +602,12 @@ parser.add_option('--shared', 28@@ -626,6 +626,12 @@ parser.add_option('--shared',
26 help='compile shared library for embedding node in another project. ' + 29 help='compile shared library for embedding node in another project. ' +
27 '(This mode is not officially supported for regular applications)') 30 '(This mode is not officially supported for regular applications)')
28 31
@@ -35,7 +38,7 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
35 parser.add_option('--without-v8-platform', 38 parser.add_option('--without-v8-platform',
36 action='store_true', 39 action='store_true',
37 dest='without_v8_platform', 40 dest='without_v8_platform',
38@@ -1168,6 +1174,7 @@ def configure_node(o): 41@@ -1202,6 +1208,7 @@ def configure_node(o):
39 o['variables']['node_no_browser_globals'] = b(options.no_browser_globals) 42 o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
40 43
41 o['variables']['node_shared'] = b(options.shared) 44 o['variables']['node_shared'] = b(options.shared)
@@ -43,9 +46,11 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
43 node_module_version = getmoduleversion.get_version() 46 node_module_version = getmoduleversion.get_version()
44 47
45 if options.dest_os == 'android': 48 if options.dest_os == 'android':
49diff --git a/tools/install.py b/tools/install.py
50index 729b416f..9bfc6234 100755
46--- a/tools/install.py 51--- a/tools/install.py
47+++ b/tools/install.py 52+++ b/tools/install.py
48@@ -121,26 +121,23 @@ def subdir_files(path, dest, action): 53@@ -121,22 +121,19 @@ def subdir_files(path, dest, action):
49 54
50 def files(action): 55 def files(action):
51 is_windows = sys.platform == 'win32' 56 is_windows = sys.platform == 'win32'
@@ -64,16 +69,8 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
64- output_file += '.dll' 69- output_file += '.dll'
65- else: 70- else:
66- output_file = 'lib' + output_file + '.' + variables.get('shlib_suffix') 71- output_file = 'lib' + output_file + '.' + variables.get('shlib_suffix')
67- # GYP will output to lib.target except on OS X, this is hardcoded
68- # in its source - see the _InstallableTargetInstallPath function.
69- if sys.platform != 'darwin':
70- output_prefix += 'lib.target/'
71+ output_bin = 'node' 72+ output_bin = 'node'
72+ output_lib = 'libnode.' + variables.get('shlib_suffix') 73+ output_lib = 'libnode.' + variables.get('shlib_suffix')
73+ # GYP will output to lib.target except on OS X, this is hardcoded
74+ # in its source - see the _InstallableTargetInstallPath function.
75+ if sys.platform != 'darwin':
76+ output_libprefix += 'lib.target/'
77 74
78- if 'false' == variables.get('node_shared'): 75- if 'false' == variables.get('node_shared'):
79- action([output_prefix + output_file], 'bin/' + output_file) 76- action([output_prefix + output_file], 'bin/' + output_file)
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_12.21.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_14.16.1.bb
index 9b86bf337..b24a6d656 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_12.21.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_14.16.1.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" 1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
2HOMEPAGE = "http://nodejs.org" 2HOMEPAGE = "http://nodejs.org"
3LICENSE = "MIT & BSD & Artistic-2.0" 3LICENSE = "MIT & BSD & Artistic-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8c66ff8861d9f96076a7cb61e3d75f54" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=85bf260d8b6de1588f57abc5dc66587c"
5 5
6DEPENDS = "openssl" 6DEPENDS = "openssl"
7DEPENDS_append_class-target = " nodejs-native" 7DEPENDS_append_class-target = " nodejs-native"
@@ -21,12 +21,11 @@ SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
21 file://0004-v8-don-t-override-ARM-CFLAGS.patch \ 21 file://0004-v8-don-t-override-ARM-CFLAGS.patch \
22 file://big-endian.patch \ 22 file://big-endian.patch \
23 file://mips-warnings.patch \ 23 file://mips-warnings.patch \
24 file://0001-Remove-use-of-register-r7-because-llvm-now-issues-an.patch \
25 " 24 "
26SRC_URI_append_class-target = " \ 25SRC_URI_append_class-target = " \
27 file://0002-Using-native-binaries.patch \ 26 file://0002-Using-native-binaries.patch \
28 " 27 "
29SRC_URI[sha256sum] = "052f37ace6f569b513b5a1154b2a45d3c4d8b07d7d7c807b79f1566db61e979d" 28SRC_URI[sha256sum] = "e44adbbed6756c2c1a01258383e9f00df30c147b36e438f6369b5ef1069abac3"
30 29
31S = "${WORKDIR}/node-v${PV}" 30S = "${WORKDIR}/node-v${PV}"
32 31