diff options
3 files changed, 19 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-ujson.inc b/meta-python/recipes-devtools/python/python-ujson.inc new file mode 100644 index 000000000..9654d5ad3 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-ujson.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "Ultra fast JSON encoder and decoder for Python" | ||
2 | DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3." | ||
3 | |||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;startline=8;endline=9;md5=4f369b3c3c290b4aede8796a4065e5ab" | ||
6 | |||
7 | SRC_URI[md5sum] = "42f77b0cce686dfa4da2e68480b1dd24" | ||
8 | SRC_URI[sha256sum] = "f66073e5506e91d204ab0c614a148d5aa938bdbf104751be66f8ad7a222f5f86" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | RDEPENDS_${PN} += "\ | ||
13 | ${PYTHON_PN}-datetime \ | ||
14 | ${PYTHON_PN}-numbers \ | ||
15 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-ujson_1.35.bb b/meta-python/recipes-devtools/python/python-ujson_1.35.bb index 238dc9286..b3c6ae66f 100644 --- a/meta-python/recipes-devtools/python/python-ujson_1.35.bb +++ b/meta-python/recipes-devtools/python/python-ujson_1.35.bb | |||
@@ -1,15 +1,2 @@ | |||
1 | SUMMARY = "Ultra fast JSON encoder and decoder for Python" | 1 | inherit setuptools |
2 | DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3." | 2 | require python-ujson.inc |
3 | |||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;startline=8;endline=9;md5=4f369b3c3c290b4aede8796a4065e5ab" | ||
6 | |||
7 | SRC_URI[md5sum] = "42f77b0cce686dfa4da2e68480b1dd24" | ||
8 | SRC_URI[sha256sum] = "f66073e5506e91d204ab0c614a148d5aa938bdbf104751be66f8ad7a222f5f86" | ||
9 | |||
10 | inherit pypi setuptools | ||
11 | |||
12 | RDEPENDS_${PN} += "\ | ||
13 | ${PYTHON_PN}-datetime \ | ||
14 | ${PYTHON_PN}-numbers \ | ||
15 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-ujson_1.35.bb b/meta-python/recipes-devtools/python/python3-ujson_1.35.bb new file mode 100644 index 000000000..ae4cc0a81 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-ujson_1.35.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-ujson.inc | ||