diff options
7 files changed, 52 insertions, 40 deletions
diff --git a/meta-oe/recipes-bsp/efivar/efivar/0001-efivar-dp.h-Add-Wunknown-attributes-when-using-clang.patch b/meta-oe/recipes-bsp/efivar/efivar/0001-efivar-dp.h-Add-Wunknown-attributes-when-using-clang.patch index 1b8815e9df..b4ce132a25 100644 --- a/meta-oe/recipes-bsp/efivar/efivar/0001-efivar-dp.h-Add-Wunknown-attributes-when-using-clang.patch +++ b/meta-oe/recipes-bsp/efivar/efivar/0001-efivar-dp.h-Add-Wunknown-attributes-when-using-clang.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 3d43c5efdb632da5d7387dcadce4e87b83929c64 Mon Sep 17 00:00:00 2001 | 1 | From d65c325dd8681edf2ee3332eeb0a547229c7ffb5 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Thu, 24 Aug 2017 15:54:47 -0700 | 3 | Date: Thu, 24 Aug 2017 15:54:47 -0700 |
4 | Subject: [PATCH] efivar-dp.h: Add -Wunknown-attributes when using clang | 4 | Subject: [PATCH] efivar-dp.h: Add -Wunknown-attributes when using clang |
@@ -7,15 +7,16 @@ change !dp check to a comparision against NULL to silent clang warning | |||
7 | nonnull parameter 'dp' will evaluate to 'true' on first encounter | 7 | nonnull parameter 'dp' will evaluate to 'true' on first encounter |
8 | 8 | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
10 | |||
10 | --- | 11 | --- |
11 | src/include/efivar/efivar-dp.h | 12 +++++++----- | 12 | src/include/efivar/efivar-dp.h | 5 +++++ |
12 | 1 file changed, 7 insertions(+), 5 deletions(-) | 13 | 1 file changed, 5 insertions(+) |
13 | 14 | ||
14 | Index: git/src/include/efivar/efivar-dp.h | 15 | diff --git a/src/include/efivar/efivar-dp.h b/src/include/efivar/efivar-dp.h |
15 | =================================================================== | 16 | index 3a509b7..c140e8d 100644 |
16 | --- git.orig/src/include/efivar/efivar-dp.h | 17 | --- a/src/include/efivar/efivar-dp.h |
17 | +++ git/src/include/efivar/efivar-dp.h | 18 | +++ b/src/include/efivar/efivar-dp.h |
18 | @@ -783,9 +783,14 @@ extern int efidp_append_instance(const_e | 19 | @@ -783,9 +783,14 @@ extern int efidp_append_instance(const_efidp dp, const_efidp dpi, efidp *out); |
19 | * though older or other compilers might just ignore that attribute if they | 20 | * though older or other compilers might just ignore that attribute if they |
20 | * don't support it. Ugh. | 21 | * don't support it. Ugh. |
21 | */ | 22 | */ |
diff --git a/meta-oe/recipes-bsp/efivar/efivar/0001-efivar-fix-for-cross-compile.patch b/meta-oe/recipes-bsp/efivar/efivar/0001-efivar-fix-for-cross-compile.patch index 6f6ca6475a..251e50c902 100644 --- a/meta-oe/recipes-bsp/efivar/efivar/0001-efivar-fix-for-cross-compile.patch +++ b/meta-oe/recipes-bsp/efivar/efivar/0001-efivar-fix-for-cross-compile.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 9a3c480af653b37e62d1be04d49fe7a60a80168f Mon Sep 17 00:00:00 2001 | 1 | From a9115d9e6f0f62d6bb735ce3698858d1f89f8d73 Mon Sep 17 00:00:00 2001 |
2 | From: Kai Kang <kai.kang@windriver.com> | 2 | From: Kai Kang <kai.kang@windriver.com> |
3 | Date: Fri, 25 Sep 2015 18:14:31 +0800 | 3 | Date: Fri, 25 Sep 2015 18:14:31 +0800 |
4 | Subject: [PATCH 1/2] efivar: fix for cross compile | 4 | Subject: [PATCH] efivar: fix for cross compile |
5 | 5 | ||
6 | It builds and calls elf file makeguids to generate a header file which | 6 | It builds and calls elf file makeguids to generate a header file which |
7 | doesn't work for cross compile. Fix it. | 7 | doesn't work for cross compile. Fix it. |
@@ -16,10 +16,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | |||
16 | 1 file changed, 2 insertions(+), 2 deletions(-) | 16 | 1 file changed, 2 insertions(+), 2 deletions(-) |
17 | 17 | ||
18 | diff --git a/src/Makefile b/src/Makefile | 18 | diff --git a/src/Makefile b/src/Makefile |
19 | index 5fc7887..1829d22 100644 | 19 | index 0c16597..dcc7fc8 100644 |
20 | --- a/src/Makefile | 20 | --- a/src/Makefile |
21 | +++ b/src/Makefile | 21 | +++ b/src/Makefile |
22 | @@ -29,8 +29,8 @@ all : deps $(TARGETS) | 22 | @@ -40,8 +40,8 @@ abicheck : $(patsubst %.so,%.abicheck,$(LIBTARGETS)) |
23 | ./guid-symbols.c : include/efivar/efivar-guids.h | 23 | ./guid-symbols.c : include/efivar/efivar-guids.h |
24 | ./guids.bin : include/efivar/efivar-guids.h | 24 | ./guids.bin : include/efivar/efivar-guids.h |
25 | ./names.bin : include/efivar/efivar-guids.h | 25 | ./names.bin : include/efivar/efivar-guids.h |
@@ -30,6 +30,3 @@ index 5fc7887..1829d22 100644 | |||
30 | guid-symbols.c include/efivar/efivar-guids.h | 30 | guid-symbols.c include/efivar/efivar-guids.h |
31 | 31 | ||
32 | makeguids : CPPFLAGS+=-DEFIVAR_BUILD_ENVIRONMENT | 32 | makeguids : CPPFLAGS+=-DEFIVAR_BUILD_ENVIRONMENT |
33 | -- | ||
34 | 2.4.3 | ||
35 | |||
diff --git a/meta-oe/recipes-bsp/efivar/efivar/0001-makeguids-Do-not-use-__bswap_constant_-16-32-macros.patch b/meta-oe/recipes-bsp/efivar/efivar/0001-makeguids-Do-not-use-__bswap_constant_-16-32-macros.patch index 73a772186a..2a6eb065f3 100644 --- a/meta-oe/recipes-bsp/efivar/efivar/0001-makeguids-Do-not-use-__bswap_constant_-16-32-macros.patch +++ b/meta-oe/recipes-bsp/efivar/efivar/0001-makeguids-Do-not-use-__bswap_constant_-16-32-macros.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 98b33d4193998687aa3a78c097f7bd4c393e0c85 Mon Sep 17 00:00:00 2001 | 1 | From dd4291265b7b3d7d7ffa1d8adf32781ae25dbfeb Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 15 Jul 2017 00:29:42 -0700 | 3 | Date: Sat, 15 Jul 2017 00:29:42 -0700 |
4 | Subject: [PATCH] makeguids: Do not use __bswap_constant_{16|32} macros | 4 | Subject: [PATCH] makeguids: Do not use __bswap_constant_{16|32} macros |
@@ -6,6 +6,7 @@ Subject: [PATCH] makeguids: Do not use __bswap_constant_{16|32} macros | |||
6 | not available on musl | 6 | not available on musl |
7 | 7 | ||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
9 | |||
9 | --- | 10 | --- |
10 | src/makeguids.c | 8 ++++---- | 11 | src/makeguids.c | 8 ++++---- |
11 | 1 file changed, 4 insertions(+), 4 deletions(-) | 12 | 1 file changed, 4 insertions(+), 4 deletions(-) |
@@ -32,6 +33,3 @@ index da2f5f7..daf821a 100644 | |||
32 | #endif\n\ | 33 | #endif\n\ |
33 | """); | 34 | """); |
34 | 35 | ||
35 | -- | ||
36 | 2.13.3 | ||
37 | |||
diff --git a/meta-oe/recipes-bsp/efivar/efivar/0003-efivar-fix-for-cross-compile.patch b/meta-oe/recipes-bsp/efivar/efivar/0003-efivar-fix-for-cross-compile.patch index 3f43f2a93e..83105fe0d1 100644 --- a/meta-oe/recipes-bsp/efivar/efivar/0003-efivar-fix-for-cross-compile.patch +++ b/meta-oe/recipes-bsp/efivar/efivar/0003-efivar-fix-for-cross-compile.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 7ead29ca6bb5e280ae07551cc3521281ecf73682 Mon Sep 17 00:00:00 2001 | 1 | From dea4a55714249b2734a36701120fd22c91c64ec2 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Sat, 7 May 2016 02:06:47 -0400 | 3 | Date: Sat, 7 May 2016 02:06:47 -0400 |
4 | Subject: [PATCH] Makefile: fix efivar.pc not found | 4 | Subject: [PATCH] Makefile: fix efivar.pc not found |
@@ -20,17 +20,18 @@ It fixes efivar.pc not found: | |||
20 | Upstream-Status: Pending | 20 | Upstream-Status: Pending |
21 | 21 | ||
22 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | 22 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
23 | |||
23 | --- | 24 | --- |
24 | src/Makefile | 4 +++- | 25 | src/Makefile | 4 +++- |
25 | 1 file changed, 3 insertions(+), 1 deletion(-) | 26 | 1 file changed, 3 insertions(+), 1 deletion(-) |
26 | 27 | ||
27 | diff --git a/src/Makefile b/src/Makefile | 28 | diff --git a/src/Makefile b/src/Makefile |
28 | index c7a0ca3..ad9c427 100644 | 29 | index dcc7fc8..691aa8a 100644 |
29 | --- a/src/Makefile | 30 | --- a/src/Makefile |
30 | +++ b/src/Makefile | 31 | +++ b/src/Makefile |
31 | @@ -78,7 +78,9 @@ install : all | 32 | @@ -94,7 +94,9 @@ install : all |
32 | ln -fs $(x).$(VERSION) $(DESTDIR)$(libdir)/$(x).$(MAJOR_VERSION);\ | 33 | ln -fs $(x).1.$(VERSION) $(DESTDIR)$(libdir)/$(x) ;\ |
33 | ln -fs $(x).$(VERSION) $(DESTDIR)$(libdir)/$(x); ) | 34 | ) |
34 | $(INSTALL) -d -m 755 $(DESTDIR)$(PCDIR) | 35 | $(INSTALL) -d -m 755 $(DESTDIR)$(PCDIR) |
35 | - $(foreach x, $(PCTARGETS), $(INSTALL) -m 644 $(x) $(DESTDIR)$(PCDIR) ;) | 36 | - $(foreach x, $(PCTARGETS), $(INSTALL) -m 644 $(x) $(DESTDIR)$(PCDIR) ;) |
36 | + $(foreach x, $(PCTARGETS), $(INSTALL) -m 644 $(TOPDIR)/src/$(x).in $(DESTDIR)$(PCDIR)/$(x) ;\ | 37 | + $(foreach x, $(PCTARGETS), $(INSTALL) -m 644 $(TOPDIR)/src/$(x).in $(DESTDIR)$(PCDIR)/$(x) ;\ |
@@ -39,6 +40,3 @@ index c7a0ca3..ad9c427 100644 | |||
39 | $(INSTALL) -d -m 755 $(DESTDIR)$(includedir)/efivar | 40 | $(INSTALL) -d -m 755 $(DESTDIR)$(includedir)/efivar |
40 | $(foreach x, $(wildcard $(TOPDIR)/src/include/efivar/*.h), $(INSTALL) -m 644 $(x) $(DESTDIR)$(includedir)/efivar/$(notdir $(x));) | 41 | $(foreach x, $(wildcard $(TOPDIR)/src/include/efivar/*.h), $(INSTALL) -m 644 $(x) $(DESTDIR)$(includedir)/efivar/$(notdir $(x));) |
41 | $(INSTALL) -d -m 755 $(DESTDIR)$(bindir) | 42 | $(INSTALL) -d -m 755 $(DESTDIR)$(bindir) |
42 | -- | ||
43 | 2.8.1 | ||
44 | |||
diff --git a/meta-oe/recipes-bsp/efivar/efivar/allow-multi-definitions-for-native.patch b/meta-oe/recipes-bsp/efivar/efivar/allow-multi-definitions-for-native.patch index 87f555509b..f88af1fe17 100644 --- a/meta-oe/recipes-bsp/efivar/efivar/allow-multi-definitions-for-native.patch +++ b/meta-oe/recipes-bsp/efivar/efivar/allow-multi-definitions-for-native.patch | |||
@@ -1,3 +1,8 @@ | |||
1 | From c801dcb03d42eb533a9bead0b397d7ce4fc5a6fe Mon Sep 17 00:00:00 2001 | ||
2 | From: Kai Kang <kai.kang@windriver.com> | ||
3 | Date: Wed, 10 Aug 2016 17:49:50 +0800 | ||
4 | Subject: [PATCH] allow multi definitions for native | ||
5 | |||
1 | Upstream-Status: Pending | 6 | Upstream-Status: Pending |
2 | 7 | ||
3 | It fails to create .so file when build efivar-native: | 8 | It fails to create .so file when build efivar-native: |
@@ -8,16 +13,20 @@ It fails to create .so file when build efivar-native: | |||
8 | Add link option '-z muldefs' to fix it. | 13 | Add link option '-z muldefs' to fix it. |
9 | 14 | ||
10 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | 15 | Signed-off-by: Kai Kang <kai.kang@windriver.com> |
16 | |||
11 | --- | 17 | --- |
18 | Make.rules | 1 + | ||
19 | 1 file changed, 1 insertion(+) | ||
20 | |||
12 | diff --git a/Make.rules b/Make.rules | 21 | diff --git a/Make.rules b/Make.rules |
13 | index d9c0609..874bce0 100644 | 22 | index 88b9aa7..799332f 100644 |
14 | --- a/Make.rules | 23 | --- a/Make.rules |
15 | +++ b/Make.rules | 24 | +++ b/Make.rules |
16 | @@ -20,6 +20,7 @@ include $(TOPDIR)/Make.version | 25 | @@ -20,6 +20,7 @@ include $(TOPDIR)/Make.version |
17 | $(CCLD) $(ccldflags) $(CPPFLAGS) $(SOFLAGS) \ | 26 | $(CCLD) $(ccldflags) $(CPPFLAGS) $(SOFLAGS) \ |
18 | -Wl,-soname,$@.$(MAJOR_VERSION) \ | 27 | -Wl,-soname,$@.1 \ |
19 | -Wl,--version-script=$(MAP) \ | 28 | -Wl,--version-script=$(MAP) \ |
20 | + -Wl,-z,muldefs \ | 29 | + -Wl,-z,muldefs \ |
21 | -o $@ $^ $(LDLIBS) | 30 | -o $@ $^ $(LDLIBS) |
22 | 31 | ||
23 | %.o : %.c | 32 | %.abixml : %.so |
diff --git a/meta-oe/recipes-bsp/efivar/efivar/fix-compile-failure-with-host-gcc-4.6.patch b/meta-oe/recipes-bsp/efivar/efivar/fix-compile-failure-with-host-gcc-4.6.patch index e3fa2e1c1a..dbc9a5755e 100644 --- a/meta-oe/recipes-bsp/efivar/efivar/fix-compile-failure-with-host-gcc-4.6.patch +++ b/meta-oe/recipes-bsp/efivar/efivar/fix-compile-failure-with-host-gcc-4.6.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 1361225abbaba878960f970df39a4570bbc39553 Mon Sep 17 00:00:00 2001 | 1 | From 3edce6a0019bcb90febc1f654b5b2e2bad5c59bd Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Thu, 26 May 2016 21:50:01 -0400 | 3 | Date: Thu, 26 May 2016 21:50:01 -0400 |
4 | Subject: [PATCH] fix compile failure with older host gcc (<=4.6) | 4 | Subject: [PATCH] fix compile failure with older host gcc (<=4.6) |
@@ -16,14 +16,15 @@ and directly remove -Wmaybe-uninitialized and -flto. | |||
16 | Upstream-Status: Pending | 16 | Upstream-Status: Pending |
17 | 17 | ||
18 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | 18 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
19 | |||
19 | --- | 20 | --- |
20 | gcc.specs | 4 ++-- | 21 | gcc.specs | 4 ++-- |
21 | 1 file changed, 2 insertions(+), 2 deletions(-) | 22 | 1 file changed, 2 insertions(+), 2 deletions(-) |
22 | 23 | ||
23 | Index: git/gcc.specs | 24 | diff --git a/gcc.specs b/gcc.specs |
24 | =================================================================== | 25 | index 45d43d1..f1c6944 100644 |
25 | --- git.orig/gcc.specs | 26 | --- a/gcc.specs |
26 | +++ git/gcc.specs | 27 | +++ b/gcc.specs |
27 | @@ -2,13 +2,13 @@ | 28 | @@ -2,13 +2,13 @@ |
28 | + -D_GNU_SOURCE | 29 | + -D_GNU_SOURCE |
29 | 30 | ||
diff --git a/meta-oe/recipes-bsp/efivar/efivar/musl-strndupa.patch b/meta-oe/recipes-bsp/efivar/efivar/musl-strndupa.patch index fc8f8c8b21..5864ac63e4 100644 --- a/meta-oe/recipes-bsp/efivar/efivar/musl-strndupa.patch +++ b/meta-oe/recipes-bsp/efivar/efivar/musl-strndupa.patch | |||
@@ -1,9 +1,17 @@ | |||
1 | Taken from void linux | 1 | From 8000b9afc858472912aace985004b44f8eb467e0 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 18 Aug 2017 09:49:49 -0700 | ||
4 | Subject: [PATCH] support musl | ||
2 | 5 | ||
3 | Index: git/src/linux.c | 6 | Upstream-Status: Pending |
4 | =================================================================== | 7 | --- |
5 | --- git.orig/src/linux.c | 8 | src/linux.c | 4 ++++ |
6 | +++ git/src/linux.c | 9 | 1 file changed, 4 insertions(+) |
10 | |||
11 | diff --git a/src/linux.c b/src/linux.c | ||
12 | index 34ed479..1304f2b 100644 | ||
13 | --- a/src/linux.c | ||
14 | +++ b/src/linux.c | ||
7 | @@ -40,6 +40,10 @@ | 15 | @@ -40,6 +40,10 @@ |
8 | #include <efivar.h> | 16 | #include <efivar.h> |
9 | #include <efiboot.h> | 17 | #include <efiboot.h> |