summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch26
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone/80oe.conf23
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone/gateone.service2
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone/server.conf5
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb42
5 files changed, 77 insertions, 21 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch b/meta-oe/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch
new file mode 100644
index 000000000..5f5fa9117
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch
@@ -0,0 +1,26 @@
1From d811d3bdf06d78c93c48bef762c19c392c879077 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Tue, 26 Nov 2013 15:54:10 +0100
4Subject: [PATCH] configuration.py: Hack around broken gethostname thingy
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 gateone/core/configuration.py | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/gateone/core/configuration.py b/gateone/core/configuration.py
12index da41cbd..d1c8222 100644
13--- a/gateone/core/configuration.py
14+++ b/gateone/core/configuration.py
15@@ -162,7 +162,7 @@ def define_options(installed=True):
16 ]
17 # Used both http and https above to demonstrate that both are acceptable
18 try:
19- additional_origins = socket.gethostbyname_ex(socket.gethostname())
20+ additional_origins = [] # additional_origins = socket.gethostbyname_ex(socket.gethostname())
21 except socket.gaierror:
22 # Couldn't get any IPs from the hostname
23 additional_origins = []
24--
251.8.4.2
26
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/80oe.conf b/meta-oe/recipes-connectivity/gateone/gateone/80oe.conf
new file mode 100644
index 000000000..cde98bc10
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gateone/gateone/80oe.conf
@@ -0,0 +1,23 @@
1// Some custom Gate One settings for OpenEmbedded
2{
3 "*": {
4 "gateone": { // These settings apply to all of Gate One
5 "log_file_max_size": 5242880, // 5 megabyte logs for OE by default (default would normally be 100Mb)
6 "log_file_num_backups": 2, // Default is normally 10
7 "origins": ["*"], // Every device has a unique origin
8 "logging": "info",
9 "pid_file": "/var/run/gateone.pid",
10 "session_dir": "/tmp/gateone",
11 "user_dir": "/var/lib/gateone/users"
12 },
13 "terminal": {
14 // Disabling session logging for embedded devices is a good idea (limited/slow storage)
15 "session_logging": false,
16 "syslog_session_logging": false
17// "commands": {
18// // For some reason this doesn't work (never asks for the password)
19// "login": "setsid /bin/login" // Normally this would emulate logging into the host console
20// }
21 }
22 }
23}
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service b/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
index 7ff60020a..7b14d3e6d 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
+++ b/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
@@ -4,7 +4,7 @@ ConditionPathExists=|/var/lib/gateone
4 4
5[Service] 5[Service]
6WorkingDirectory=/var/lib/gateone 6WorkingDirectory=/var/lib/gateone
7ExecStart=/usr/bin/python gateone.py 7ExecStart=/usr/bin/python /usr/bin/gateone
8 8
9[Install] 9[Install]
10WantedBy=multi-user.target 10WantedBy=multi-user.target
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/server.conf b/meta-oe/recipes-connectivity/gateone/gateone/server.conf
deleted file mode 100644
index 988b0d085..000000000
--- a/meta-oe/recipes-connectivity/gateone/gateone/server.conf
+++ /dev/null
@@ -1,5 +0,0 @@
1session_logging = False
2origins = "*"
3command = "/var/lib/gateone/plugins/ssh/scripts/ssh_connect.py -S '/tmp/gateone/%SESSION%/%SHORT_SOCKET%' --sshfp -a '-oUserKnownHostsFile=%USERDIR%/%USER%/ssh/known_hosts'"
4log_file_prefix = "/var/log/gateone.log"
5
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
index 0069c26c1..edc997721 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -1,14 +1,14 @@
1SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client" 1SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
2LICENSE = "AGPL-3.0" 2LICENSE = "AGPL-3.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c" 3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
4HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
4 5
5PR = "r13" 6PV = "1.2"
6 7SRCREV = "1528d324088fc1c180b7fdf50f5b5c1af057eef6"
7PV = "1.1"
8SRCREV = "ea5db3dcb3bbbe445ae6d1a5611c1f8d547c57b9"
9SRC_URI = "git://github.com/liftoff/GateOne.git \ 8SRC_URI = "git://github.com/liftoff/GateOne.git \
9 file://0001-configuration.py-Hack-around-broken-gethostname-thin.patch \
10 file://gateone-avahi.service \ 10 file://gateone-avahi.service \
11 file://server.conf \ 11 file://80oe.conf \
12 file://gateone.service \ 12 file://gateone.service \
13 file://gateone-init \ 13 file://gateone-init \
14" 14"
@@ -16,33 +16,44 @@ SRC_URI = "git://github.com/liftoff/GateOne.git \
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18inherit distutils python-dir systemd update-rc.d 18inherit distutils python-dir systemd update-rc.d
19export prefix = "${localstatedir}"
19 20
20export prefix = "${localstatedir}/lib" 21DISTUTILS_INSTALL_ARGS = "--root=${D} \
22 --prefix=${prefix} \
23 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
24 --install-data=${PYTHON_SITEPACKAGES_DIR} \
25 --install-scripts=${bindir} \
26 --skip_init_scripts"
21 27
22do_install_append() { 28do_install_append() {
23 install -d ${D}${localstatedir}/log/${BPN}
24 29
25 install -m 0755 -d ${D}${sysconfdir}/avahi/services/ 30 # fix up hardcoded paths
26 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/ 31 sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/gateone.service
27
28 install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf
29 32
30 install -d ${D}${systemd_unitdir}/system 33 install -d ${D}${systemd_unitdir}/system
31 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system 34 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
32 35
33 install -d ${D}${sysconfdir}/init.d 36 install -d ${D}${sysconfdir}/init.d
34 install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone 37 install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone
38
39 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
40 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
41
42 install -m 0755 -d ${D}${sysconfdir}/gateone/conf.d/
43 install -m 0644 ${WORKDIR}/80oe.conf ${D}${sysconfdir}/gateone/conf.d/80oe.conf
44
45 install -d ${D}${localstatedir}/lib/gateone
35} 46}
36 47
37FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${localstatedir}/volatile/log ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}" 48FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}"
38RDEPENDS_${PN} = "file \ 49RDEPENDS_${PN} = "mime-support \
39 mime-support \
40 openssh-ssh \ 50 openssh-ssh \
41 python-compression \ 51 python-compression \
42 python-crypt \ 52 python-crypt \
43 python-datetime \ 53 python-datetime \
44 python-email \ 54 python-email \
45 python-fcntl \ 55 python-fcntl \
56 python-futures \
46 python-html \ 57 python-html \
47 python-imaging \ 58 python-imaging \
48 python-io \ 59 python-io \
@@ -55,6 +66,7 @@ RDEPENDS_${PN} = "file \
55 python-pyopenssl \ 66 python-pyopenssl \
56 python-re \ 67 python-re \
57 python-readline \ 68 python-readline \
69 python-setuptools \
58 python-shell \ 70 python-shell \
59 python-simplejson \ 71 python-simplejson \
60 python-subprocess \ 72 python-subprocess \