summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
new file mode 100644
index 000000000..fbc6bdfbe
--- /dev/null
+++ b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Inject PCIE AER errors on the software level into a running Linux kernel."
2DESCRIPTION = "\
3aer-inject allows to inject PCIE AER errors on the software \
4level into a running Linux kernel. This is intended for \
5validation of the PCIE driver error recovery handler and \
6PCIE AER core handler."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/gong.chen/aer-inject.git/"
8SECTION = "pcie/misc"
9LICENSE = "GPL-2.0-only"
10
11LIC_FILES_CHKSUM = "file://README;beginline=25;endline=38;md5=643c2332ec702691a87ba6ea9499b2d6"
12
13SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/gong.chen/aer-inject.git;protocol=https;branch=master \
14"
15SRCREV = "9bd5e2c7886fca72f139cd8402488a2235957d41"
16
17S = "${WORKDIR}/git"
18
19DEPENDS = "bison-native"
20
21do_compile() {
22 oe_runmake CFLAGS="-Wall -D_GNU_SOURCE"
23}
24
25do_install() {
26 oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr/' install
27}
28FILES:${PN} += "/usr/aer-inject"
29BBCLASSEXTEND = "native nativesdk" \ No newline at end of file