summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-perl/recipes-perl/libcgi/libcgi-perl_4.38.bb25
-rw-r--r--meta-perl/recipes-perl/libcgi/libcgi-perl_4.43.bb50
2 files changed, 50 insertions, 25 deletions
diff --git a/meta-perl/recipes-perl/libcgi/libcgi-perl_4.38.bb b/meta-perl/recipes-perl/libcgi/libcgi-perl_4.38.bb
deleted file mode 100644
index db16d8307..000000000
--- a/meta-perl/recipes-perl/libcgi/libcgi-perl_4.38.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1DESCRIPTION = "CGI.pm is a stable, complete and mature solution for processing and preparing \
2HTTP requests and responses. Major features including processing form \
3submissions, file uploads, reading and writing cookies, query string generation \
4and manipulation, and processing and preparing HTTP headers."
5HOMEPAGE = "http://search.cpan.org/~leejo/CGI-4.28/lib/CGI.pod"
6SECTION = "libs"
7LICENSE = "Artistic-2.0 | GPL-2.0"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=2e9769f0a2613a98bc7fce15dee0c533"
10
11SRC_URI = "http://search.cpan.org/CPAN/authors/id/L/LE/LEEJO/CGI-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "0aeb8563d533e7f83724ed068b5bfc37"
14SRC_URI[sha256sum] = "8c58f4a529bb92a914b22b7e64c5e31185c9854a4070a6dfad44fe5cc248e7d4"
15
16S = "${WORKDIR}/CGI-${PV}"
17
18inherit cpan
19
20RDEPENDS_${PN} += "\
21 perl-module-deprecate \
22 perl-module-if \
23"
24
25RPROVIDES_${PN} += "perl-module-cgi"
diff --git a/meta-perl/recipes-perl/libcgi/libcgi-perl_4.43.bb b/meta-perl/recipes-perl/libcgi/libcgi-perl_4.43.bb
new file mode 100644
index 000000000..b4571b27e
--- /dev/null
+++ b/meta-perl/recipes-perl/libcgi/libcgi-perl_4.43.bb
@@ -0,0 +1,50 @@
1DESCRIPTION = "CGI.pm is a stable, complete and mature solution for processing and preparing \
2HTTP requests and responses. Major features including processing form \
3submissions, file uploads, reading and writing cookies, query string generation \
4and manipulation, and processing and preparing HTTP headers."
5HOMEPAGE = "http://search.cpan.org/~leejo/CGI-4.28/lib/CGI.pod"
6SECTION = "libs"
7LICENSE = "Artistic-2.0 | GPL-2.0"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=415fc49abed2728f9480cd32c8d67beb"
10
11SRC_URI = "http://search.cpan.org/CPAN/authors/id/L/LE/LEEJO/CGI-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "8c1f2cf11e4410911827ea48d58aaecc"
14SRC_URI[sha256sum] = "14b94f9df6e48fc26ebc4fa1e01a7b534cbc1611028a49028f9ac9d8ca27b734"
15
16S = "${WORKDIR}/CGI-${PV}"
17
18inherit cpan ptest-perl
19
20RDEPENDS_${PN} += "\
21 libhtml-parser-perl \
22 perl-module-base \
23 perl-module-deprecate \
24 perl-module-if \
25"
26
27do_install_prepend() {
28 # requires "-T" (taint) command line option
29 rm -rf ${B}/t/push.t
30 rm -rf ${B}/t/utf8.t
31 # tests building of docs
32 rm -rf ${B}/t/compiles_pod.t
33}
34
35RDEPENDS_${PN}-ptest += " \
36 libtest-deep-perl \
37 perl-module-bytes \
38 perl-module-file-find \
39 perl-module-filehandle \
40 perl-module-findbin \
41 perl-module-lib \
42 perl-module-perlio \
43 perl-module-perlio-scalar \
44 perl-module-test-more \
45 perl-module-utf8 \
46"
47
48RPROVIDES_${PN} += "perl-module-cgi"
49
50BBCLASSEXTEND = "native"