diff options
-rw-r--r-- | meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc43x.diff | 63 | ||||
-rw-r--r-- | meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb | 19 |
2 files changed, 82 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc43x.diff b/meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc43x.diff new file mode 100644 index 000000000..fcc52c1f4 --- /dev/null +++ b/meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc43x.diff | |||
@@ -0,0 +1,63 @@ | |||
1 | --- /tmp/mathVariantAux.cc 2008-07-13 15:56:56.000000000 +0200 | ||
2 | +++ gtkmathview-0.8.0/src/engine/mathml/mathVariantAux.cc 2008-07-13 15:57:46.893198000 +0200 | ||
3 | @@ -20,6 +20,8 @@ | ||
4 | |||
5 | #include <cassert> | ||
6 | |||
7 | +#include <string.h> | ||
8 | + | ||
9 | #include "mathVariantAux.hh" | ||
10 | |||
11 | static MathVariantAttributes vattr[] = { | ||
12 | --- /tmp/T1_FontDataBase.cc 2008-07-13 16:25:24.000000000 +0200 | ||
13 | +++ gtkmathview-0.8.0/src/backend/ps/T1_FontDataBase.cc 2008-07-13 16:25:47.123198000 +0200 | ||
14 | @@ -20,6 +20,7 @@ | ||
15 | #include <config.h> | ||
16 | #include <map> | ||
17 | #include <string> | ||
18 | +#include <string.h> | ||
19 | #include <stdlib.h> | ||
20 | #include <iostream> | ||
21 | #include <list> | ||
22 | --- /tmp/SMS.cc 2008-07-13 16:27:23.000000000 +0200 | ||
23 | +++ gtkmathview-0.8.0/mathmlsvg/SMS.cc 2008-07-13 16:27:41.543198000 +0200 | ||
24 | @@ -19,6 +19,7 @@ | ||
25 | #include <config.h> | ||
26 | |||
27 | #include <sstream> | ||
28 | +#include <string.h> | ||
29 | #include "defs.h" | ||
30 | #include "AbstractLogger.hh" | ||
31 | #include "ValueConversion.hh" | ||
32 | --- /tmp/main.cc 2008-07-13 16:29:11.000000000 +0200 | ||
33 | +++ gtkmathview-0.8.0/mathmlsvg/main.cc 2008-07-13 16:29:28.813198000 +0200 | ||
34 | @@ -20,7 +20,7 @@ | ||
35 | |||
36 | #include <cassert> | ||
37 | #include <fstream> | ||
38 | - | ||
39 | +#include <string.h> | ||
40 | #include <popt.h> | ||
41 | |||
42 | // needed for old versions of GCC, must come before String.hh! | ||
43 | --- /tmp/main.cc 2008-07-13 16:30:11.000000000 +0200 | ||
44 | +++ gtkmathview-0.8.0/mathmlps/main.cc 2008-07-13 16:30:33.183198000 +0200 | ||
45 | @@ -20,7 +20,7 @@ | ||
46 | |||
47 | #include <cassert> | ||
48 | #include <fstream> | ||
49 | - | ||
50 | +#include <string.h> | ||
51 | #include <popt.h> | ||
52 | |||
53 | // needed for old versions of GCC, must come before String.hh! | ||
54 | --- gtkmathview-0.8.0.orig/src/common/AbstractLogger.cc 2007-08-17 12:02:45.000000000 +0200 | ||
55 | +++ gtkmathview-0.8.0/src/common/AbstractLogger.cc 2010-02-01 10:19:46.000000000 +0100 | ||
56 | @@ -19,6 +19,7 @@ | ||
57 | #include <config.h> | ||
58 | |||
59 | #include <stdarg.h> | ||
60 | +#include <stdio.h> | ||
61 | |||
62 | #include "AbstractLogger.hh" | ||
63 | |||
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb new file mode 100644 index 000000000..725b1c812 --- /dev/null +++ b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | HOMEPAGE = "http://helm.cs.unibo.it/mml-widget/" | ||
2 | DEPENDS = "t1lib gtk+ popt libxslt libxml2" | ||
3 | |||
4 | LICENSE = "LGPLv3" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6" | ||
6 | |||
7 | SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \ | ||
8 | file://mathview-gcc43x.diff \ | ||
9 | " | ||
10 | SRC_URI[md5sum] = "b53564e553728d4b69f7d366dfeb5299" | ||
11 | SRC_URI[sha256sum] = "1dc30175da6a3c560a7d62d1abe1c2f9829d988e6f1a7c5e766544575c558c43" | ||
12 | |||
13 | inherit autotools | ||
14 | |||
15 | EXTRA_OECONF = "--disable-binreloc" | ||
16 | |||
17 | do_configure_prepend() { | ||
18 | sed -i -e s:AM_BINRELOC::g ${S}/configure.ac | ||
19 | } | ||