summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio.inc11
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch58
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch42
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb10
4 files changed, 112 insertions, 9 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio.inc b/meta-oe/recipes-connectivity/gnuradio/gnuradio.inc
index d114f89ea..3759e077b 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio.inc
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio.inc
@@ -1,10 +1,11 @@
1DESCRIPTION = "GNU Radio" 1DESCRIPTION = "GNU Radio"
2URL = "http://gnuradio.org" 2HOMEPAGE = "http://gnuradio.org"
3SECTION = "apps"
4PRIORITY = "optional"
5LICENSE = "GPLv3" 3LICENSE = "GPLv3"
6DEPENDS = "uhd gsl guile-native fftwf python alsa-lib boost cppunit swig-native python-numpy" 4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7INC_PR = "r8" 5
6DEPENDS = "uhd virtual/libsdl gsl guile-native fftwf python alsa-lib boost cppunit swig-native python-numpy"
7
8INC_PR = "r0"
8 9
9inherit distutils-base autotools pkgconfig 10inherit distutils-base autotools pkgconfig
10 11
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch b/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch
new file mode 100644
index 000000000..7caaf51e6
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch
@@ -0,0 +1,58 @@
1From a130153ae84d8bb5914879cef94df09f06825c10 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sat, 18 Jun 2011 11:25:36 +0200
4Subject: [PATCH] buildsys: don't add /usr/include and /usr/lib to configure tests for libusb
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 config/usrp_libusb.m4 | 13 -------------
9 1 files changed, 0 insertions(+), 13 deletions(-)
10
11diff --git a/config/usrp_libusb.m4 b/config/usrp_libusb.m4
12index cc3410f..b421820 100644
13--- a/config/usrp_libusb.m4
14+++ b/config/usrp_libusb.m4
15@@ -117,10 +117,6 @@ AC_DEFUN([USRP_LIBUSB], [
16 dnl configured to find this header.
17 AC_LANG_PUSH(C)
18 save_CPPFLAGS="$CPPFLAGS"
19- if test x$USB_INCLUDEDIR != x; then
20- USB_INCLUDES="-I$USB_INCLUDEDIR"
21- CPPFLAGS="$USB_INCLUDES"
22- fi
23 AC_MSG_CHECKING([$libusb_name for header $usb_header])
24 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
25 #include "$usb_header"
26@@ -172,9 +168,6 @@ AC_DEFUN([USRP_LIBUSB], [
27 *)
28 AC_LANG_PUSH(C)
29 save_CPPFLAGS="$CPPFLAGS"
30- if test x$USB_INCLUDEDIR != x; then
31- CPPFLAGS="$USB_INCLUDES"
32- fi
33 save_LIBS="$LIBS"
34 LIBS="$USB_LIBS"
35 AC_MSG_CHECKING([$libusb_name for symbol usb_debug in library $usb_lib_name])
36@@ -217,9 +210,6 @@ AC_DEFUN([USRP_LIBUSB], [
37 dnl final error checking, mostly to create #define's
38 AC_LANG_PUSH(C)
39 save_CPPFLAGS="$CPPFLAGS"
40- if test x$USB_INCLUDEDIR != x; then
41- CPPFLAGS="$USB_INCLUDES"
42- fi
43 dnl Check for the header.
44 AC_CHECK_HEADERS([$usb_header], [], [libusbok=no])
45 CPPFLAGS="$save_CPPFLAGS"
46@@ -231,9 +221,6 @@ AC_DEFUN([USRP_LIBUSB], [
47 dnl check for the library (again)
48 AC_LANG_PUSH(C)
49 save_CPPFLAGS="$CPPFLAGS"
50- if test x$USB_INCLUDEDIR != x; then
51- CPPFLAGS="$USB_INCLUDES"
52- fi
53 save_LIBS="$LIBS"
54 LIBS="$USB_LIBS"
55 AC_CHECK_LIB([$usb_lib_name], [$usb_lib_func], [], [
56--
571.6.6.1
58
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch b/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch
new file mode 100644
index 000000000..e2f674b75
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch
@@ -0,0 +1,42 @@
1From 857c38eb8201e2a34b524fcabea21b1accbdb288 Mon Sep 17 00:00:00 2001
2From: Philip Balister <philip@opensdr.com>
3Date: Fri, 13 May 2011 12:26:14 -0400
4Subject: [PATCH] volk : Remove all traces of volk from configure for OE builds.
5
6Signed-off-by: Philip Balister <philip@opensdr.com>
7---
8 Makefile.common | 4 ++--
9 configure.ac | 2 +-
10 2 files changed, 3 insertions(+), 3 deletions(-)
11
12diff --git a/Makefile.common b/Makefile.common
13index 20b8a78..aeda1dd 100644
14--- a/Makefile.common
15+++ b/Makefile.common
16@@ -92,8 +92,8 @@ GRUEL_INCLUDES = @gruel_INCLUDES@
17 GRUEL_LA = @gruel_LA@
18
19 # How to link in the VOLK library from inside the tree
20-VOLK_INCLUDES = @volk_INCLUDES@
21-VOLK_LA = @volk_LA@
22+#VOLK_INCLUDES = @volk_INCLUDES@
23+#VOLK_LA = @volk_LA@
24
25 # How to link in the USRP library from inside the tree
26 USRP_INCLUDES = @usrp_INCLUDES@
27diff --git a/configure.ac b/configure.ac
28index 73ebbd6..e5cf7a2 100644
29--- a/configure.ac
30+++ b/configure.ac
31@@ -349,7 +349,7 @@ AC_ARG_ENABLE(
32
33 build_dirs="config"
34 GRC_GRUEL dnl must come first
35-GRC_VOLK
36+dnl GRC_VOLK
37 GRC_GCELL
38 GRC_GNURADIO_CORE
39 GRC_USRP
40--
411.7.3.4
42
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index 757a80136..76c942418 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -1,16 +1,18 @@
1require gnuradio.inc 1require gnuradio.inc
2 2
3PR = "${INC_PR}.1" 3PR = "${INC_PR}.0"
4PV = "3.3.0-${PR}+gitr${SRCREV}" 4PV = "3.4.0-${PR}+gitr${SRCREV}"
5 5
6SRCREV = "cdca1c917626f7c63f820da921a17187efc92cd5" 6SRCREV = "f53fef3d2bc39b2020b8bce3d88b43569dd16605"
7 7
8# Make it easy to test against developer repos and branches 8# Make it easy to test against developer repos and branches
9GIT_REPO = "gnuradio.git" 9GIT_REPO = "gnuradio.git"
10GIT_BRANCH = "next" 10GIT_BRANCH = "next"
11 11
12SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \ 12SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \
13" 13 file://0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch \
14 file://0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch \
15 "
14 16
15S="${WORKDIR}/git" 17S="${WORKDIR}/git"
16 18