diff options
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2/0001-test-widget.c-fix-non-literal-format-string-issues.patch b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2/0001-test-widget.c-fix-non-literal-format-string-issues.patch new file mode 100644 index 000000000..6118b679a --- /dev/null +++ b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2/0001-test-widget.c-fix-non-literal-format-string-issues.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 0781b218beb8ba160ea223ff3d74a4fa2abf86fa Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Apr 2017 16:21:14 -0700 | ||
4 | Subject: [PATCH] test-widget.c: fix non-literal format string issues | ||
5 | |||
6 | clang errors out when using -Werror=format-nonliteral | ||
7 | since the definition of g_strdup_vprintf() from glib-2.0 | ||
8 | is using va_list and clang seems to still warn where as | ||
9 | gcc doesn't do that for va_list arguments | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | tests/test-widget.c | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/tests/test-widget.c b/tests/test-widget.c | ||
17 | index 46f5f4e..3f2e60f 100644 | ||
18 | --- a/tests/test-widget.c | ||
19 | +++ b/tests/test-widget.c | ||
20 | @@ -260,7 +260,7 @@ static const gchar *buffer_ui_description = | ||
21 | |||
22 | /* File loading code ----------------------------------------------------------------- */ | ||
23 | |||
24 | -static void | ||
25 | +static void G_GNUC_PRINTF (2, 0) | ||
26 | error_dialog (GtkWindow *parent, const gchar *msg, ...) | ||
27 | { | ||
28 | va_list ap; | ||
29 | -- | ||
30 | 2.12.2 | ||
31 | |||
diff --git a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2_2.10.5.bb b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2_2.10.5.bb index e3bf551eb..012f8e3bc 100644 --- a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2_2.10.5.bb +++ b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview2_2.10.5.bb | |||
@@ -18,7 +18,8 @@ REQUIRED_DISTRO_FEATURES = "x11" | |||
18 | SRC_URI = "${GNOME_MIRROR}/${PNAME}/${@gnome_verdir("${PV}")}/${PNAME}-${PV}.tar.bz2;name=archive \ | 18 | SRC_URI = "${GNOME_MIRROR}/${PNAME}/${@gnome_verdir("${PV}")}/${PNAME}-${PV}.tar.bz2;name=archive \ |
19 | file://gtk-doc.make \ | 19 | file://gtk-doc.make \ |
20 | file://suppress-string-format-literal-warning.patch \ | 20 | file://suppress-string-format-literal-warning.patch \ |
21 | " | 21 | file://0001-test-widget.c-fix-non-literal-format-string-issues.patch \ |
22 | " | ||
22 | SRC_URI[archive.md5sum] = "1219ad1694df136f126507466aeb41aa" | 23 | SRC_URI[archive.md5sum] = "1219ad1694df136f126507466aeb41aa" |
23 | SRC_URI[archive.sha256sum] = "c585773743b1df8a04b1be7f7d90eecdf22681490d6810be54c81a7ae152191e" | 24 | SRC_URI[archive.sha256sum] = "c585773743b1df8a04b1be7f7d90eecdf22681490d6810be54c81a7ae152191e" |
24 | 25 | ||