diff options
-rw-r--r-- | meta-oe/recipes-graphics/fbida/fbida_2.09.bb | 27 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/fbida/fbida_git.bb | 52 |
2 files changed, 52 insertions, 27 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.09.bb b/meta-oe/recipes-graphics/fbida/fbida_2.09.bb deleted file mode 100644 index 32f376f04..000000000 --- a/meta-oe/recipes-graphics/fbida/fbida_2.09.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | HOMEPAGE = "http://linux.bytesex.org/fbida/" | ||
2 | SUMMARY = "frame buffer image and doc viewer tools" | ||
3 | AUTHOR = "Gerd Hoffmann" | ||
4 | SECTION = "utils" | ||
5 | |||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" | ||
8 | |||
9 | DEPENDS = "virtual/libiconv libpng jpeg fontconfig freetype libexif curl libungif tiff" | ||
10 | |||
11 | SRC_URI = "git://git.kraxel.org/fbida" | ||
12 | SRCREV = "cb0ce5fa5f42bfaea4f8f326bcd8914dd14e782d" | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | EXTRA_OEMAKE = "STRIP=" | ||
16 | |||
17 | do_compile() { | ||
18 | sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I{STAGING_INCDIR}:g' GNUmakefile | ||
19 | oe_runmake | ||
20 | } | ||
21 | |||
22 | do_install() { | ||
23 | oe_runmake 'DESTDIR=${D}' install | ||
24 | } | ||
25 | |||
26 | RDEPENDS_${PN} = "ttf-dejavu-sans-mono" | ||
27 | |||
diff --git a/meta-oe/recipes-graphics/fbida/fbida_git.bb b/meta-oe/recipes-graphics/fbida/fbida_git.bb new file mode 100644 index 000000000..9eea664b9 --- /dev/null +++ b/meta-oe/recipes-graphics/fbida/fbida_git.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | SUMMARY = "Framebuffer image and doc viewer tools" | ||
2 | DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \ | ||
3 | with the main focus being photos." | ||
4 | HOMEPAGE = "http://linux.bytesex.org/fbida/" | ||
5 | AUTHOR = "Gerd Hoffmann" | ||
6 | SECTION = "utils" | ||
7 | |||
8 | LICENSE = "GPLv2" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" | ||
10 | |||
11 | DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif curl" | ||
12 | |||
13 | SRC_URI = "git://git.kraxel.org/fbida" | ||
14 | SRCREV = "cb0ce5fa5f42bfaea4f8f326bcd8914dd14e782d" | ||
15 | PV = "2.09+git${SRCPV}" | ||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | EXTRA_OEMAKE = "STRIP=" | ||
19 | |||
20 | PACKAGECONFIG ??= "gif png" | ||
21 | PACKAGECONFIG[gif] = ",,libungif" | ||
22 | PACKAGECONFIG[png] = ",,libpng" | ||
23 | PACKAGECONFIG[tiff] = ",,tiff" | ||
24 | |||
25 | do_compile() { | ||
26 | sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk | ||
27 | sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I${STAGING_INCDIR}:' ${S}/GNUmakefile | ||
28 | |||
29 | if [ -z "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" ]; then | ||
30 | sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile | ||
31 | fi | ||
32 | |||
33 | # Be sure to respect preferences (force to "no") | ||
34 | # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH} | ||
35 | if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then | ||
36 | sed -i -e '/^HAVE_LIBUNGIF/s/:=.*$/:= no/' ${S}/GNUmakefile | ||
37 | fi | ||
38 | if [ -z "${@base_contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then | ||
39 | sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile | ||
40 | fi | ||
41 | if [ -z "${@base_contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then | ||
42 | sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile | ||
43 | fi | ||
44 | |||
45 | oe_runmake | ||
46 | } | ||
47 | |||
48 | do_install() { | ||
49 | oe_runmake 'DESTDIR=${D}' install | ||
50 | } | ||
51 | |||
52 | RDEPENDS_${PN} = "ttf-dejavu-sans-mono" | ||