summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/gflags/gflags_2.1.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gflags/gflags_2.1.2.bb b/meta-oe/recipes-support/gflags/gflags_2.1.2.bb
new file mode 100644
index 000000000..b5e059798
--- /dev/null
+++ b/meta-oe/recipes-support/gflags/gflags_2.1.2.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "The gflags package contains a C++ library that implements commandline flags processing. It includes built-in support for standard types such as string and the ability to define flags in the source file in which they are used"
2
3HOMEPAGE = "https://github.com/gflags/gflags"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df"
7
8SRC_URI = "git://github.com/gflags/gflags.git;branch=release"
9SRCREV = "1a02f2851ee3d48d32d2c8f4d8f390a0bc25565c"
10S = "${WORKDIR}/git/"
11
12FILES_${PN}-dev += "${libdir}/cmake"
13
14inherit cmake
15
16EXTRA_OECMAKE="-DBUILD_SHARED_LIBS=ON"
17
18PACKAGES =+ "${PN}-bash-completion"
19FILES_${PN}-bash-completion += "${bindir}/gflags_completions.sh"
20RDEPENDS_${PN}-bash-completion = "bash-completion"