summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_10.16.0.bb (renamed from meta-oe/recipes-devtools/nodejs/nodejs_10.15.3.bb)17
1 files changed, 11 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.15.3.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.16.0.bb
index d2e77ea0d..aaa1da0aa 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_10.15.3.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.16.0.bb
@@ -1,9 +1,9 @@
1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" 1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
2HOMEPAGE = "http://nodejs.org" 2HOMEPAGE = "http://nodejs.org"
3LICENSE = "MIT & BSD & Artistic-2.0" 3LICENSE = "MIT & BSD & Artistic-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9ceeba79eb2ea1067b7b3ed16fff8bab" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=be980eb7ccafe287cb438076a65e888c"
5 5
6DEPENDS = "openssl zlib icu" 6DEPENDS = "openssl"
7DEPENDS_append_class-target = " nodejs-native" 7DEPENDS_append_class-target = " nodejs-native"
8 8
9inherit pkgconfig 9inherit pkgconfig
@@ -23,8 +23,8 @@ SRC_URI_append_class-target = " \
23 file://0002-Using-native-torque.patch \ 23 file://0002-Using-native-torque.patch \
24 " 24 "
25 25
26SRC_URI[md5sum] = "d76210a6ae1ea73d10254947684836fb" 26SRC_URI[md5sum] = "c9a7ab43f8b50c8a4d5545de307b7540"
27SRC_URI[sha256sum] = "4e22d926f054150002055474e452ed6cbb85860aa7dc5422213a2002ed9791d5" 27SRC_URI[sha256sum] = "18e37f891d10ea7fbc8f6410c444c2b1d9cc3cbbb1d35aa9c41f761816956608"
28 28
29S = "${WORKDIR}/node-v${PV}" 29S = "${WORKDIR}/node-v${PV}"
30 30
@@ -49,16 +49,21 @@ ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '-
49GYP_DEFINES_append_mipsel = " mips_arch_variant='r1' " 49GYP_DEFINES_append_mipsel = " mips_arch_variant='r1' "
50ARCHFLAGS ?= "" 50ARCHFLAGS ?= ""
51 51
52PACKAGECONFIG ??= "zlib icu"
53PACKAGECONFIG[zlib] = "--shared-zlib,,zlib"
54PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu"
55
52# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi 56# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
53do_configure () { 57do_configure () {
54 rm -rf ${S}/deps/openssl 58 rm -rf ${S}/deps/openssl
55 export LD="${CXX}" 59 export LD="${CXX}"
56 GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES 60 GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES
57 # $TARGET_ARCH settings don't match --dest-cpu settings 61 # $TARGET_ARCH settings don't match --dest-cpu settings
58 ./configure --prefix=${prefix} --with-intl=system-icu --without-snapshot --shared-openssl --shared-zlib \ 62 ./configure --prefix=${prefix} --without-snapshot --shared-openssl \
59 --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH'), d)}" \ 63 --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH'), d)}" \
60 --dest-os=linux \ 64 --dest-os=linux \
61 ${ARCHFLAGS} 65 ${ARCHFLAGS} \
66 ${PACKAGECONFIG_CONFARGS}
62} 67}
63 68
64do_compile () { 69do_compile () {