summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pyperf.inc23
-rw-r--r--meta-python/recipes-devtools/python/python-pyperf_1.6.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperf_1.6.1.bb4
3 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyperf.inc b/meta-python/recipes-devtools/python/python-pyperf.inc
new file mode 100644
index 000000000..81837f300
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyperf.inc
@@ -0,0 +1,23 @@
1SUMMARY = "A toolkit to write, run and analyze benchmarks"
2DESCRIPTION = " \
3The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
4Features: \
5 * Simple API to run reliable benchmarks \
6 * Automatically calibrate a benchmark for a time budget. \
7 * Spawn multiple worker processes. \
8 * Compute the mean and standard deviation. \
9 * Detect if a benchmark result seems unstable. \
10 * JSON format to store benchmark results. \
11 * Support multiple units: seconds, bytes and integer. \
12"
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
15
16SRC_URI[md5sum] = "d67fe5f447963da8873f3e9923f76de1"
17SRC_URI[sha256sum] = "8d0143a22a13ee10c997a648f30b82cdc40175d5a20b11055ae058a82e45d371"
18
19inherit pypi
20
21PYPI_PACKAGE = "pyperf"
22
23DEPENDS += "${PYTHON_PN}-six-native"
diff --git a/meta-python/recipes-devtools/python/python-pyperf_1.6.1.bb b/meta-python/recipes-devtools/python/python-pyperf_1.6.1.bb
new file mode 100644
index 000000000..a9d5c7488
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyperf_1.6.1.bb
@@ -0,0 +1,4 @@
1inherit setuptools
2require python-pyperf.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-statistics"
diff --git a/meta-python/recipes-devtools/python/python3-pyperf_1.6.1.bb b/meta-python/recipes-devtools/python/python3-pyperf_1.6.1.bb
new file mode 100644
index 000000000..5ba5efb05
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyperf_1.6.1.bb
@@ -0,0 +1,4 @@
1inherit setuptools3
2require python-pyperf.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-misc"